Installation fails on 10.13.x, 10.14.x (rc=-1908)

Discussions related to using VirtualBox on Mac OS X hosts.

Re: VirtualBox failed to install on Mac OS Catalina

Postby socratis » 22. Nov 2019, 09:37

Nov 21 11:01:48 dhcp-23-236 installd[881]: ./postflight: /Library/Application
Support/VirtualBox/VBoxDrv.kext failed to load - (libkern/kext) system policy prevents
; check the system/kernel logs for errors or try kextutil(8).

@psych, svenyonson
Merging your thread with the prominent thread dealing with the issue. Read it from the beginning...
Do NOT send me Personal Messages (PMs) for troubleshooting, they are simply deleted.
Do NOT reply with the "QUOTE" button, please use the "POST REPLY", at the bottom of the form.
If you obfuscate any information requested, I will obfuscate my response. These are virtual UUIDs, not real ones.
Site Moderator
Posts: 27690
Joined: 22. Oct 2010, 11:03
Location: Greece
Primary OS: Mac OS X other
VBox Version: PUEL
Guest OSses: Win(*>98), Linux*, OSX>10.5

Error installing Kali in VirtualBox (VERR_NOT_SUPPORTED)

Postby agricolaparra » 13. Jan 2020, 10:05

Hi everyone

I am trying to make a virtual machine with Kali in VirtualBox, but I get the following error when starting the machine:
Failed to open disk image file / Users / miguelito / Various Programs / kali-linux-2019.4-vbox-amd64.ova.

Could not get the storage format of the medium '/ Users / miguelito / Various Programs / kali-linux-2019.4-vbox-amd64.ova' (VERR_NOT_SUPPORTED).

Result code: VBOX_E_IPRT_ERROR (0x80BB0005)
Component: MediumWrap
Interface: IMedium {ad47ad09-787b-44ab-b343-a082a3f2dfb1}
Receiver: IVirtualBox {d0a0163f-e254-4e5b-a1f2-011cf991c38d}
RC receiver: VBOX_E_OBJECT_NOT_FOUND (0x80BB0001)

The image is downloaded as follows:

Can you help me and tell me what I am doing wrong?
Thank you
Posts: 1
Joined: 11. Jan 2020, 18:25

Re: Installation fails on 10.13.x, 10.14.x (rc=-1908)

Postby buggs1a » 15. Jan 2020, 23:12

Install fails on Mac OS 10.15.x
Posts: 5
Joined: 21. May 2011, 12:36
Primary OS: Mac OS X Leopard
VBox Version: OSE other
Guest OSses: windows xp pro

Re: Installation fails on 10.13.x, 10.14.x (rc=-1908)

Postby Nishu » 15. Mar 2020, 18:49

:D :D :D :D Working Fine
I found a useful link and working fine
So step is 1st install your virtual box let it be failed and exit.
oose “Security & Privacy” and go to the ‘General’ tab within the Security preference panel, then click the lock button and enter the administrator password
At the bottom of the Security General section, look for the message stating “System software from developer ‘Oracle America, Inc’ was blocked from loading” and click the “Allow” button
again run the setup you will get success
Posts: 2
Joined: 15. Mar 2020, 18:43

Re: Installation fails on 10.13.x, 10.14.x (rc=-1908)

Postby camvirt » 23. Mar 2020, 10:03

On My Mac running 10.13.6 I get the message "the installer encountered an error that caused the installation to fail" and my log has "org.virtualbox.kext.VBoxNetAdp failed security checks; failing."

My security & privacy panel has no indication of a kext being installed and has no allow option. Any suggsstions?
Posts: 5
Joined: 25. Mar 2019, 01:14

Re: Installation fails on 10.13.x, 10.14.x (rc=-1908)

Postby CosmonautMonkey » 6. Apr 2020, 21:08

VB 6.0 keeps crashing (MacBook Pro host running OSX 12.6) whenever I try to open the guest Windows 10 machine I created. This is an improvement, as it previously kept telling me I had to re-install Windows 10 as though I had never done that before. But still, it crashes every time now and makes my whole computer crash with it. The Windows logo appears in the middle of the screen, the pinwheel starts turning, but then almost instantly freezes and everything just becomes really, really slow until I can't do anything. What gives? Any thoughts?
Posts: 1
Joined: 6. Apr 2020, 20:28

Re: Installation fails on 10.13.x, 10.14.x (rc=-1908)

Postby jjmm » 27. May 2020, 09:34

OS: macOS Catalina (10.15.4)
virtualBox: 6.1.8 r137981 (Qt5.6.3)
Hardware: Macbook Pro Retina 13-inch late 2013, Memory 8GB, Processor 2,6 GHz Dual-Core Intel Core i5

I received an error saying "installation failed".

It would be a fix if instead of the message "installation failed" you give us, macOS users the message "Installation failed, go to the System Preferences » Security » General, and "Allow Oracle to install" and then Retry the installation" or another message like this. Other programs do the same.

Note: Now I have to lear how to work with Virtual Box.

Many thanks,
Posts: 1
Joined: 27. May 2020, 09:25

Re: Installation fails on 10.13.x, 10.14.x (rc=-1908)

Postby multiOS » 27. May 2020, 13:15


The action you described shouldn't be necessary any longer because Oracle is an Apple "identified developer", but the default security setting in MacOS 10.15 (Catalina) is only to allow installations from the AppStore. See Apple's guidance for the action users need to take to allow installations from identified developers: ... /mac/10.15

No 'fix' should be necessary for any software from identified developers if the Apple Guide is followed.
Posts: 459
Joined: 14. Sep 2019, 16:51
Location: United Kingdom
Primary OS: Mac OS X other
VBox Version: PUEL
Guest OSses: Windows 10Pro, 7

Re: Installation fails on 10.13.x, 10.14.x (rc=-1908)

Postby TenthDoctor » 3. Jun 2020, 14:20

I am running Catalina as well and received the same error. I already had changed my security settings to allow for apps outside the App Store. It still fails. No idea why. I earlier had also approved files from Oracle.
Posts: 3
Joined: 3. Jun 2020, 00:44

Re: Installation fails on 10.13.x, 10.14.x (rc=-1908)

Postby Toyosi04 » 9. Sep 2020, 09:33

Hi, I'm trying to install Lubuntu on VirtualBox. This is the error message I received:

[6.278342] [drm:vmw_host_log [vmwgfx]] *ERROR* Failed to send log
[6.279473] [drm:vmw_host_log [vmwgfx]] *ERROR* Failed to send log
Posts: 2
Joined: 9. Sep 2020, 09:09

Re: Installation fails on 10.13.x, 10.14.x (rc=-1908)

Postby ptram » 25. Sep 2020, 20:13

I have the same error with Mac High Sierra, after trying to install VB 6.1.14.

I tried any workaround suggested (boot in recovery mode and authorize the extensions, uninstall VB and install an older version) but it still doesn't work.

EDIT: I find the same issue with VB 6.0.24.

Posts: 75
Joined: 10. Dec 2008, 18:58

Re: Installation fails on 10.13.x, 10.14.x (rc=-1908)

Postby ptram » 30. Sep 2020, 11:26


Since I don't see reactions to my reports about not being able to install VB on High Sierra (10.13.6), please let me ask this directly: is VB currently supported on High Sierra?

Posts: 75
Joined: 10. Dec 2008, 18:58

Re: Installation fails on 10.13.x, 10.14.x (rc=-1908)

Postby ptram » 6. Oct 2020, 16:35

I tried again, after running the .tool and doing some other old file cleaning. No success. This is the detailed log. High Sierra (10.13.6), Oracle allowed from the Terminal.

The Extension Pack appears to be installed with no issues.

(1.89 KiB) Downloaded 8 times
Posts: 75
Joined: 10. Dec 2008, 18:58

Re: Installation fails on 10.13.x, 10.14.x (rc=-1908)

Postby ptram » 17. Oct 2020, 01:50

I could solve my issue with installation failing, by reinstalling High Sierra.

After a backup, I rebooted while keeping Cmd-R pressed. I then chose to reinstall the OS.

When done, the VB installer worked fine. Reinstalling probably reset some OS file permission.

Posts: 75
Joined: 10. Dec 2008, 18:58

Re: Installation fails on 10.13.x, 10.14.x (rc=-1908)

Postby mfurlanetto » 28. Oct 2020, 15:10

Hi Everyone,

I'm sorry to resume this thread, but every solution proposed here did not work for me.

My situation is like this:
I had MacOs HighSierra with VB 6.1.14 working.
Last week I updated to Mojave, VB still working fine.
Then the mistake: I tried to update VB to 6.1.16 with the result of failed update and corruption of 6.1.14 version.

I tried with fully removing the previous files (found some directories not cleaned), reinstall, uncountable reboots, entering in recovery mode, and so on, but I can't get the OS to show the "allow" button in Security tab.
So I am here asking for help.

Here is the files you asked for in the first messages of the thread.

(27.13 KiB) Downloaded 6 times
Posts: 2
Joined: 28. Oct 2020, 12:26


Return to VirtualBox on Mac OS X Hosts

Who is online

Users browsing this forum: No registered users and 10 guests