[Solved] Seamless mode broken (ver. 5.1.10 and greater) (#16246)

Discussions related to using VirtualBox on Mac OS X hosts.

[Solved] Seamless mode broken (ver. 5.1.10 and greater) (#16246)

Postby z3rodivide » 20. Dec 2016, 22:36


[ModEdit, related ticket #16246: In seamless mode, mouse events do not reach host windows visible behind the VM -> fixed in 5.1.28]

Hello everybody.

I am finding issues with seamless mode in version 5.1.10 (r112026) :
the guest desktop appears transparent (as it should) but it is impossibile to inteact with icons on desktop or with other hosts application
(e.g. you can see every windows of other OSX applications but they don't respond to mouse clicks and don't get focused).

Tested with guests : Windows XP, Windows 7, debian linux , on two different Macs
tested with Mac OS Sierra ve 10.12.1 and 10.12.2

Downgrading back to VirtualBox 5.1.8 everything works fine.

See attached log file

Thanks :)

------
EDIT
solved in 5.1.28
------
Attachments
VBox.log.zip
vbox log file
(24.36 KiB) Downloaded 4 times
Last edited by socratis on 19. Sep 2017, 15:34, edited 6 times in total.
Reason: Added ticket related information.
z3rodivide
 
Posts: 17
Joined: 25. Oct 2013, 16:23
Primary OS: Mac OS X other
VBox Version: PUEL
Guest OSses: Win XP, Win7, Linux

Re: Seamless mode broken (ver. 5.1.10)

Postby brycesteiner » 20. Dec 2016, 22:50

same thing here.
brycesteiner
 
Posts: 90
Joined: 7. Nov 2008, 16:04

Re: Seamless mode broken (ver. 5.1.10)

Postby socratis » 20. Dec 2016, 23:59

5.1.12 was just released and it contains a couple of fixes related to "Seamless". Could you give it a try?
EDIT:
https://www.virtualbox.org/ticket/15837 This is a ticket that doesn't apply.
If you obfuscate any information requested, I will obfuscate my response. These are virtual UUIDs, not real ones.
Do NOT reply with the "QUOTE" button, please use the "POST REPLY", at the bottom of the form.
socratis
Site Moderator
 
Posts: 12693
Joined: 22. Oct 2010, 11:03
Location: Greece
Primary OS: Mac OS X other
VBox Version: PUEL
Guest OSses: Win(*>98), Linux*, OSX>10.5

Re: Seamless mode broken (ver. 5.1.10 / 5.1.12)

Postby z3rodivide » 21. Dec 2016, 01:03

Thanks socratis for your answer, just tested 5.1.12, unfortunately there's no change, still have the same problem.

About the ticket you linked, if I understand it correctly, it regards problems while resizing guest applications, while I'm experiencing problems with host applications (and host desktop)
z3rodivide
 
Posts: 17
Joined: 25. Oct 2013, 16:23
Primary OS: Mac OS X other
VBox Version: PUEL
Guest OSses: Win XP, Win7, Linux

Re: Seamless mode broken (ver. 5.1.10 / 5.1.12)

Postby socratis » 21. Dec 2016, 01:07

Not only that, but if you look at the changelog, it's for X11 hosts only. Sorry, false alarm... :oops:
If you obfuscate any information requested, I will obfuscate my response. These are virtual UUIDs, not real ones.
Do NOT reply with the "QUOTE" button, please use the "POST REPLY", at the bottom of the form.
socratis
Site Moderator
 
Posts: 12693
Joined: 22. Oct 2010, 11:03
Location: Greece
Primary OS: Mac OS X other
VBox Version: PUEL
Guest OSses: Win(*>98), Linux*, OSX>10.5

Re: Seamless mode broken (ver. 5.1.10 / 5.1.12)

Postby brycesteiner » 21. Dec 2016, 18:06

Same here
brycesteiner
 
Posts: 90
Joined: 7. Nov 2008, 16:04

Seamless Mode Freezes Mac Apps

Postby Andrew470 » 21. Dec 2016, 18:37

I've got a Mac Mini running El Capitan 10.11.6 and VirtualBox 5.1.12 that has an issue with seamless mode. When running seamless mode, you can't click on any Mac app that's running on a screen that has seamless mode. If you right click, it brings up the Windows 7 desktop context menu. It seems like seamless mode is acting like Windowed mode, but I'm not finding anything online in searching for this issue. Any help would be appreciated as this is really interfering with operations.

I would include a screenshot, but the image is too big to attach, and I can't add links yet.
Andrew470
 
Posts: 2
Joined: 21. Dec 2016, 18:21

Re: Seamless mode broken (ver. 5.1.10 / 5.1.12)

Postby socratis » 21. Dec 2016, 18:40

Andrew470 wrote:I'm not finding anything online in searching for this issue

It was the thread just before yours. Which is why I merged your post to the existing one. I'm not sure what you searched for...
If you obfuscate any information requested, I will obfuscate my response. These are virtual UUIDs, not real ones.
Do NOT reply with the "QUOTE" button, please use the "POST REPLY", at the bottom of the form.
socratis
Site Moderator
 
Posts: 12693
Joined: 22. Oct 2010, 11:03
Location: Greece
Primary OS: Mac OS X other
VBox Version: PUEL
Guest OSses: Win(*>98), Linux*, OSX>10.5

Re: Seamless Mode Freezes Mac Apps

Postby z3rodivide » 21. Dec 2016, 19:19

Andrew470 wrote: Any help would be appreciated as this is really interfering with operations.

actually the only "workaround" I found is to downgrade back to 5.1.8 which is working fine with seamless mode
z3rodivide
 
Posts: 17
Joined: 25. Oct 2013, 16:23
Primary OS: Mac OS X other
VBox Version: PUEL
Guest OSses: Win XP, Win7, Linux

Re: Seamless mode broken (ver. 5.1.10 / 5.1.12)

Postby socratis » 21. Dec 2016, 19:37

OK, I tested with 5.1.8 (works), 5.1.10 and 5.1.12 (fails). I searched for and I found a bug report: #16246 - In seamless mode, mouse events do not reach host windows visible behind the VM. I already added my vote. I suggest you do the same...
If you obfuscate any information requested, I will obfuscate my response. These are virtual UUIDs, not real ones.
Do NOT reply with the "QUOTE" button, please use the "POST REPLY", at the bottom of the form.
socratis
Site Moderator
 
Posts: 12693
Joined: 22. Oct 2010, 11:03
Location: Greece
Primary OS: Mac OS X other
VBox Version: PUEL
Guest OSses: Win(*>98), Linux*, OSX>10.5

Re: Seamless mode broken (ver. 5.1.10 / 5.1.12)

Postby z3rodivide » 21. Dec 2016, 20:08

Thanks socratis :)
I just added my comment
z3rodivide
 
Posts: 17
Joined: 25. Oct 2013, 16:23
Primary OS: Mac OS X other
VBox Version: PUEL
Guest OSses: Win XP, Win7, Linux

Re: Seamless mode broken (ver. 5.1.10 / 5.1.12)

Postby Andrew470 » 22. Dec 2016, 16:41

socratis wrote:
Andrew470 wrote:I'm not finding anything online in searching for this issue

It was the thread just before yours. Which is why I merged your post to the existing one. I'm not sure what you searched for...

I searched on Google, not the forum itself, which is probably part of the reason I didn't find anything. The other reason was probably that I was trying to be more specific than seamless mode broken, so I searched for 'vitrualbox mac seamless mode not giving focus to mac apps' or 'virtualbox mac seamless mode guest os keeps focus'. Either way, thanks for the assistance.

z3rodivide wrote:actually the only "workaround" I found is to downgrade back to 5.1.8 which is working fine with seamless mode

That's what we get for trying to update to the latest.
Andrew470
 
Posts: 2
Joined: 21. Dec 2016, 18:21

Re: Seamless mode broken (ver. 5.1.10 / 5.1.12)

Postby knesmith » 29. Dec 2016, 22:53

I am having the same problem. To ensure this wasn't a MAC display driver issue, I switched between OS X Default Graphics Driver and the NVidia Web Driver. Neither driver changes the seamless mode focus problem under VirtualBox 5.1.10 or 5.1.12.
knesmith
 
Posts: 1
Joined: 29. Dec 2016, 22:49

Re: Seamless mode broken (ver. 5.1.10 / 5.1.12)

Postby socratis » 29. Dec 2016, 23:18

knesmith wrote:I switched between OS X Default Graphics Driver and the NVidia Web Driver
And how exactly did you do that, if you don't mind me asking? And what Nvidia web driver are you referring to? You're not relying on the OSX provided ones?
If you obfuscate any information requested, I will obfuscate my response. These are virtual UUIDs, not real ones.
Do NOT reply with the "QUOTE" button, please use the "POST REPLY", at the bottom of the form.
socratis
Site Moderator
 
Posts: 12693
Joined: 22. Oct 2010, 11:03
Location: Greece
Primary OS: Mac OS X other
VBox Version: PUEL
Guest OSses: Win(*>98), Linux*, OSX>10.5

Re: Seamless mode broken (ver. 5.1.10 / 5.1.12)

Postby z3rodivide » 19. Jan 2017, 00:42

Hi Everybody,
just tested version 5.1.14 r112924 (Qt5.6.2) still the same problem :(
z3rodivide
 
Posts: 17
Joined: 25. Oct 2013, 16:23
Primary OS: Mac OS X other
VBox Version: PUEL
Guest OSses: Win XP, Win7, Linux

Next

Return to VirtualBox on Mac OS X Hosts

Who is online

Users browsing this forum: No registered users and 15 guests