usb flash drive problem

Discussions related to using VirtualBox on Mac OS X hosts.

usb flash drive problem

Postby killermony » 21. Jul 2008, 06:47

mac os x host windows xp guest. i cannot seem to get the usb drives to work. under VM devices they show up but are greyed out and i cannot connect. i searched alot and it seems some people have gotten them to work but also some have not. so any advice thanks in advance.
killermony
 
Posts: 4
Joined: 11. Jul 2008, 23:21

Postby jaybee » 22. Jul 2008, 21:35

I'm very new at this, but I had the same problem. I found that if I "eject" the flash drive in the Mac window (still leaving it plugged in, of course) it becomes available to Windows.
jaybee
 
Posts: 1
Joined: 22. Jul 2008, 21:27

USB hairpulling

Postby Baron » 28. Jul 2008, 18:37

I'm liking Virtualbox but I'm tearing my hair out trying to get a USB flash drive up and running.

Guest is XP SP3 on a Mac Leopard Host.

Guest Additions installed.

USB Controller Enabled. And every combination of the USB Setting page tried out. User manual read, re-read and re-read. I've spent almost a day trawling through forums for a solution.

I think I must be stupid or unlucky.

The closet that I have got is to unmount my USB flash drive from the host, start up the VM. On the occasions I can get the USB drive to appear black (not greyed out) when I click it in the available USB devices tab I get the message:

Failed to Attach Unknown device
Callee RC:
0x80004005

Then all USB devices disappear from this tab. It looks as if there is a hitch transferring the product ID and revision over to the virtual machine maybe?

Any help would be massively appreciated. Many Thanks.
Baron
 
Posts: 1
Joined: 28. Jul 2008, 18:19

Postby dsluga » 11. Aug 2008, 16:47

Here is what I did that seemed to work just fine:

1) connect the USB drive and get to the settings for your Virtual Machine (remember that you cannot access these settings with the VM it running)

2) Go to USB and setup a filter for the device: With it connected this is really easy. Just click USB on the left and then the plus sign. Select the device that is not playing nice (for me it was called <something> Atapi-6 bridge). You'll see that the information below is populated. Leave remote to NO and CLICK OK. I left "Enable 2.0 support" checked also.

3) boot the VM. After everything is up just unplug and replug the device and VB will grab it before OS X does.

This worked great for me - I hope it works for you too.
dsluga
 
Posts: 3
Joined: 11. Aug 2008, 16:41

Postby E » 21. Aug 2008, 18:48

My situation is identical to Baron's in post. I have XP SP3 installed on an OS X host. Guest additions are installed. I have done everything recommended and tried every combination of ejecting/plugging a USB thumb drive, but I cannot get the XP guess to recognize it. I have also tried this with and witout USB filtering.

Like Baron, I can come close at times because I can see the USB device listed on the VM guest window, but I can never get it mounted successfully. When I try to select it, I get the same callee RC every time. My guess is the host is causing some kind of conflict. The host grabs the USB device first every time, but even when I eject from the host, the guest still can't manage to grab it.

Could this be an issue with SP3 in XP? For those of you that say it works for you, are you running SP3?

By the way, this is my first post, and I want to give a HUGE thanks to all the developers that have volunteered their time on this project. It is truly wonderful! Thanks!!!
E
 
Posts: 10
Joined: 21. Aug 2008, 18:35

USB Drives... and other "Volumes" -- Getting Conne

Postby amagine » 22. Aug 2008, 00:15

First off, no one is stupid here, I have read words of stupidity in my time, and I do not see any here.

I can also concur that mounting USB flash drives on your GUEST is a very tricky endeavor, and for what I need USB flash drives for, unnecessary.

My Workaround for this time sucking issue:

- Add a new Shared Folder.

- Type in the Folder Path field: /Volumes

- Give it a name... ie. "Drives attached to my Mac..." (I named mine "Mac Volumes"

- Open a Windows Explorer Window and select from the Tools menu: Map Network Drive...

- Select a Drive Letter... and then select your shared folder from My Network Places / Entire Network / VirtualBox Shared Folders / \\VBOXSVR\name_of_your_shared_Volumes_folder

Whenever a 'Volume' (drive) is attached to your Mac Host, it should now appear in this newly mapped drive and become nicely accessible to your XP Guest

I do not have any terrible problems getting my USB drives to Mount though on my XP Guest, just that it ends up being a waste of time and extra steps each time I need to access a USB Drive.

Here is what I do in these following steps, and yes it does not always work, sometimes it helps to shake the rubber chicken and call on help from the 'Virtual' gods...

- Restart XP Guest
- Attach USB Drive (OS X Host will 'steal it and Mount it'
- Eject USB Drive from OS X Host
- While in 'Windowed' Mode, *click* USB icon , bottom right.
- Select your USB Drive... Wait... (Shake the rubber chicken)
- If you are lucky, the Found new Hardware bubble with pop up, and in a few more seconds.. minutes? you'll see your USB Drive mounted.

IF this does not work... Re-install Guest Additions, and reboot.

Try again... (don't forget the rubber chicken)

If you are still unsuccessful try my workaround, I don't have any problems with it.

Good luck, and if you need to know where to pick up a rubber chicken contact me...


In my SIG your can see my XP guest Setup on my Mac Host that is working well for me.
amagine
Volunteer
 
Posts: 177
Joined: 28. Jul 2008, 19:52

Postby E » 22. Aug 2008, 00:26

amagine,

Thanks for the reply. The workaround you described is exactly what I was about to attempt next (map a shared drive in Windows Explorer in XP). I was planning to find an apple script or some process that would automate copying data of the USB flash drive in OS X to the shared folder, where it would be easily accessible in the XP guest.

I still may try this solution, as I think it represents a more reliable solution long-term (since I use USB flash drives a great deal).

All that said, I did find some resolution to my problem a short while ago. I decided to try a different brand of USB flash drive (Kingston). I had no trouble getting the XP guest to see the Kingston. Here's what I did:

1) With the XP guest powered off, I set a filter for the Kingston USB flash drive.

2) I booted the XP guest, inserted the Kingston, and boom. . . it worked.

Apparently brand makes a difference here because I had tried every conceivable permutation of the above steps with the other USB flash drive (Attache brand). Shaking that chicken doesn't hurt one's cause either.
E
 
Posts: 10
Joined: 21. Aug 2008, 18:35

Different Flash... Different Results..

Postby amagine » 22. Aug 2008, 04:47

Interesting that you receive different results from different drive makers.

Are they formated the same?

I forgot to mention that I have not tried any other flash drives than the ones I have formated FAT32, as Windows can not 'See/Read/Write' Mac OS Extended without special utilities.

If it is not the Formating, I wonder if it has something to do with the 'un-mounting' mechanism within the flash hardware?

*shrug*

Good to hear you managed to get your Kingston going.
I was planning to find an apple script or some process that would automate copying data of the USB flash drive in OS X to the shared folder, where it would be easily accessible in the XP guest.


I suppose this would work. Could make a little ditto shell script (or rsync although it is slower) that resides on the usb drive, wrap it into an Applescript App and put the rubber chicken in safe...

good luck
amagine
Volunteer
 
Posts: 177
Joined: 28. Jul 2008, 19:52

Postby jfranklin » 6. Feb 2009, 11:15

E wrote:Apparently brand makes a difference here because I had tried every conceivable permutation of the above steps with the other USB flash drive (Attache brand). Shaking that chicken doesn't hurt one's cause either.


I found, like you, that the Attache brand flash drive I have (4GB) would not mount in my XP guest. Leopard would keep grabbing it. I tried a SanDisk U3 Titanium I had laying around, and that worked perfectly without even having to setup a filter for it. Just unmounted from Leopard, selected it from the USB device icon, and within seconds it was ready to go.

I have a few other maker drives laying around... I'm tempted to see which others do and don't work.
jfranklin
 
Posts: 1
Joined: 6. Feb 2009, 11:09

Link to previous (similar) post

Postby wplj42 » 6. Feb 2009, 19:34

I don't know if this will help. Maybe this previous thread was different. Below is the title of the thread and its link.

USB detected but not visible in My Computer

http://forums.virtualbox.org/viewtopic. ... highlight=
wplj42
 
Posts: 33
Joined: 9. Jan 2009, 01:05

Postby Pikaplhu » 6. Feb 2009, 22:40

I have the same problem to, do I need to run a windows program from a USB that will mount as a CD, it ceeps remounting, annybody anny Idee howe I can prevent that ?
Pikaplhu
 
Posts: 2
Joined: 6. Feb 2009, 22:33

Re: usb flash drive problem

Postby wrkbear » 22. Mar 2009, 03:22

The work around for the flash drive posted by amagene also works for Ubuntu Linux. In this case, the shared folder is /media where the flash drive gets mounted in Ubuntu. I can't say for other brands of linux as I'm not sure where they mount the flash drives, but look for the folder where the flash drive is mounted in linux and designate that as a shared folder in VirtualBox. (Be sure not to list it in the USB filters as this only complicates the process.)

This just gave me a real fast solution to a long term problem. Thanks amagene.
wrkbear
 
Posts: 5
Joined: 13. Nov 2008, 05:05

Re: usb flash drive problem

Postby Schnotty » 14. Aug 2009, 02:41

Hi all,

Following applies to VBox v3.0.2, with a Windows XP VM on Mac OS-X 10.4.11.

Amagine's solution is elegant and works nicely (mapping a Windows drive to the /Volumes shared folder). I did the same thing first by adding a Network Place, but it operates quite slowly.

What I've now found is to run VBox, but NOT launch your VM yet. Select the VM, go to Settings and go to USB Devices, and make sure USB Devices and USB 2.0 are switched ON. If you have ANY existing USB Flash Drives listed, kill all but one of them. Then EDIT that iyem, and name it just plain vanilla 'USB Flash Drive' - i.e. remove any brand naming etc. Then DELETE any data relating to Vendow, Model number etc in the properties pane for the drive. Click OK, and OK again.

If you DON'T have any USB drives listed, insert drive now and wait for it to mount on the Mac Desktop. Then click the ADD USB Device icon, and VBox should add the USB Flash Drive. Then rename it as above, and delete any 'individuality' vendor data etc as above.

Eject the drive. Start your VM, and once it's running AND HAS FOCUS! then insert your USB drive. Watch the USB icon in the status bar and it should flash and mount the drive etc.

Seems to work for me, but I have still seen a couple of drives that just won't mount at all in the VM. When this happens, mount the drive on the Mac Desktop, and then use Amagine's solution to access the USB drive as a Volume via a shared folder in VBox.

That always seems to work as a good backup.

:wink:
Schnotty
 
Posts: 3
Joined: 12. Aug 2009, 08:38
Primary OS: Mac OS X other
VBox Version: PUEL
Guest OSses: Windows XP

Re: usb flash drive problem

Postby m11091940 » 10. Oct 2009, 17:35

Ejecting the USB drive on the Mac side but leaving it plugged in worked perfectly for me as it was then grabbed by Virtual Box. Until then, it did not show up. I am on a MacBook Pro using Snow Leopard 10.6.1. Using Virtual Box 3.0.8 and Vista Basic.
m11091940
 
Posts: 1
Joined: 10. Oct 2009, 17:30
Primary OS: Mac OS X other
VBox Version: OSE Debian
Guest OSses: Vista Basic

Re: usb flash drive problem

Postby Mr_Tux » 18. Dec 2013, 21:40

The solution for me was to shut down the guest, enable USB 2.0 (EHCI) Controller, and start the VM again using USB-filter as described above.

I'm using Mac 10.8, VirtualBox 4.3.4, Guest: Windows Server 2008 R2.

And since this is my first post I must say: Thank you all VirtualBox developers for this excellent software! :D
Mr_Tux
 
Posts: 1
Joined: 18. Dec 2013, 21:18


Return to VirtualBox on Mac OS X Hosts

Who is online

Users browsing this forum: No registered users and 33 guests