Cannot boot Windows anymore: VERR_VM_DRIVER_VERSION_MISMATCH

Discussions related to using VirtualBox on Mac OS X hosts.

Cannot boot Windows anymore: VERR_VM_DRIVER_VERSION_MISMATCH

Postby passij » 3. Jun 2008, 17:58

Hi,

i'm running VirtualBox on MacOSX 10.5.3. After upgrading from VirtualBox 1.5 to 1.6 I receive the following Error-Message after trying to boot Windows XP:

The VirtualBox support driver which is running is from a different version of VirtualBox. You can correct this by stopping all running instances of VirtualBox and reinstalling the software.
VBox status code: -1912 (VERR_VM_DRIVER_VERSION_MISMATCH).

Fehlercode: 0x80004005
Komponente: Console
Interface: IConsole {d5a1cbda-f5d7-4824-9afe-d640c94c7dcf}


If I reinstall VirtualBox, Windows XP starts the normal way. But I have to reinstall it nearly every time I want to boot Windows. Do you have a solution for my problem?

Thanks in advance!
passij
passij
 
Posts: 5
Joined: 3. Jun 2008, 17:36

Postby aquarius » 3. Jun 2008, 23:43

Does the error occur at guest boot time or when you start up a "paused" or "running" windows guest in the upgraded virtual machine?

Just some wild guesses to try out (in order of increasing hassle):

- Try switching IDE controller settings for the virtual machine. (Could be that your guest assumes PIIX3 and your upgraded virtualbox insists on PIIX4 ...)

- Did you ever reboot your Mac host after upgrading? I don't know if installation handles this properly on Macs but virtualbox must load a "startup module" on boot time. (perhaps the old one is still active, hence version mismatch.)

- Did you power down your windows guest properly before you upgraded virtualbox? (Windows likes that a lot - believe me) If not, do so in a downgraded virtual box if nothing else helps.

That's all I can think of. Please answer which one helped - if any ...
And don't forget to update the guest additions as well.

Good luck!
P.S. rumours go that 1.6.2 is just around the corner - see http://forums.virtualbox.org/viewtopic.php?p=24703#24703
aquarius
 
Posts: 69
Joined: 3. Jun 2008, 22:35
Primary OS: Mac OS X other
VBox Version: PUEL
Guest OSses: MS Windows XP

Postby passij » 4. Jun 2008, 09:17

Thanks!
Does the error occur at guest boot time or when you start up a "paused" or "running" windows guest in the upgraded virtual machine?

The error occurs at guest boot time.
- Try switching IDE controller settings for the virtual machine. (Could be that your guest assumes PIIX3 and your upgraded virtualbox insists on PIIX4 ...)

I tried both controllers, none of them worked for me.
- Did you ever reboot your Mac host after upgrading? I don't know if installation handles this properly on Macs but virtualbox must load a "startup module" on boot time. (perhaps the old one is still active, hence version mismatch.)

Yes I reboot it nearly every day. But maybe I shouldn't do so because once Windows XP is running there are no more problems. I can shut down Windows and boot it again and again until I restart my Guest-System.

So nothing helps. But thank you very much!
passij
 
Posts: 5
Joined: 3. Jun 2008, 17:36

Postby passij » 5. Jun 2008, 12:38

Even after I completely reinstalled virtualbox and Windows XP I receive the same error message I posted above. Does anyone know a solution?

Thanks!
passij
 
Posts: 5
Joined: 3. Jun 2008, 17:36

Postby passij » 6. Jun 2008, 11:07

VirtualBox 1.6.2 works fine by now! Hopefully my problem is solved now.

And the old icon is back :P
passij
 
Posts: 5
Joined: 3. Jun 2008, 17:36

Postby passij » 8. Jun 2008, 09:39

Oh 1.6.2 didn't solve the problem but finally I got it!

An old VirtualBox driver still was in the "startupitems" directory. I deleted it and everything works fine.

Therefore I strongly recommend using the unistaller when upgrading virtualbox!
passij
 
Posts: 5
Joined: 3. Jun 2008, 17:36


Return to VirtualBox on Mac OS X Hosts

Who is online

Users browsing this forum: No registered users and 11 guests