Status of OSX on OSX

Discussions related to using VirtualBox on Mac OS X hosts.

Re: Status of OSX on OSX

Postby Riot Nrrrd™ » 7. Aug 2014, 18:38

If I disable the DVD-ROM virtual drive, it gets stuck on reboot in the EFI boot stage after accessing the hard drive:

efiboot.jpg
efiboot.jpg (100.14 KiB) Viewed 3769 times
Riot Nrrrd™
 
Posts: 34
Joined: 1. Apr 2012, 01:15

Re: Status of OSX on OSX

Postby ChipMcK » 8. Aug 2014, 01:12

Last year I tried to get Leopard and Snow Leopard into a Virtual Machine. I was frustrated.
I reverted to p2v of running system, with help of Paragon Virtual Disk Mounter Beta - Overview.
Zip, bam, task accomplished.
  • P2V ===> Physical-to-Virtual.
ChipMcK
Volunteer
 
Posts: 1096
Joined: 20. May 2009, 02:17
Location: U S of A
Primary OS: Mac OS X other
VBox Version: PUEL
Guest OSses: Windows, OSX

Re: Status of OSX on OSX

Postby socratis » 8. Aug 2014, 12:25

Riot Nrrrd™ wrote:it gets stuck on reboot in the EFI boot stage after accessing the hard drive

Where did you get your Yosemite from? How did you "massage" the script (anything but the path I mean)? Any step that's unusual or out of the ordinary? It seems like a misunderstanding in the boot process pointing to another (than expected) boot device. I've seen it once...
Do NOT send me Personal Messages (PMs) for troubleshooting, they are simply deleted.
Do NOT reply with the "QUOTE" button, please use the "POST REPLY", at the bottom of the form.
If you obfuscate any information requested, I will obfuscate my response. These are virtual UUIDs, not real ones.
socratis
Site Moderator
 
Posts: 27231
Joined: 22. Oct 2010, 11:03
Location: Greece
Primary OS: Mac OS X other
VBox Version: PUEL
Guest OSses: Win(*>98), Linux*, OSX>10.5

Re: Status of OSX on OSX

Postby rpmurray » 8. Aug 2014, 14:47

ChipMcK wrote:Last year I tried to get Leopard and Snow Leopard into a Virtual Machine. I was frustrated.
I reverted to p2v of running system ...
Zip, bam, task accomplished.

How did you create a p2v of Leopard (10.5) and Snow Leopard (10.6) when Paragon Virtual Disk Mounter only runs on Lion (10.7) and above?
rpmurray
Volunteer
 
Posts: 916
Joined: 3. Mar 2009, 00:29
Location: Between Heaven and Hell
Primary OS: Mac OS X other
VBox Version: PUEL
Guest OSses: Windows 7, Mac OS X (various flavors)

Re: Status of OSX on OSX

Postby ChipMcK » 8. Aug 2014, 15:17

rpmurray wrote:How did you create a p2v of Leopard (10.5) and Snow Leopard (10.6) when Paragon Virtual Disk Mounter only runs on Lion (10.7) and above?
I was running on Lion at the time. Duhh.

Lion takes approximately 15 GB of Hard Disk space. Apple has made Dual Boot is easy.
Last edited by ChipMcK on 8. Aug 2014, 15:29, edited 1 time in total.
ChipMcK
Volunteer
 
Posts: 1096
Joined: 20. May 2009, 02:17
Location: U S of A
Primary OS: Mac OS X other
VBox Version: PUEL
Guest OSses: Windows, OSX

Re: Status of OSX on OSX

Postby Riot Nrrrd™ » 8. Aug 2014, 15:21

socratis wrote:
Riot Nrrrd™ wrote:it gets stuck on reboot in the EFI boot stage after accessing the hard drive

Where did you get your Yosemite from? How did you "massage" the script (anything but the path I mean)? Any step that's unusual or out of the ordinary? It seems like a misunderstanding in the boot process pointing to another (than expected) boot device. I've seen it once...

I signed up for the Beta and downloaded it from the App Store.

I only massaged your script to change the path to the Beta and change the "/tmp" paths you had in it to point to my RAID volume as my SSD "/" partition doesn't have the 15 GB you said was needed for scratch space etc.

As for "It seems like a misunderstanding in the boot process pointing to another (than expected) boot device.", I have the HDD disk - a 40 GB "Normal (VDI)" Fixed size storage file - set as "SATA Port 0", which I would assume should've matched the "SATA(0,0)" path shown in my frozen-up last screen snapshot. Right?
Riot Nrrrd™
 
Posts: 34
Joined: 1. Apr 2012, 01:15

Re: Status of OSX on OSX

Postby Riot Nrrrd™ » 8. Aug 2014, 15:38

Hysterical. Just for grins, I fired up the VM again.

It's coming up this time. No idea why (or why it froze last time).

Whisky. Tango. Foxtrot.

Yosemite Beta inside VirtualBox.jpg
It works! Yosemite Beta running inside Virtual Box 4.3.14
Yosemite Beta inside VirtualBox.jpg (123.53 KiB) Viewed 3742 times
Riot Nrrrd™
 
Posts: 34
Joined: 1. Apr 2012, 01:15

Re: Status of OSX on OSX

Postby Riot Nrrrd™ » 8. Aug 2014, 16:00

Do I dare try installing the DP5 package over the Beta? Heh :D
Riot Nrrrd™
 
Posts: 34
Joined: 1. Apr 2012, 01:15

Re: Status of OSX on OSX

Postby loukingjr » 8. Aug 2014, 16:07

Riot Nrrrd™ wrote:Do I dare try installing the DP5 package over the Beta? Heh :D

I believe you have to install, DP1, DP2, DP3, etc. first.
OSX, Linux and Windows Hosts & Guests
There are three groups of people. Those that can count and those that can't.
loukingjr
Volunteer
 
Posts: 8827
Joined: 30. Apr 2009, 09:45
Primary OS: Mac OS X other
VBox Version: PUEL
Guest OSses: just about all that run

Re: Status of OSX on OSX

Postby Riot Nrrrd™ » 8. Aug 2014, 16:51

loukingjr wrote:
Riot Nrrrd™ wrote:Do I dare try installing the DP5 package over the Beta? Heh :D

I believe you have to install, DP1, DP2, DP3, etc. first.

O RLY? 8)

Yosemite DP5 inside VirtualBox.jpg
RLY!
Yosemite DP5 inside VirtualBox.jpg (124.66 KiB) Viewed 3737 times
Riot Nrrrd™
 
Posts: 34
Joined: 1. Apr 2012, 01:15

Re: Status of OSX on OSX

Postby loukingjr » 8. Aug 2014, 18:06

well you used to have to :lol:
OSX, Linux and Windows Hosts & Guests
There are three groups of people. Those that can count and those that can't.
loukingjr
Volunteer
 
Posts: 8827
Joined: 30. Apr 2009, 09:45
Primary OS: Mac OS X other
VBox Version: PUEL
Guest OSses: just about all that run

Re: Status of OSX on OSX

Postby socratis » 9. Aug 2014, 12:31

socratis wrote:It seems like a misunderstanding in the boot process pointing to another (than expected) boot device. I've seen it once...

The misunderstanding was referring to the OS, not you. And the once meant that after reboot it worked, like your case. I should have clarified that :(
Do NOT send me Personal Messages (PMs) for troubleshooting, they are simply deleted.
Do NOT reply with the "QUOTE" button, please use the "POST REPLY", at the bottom of the form.
If you obfuscate any information requested, I will obfuscate my response. These are virtual UUIDs, not real ones.
socratis
Site Moderator
 
Posts: 27231
Joined: 22. Oct 2010, 11:03
Location: Greece
Primary OS: Mac OS X other
VBox Version: PUEL
Guest OSses: Win(*>98), Linux*, OSX>10.5

Re: Status of OSX on OSX

Postby Riot Nrrrd™ » 9. Aug 2014, 12:38

socratis wrote:
socratis wrote:It seems like a misunderstanding in the boot process pointing to another (than expected) boot device. I've seen it once...

The misunderstanding was referring to the OS, not you. And the once meant that after reboot it worked, like your case. I should have clarified that :(

I knew what you meant. I am still baffled, however - I have no idea why it just stopped after the EFI boot the first time, and yet it's been fine ever since then (have restarted about 3 times since). :o
Riot Nrrrd™
 
Posts: 34
Joined: 1. Apr 2012, 01:15

Re: Status of OSX on OSX

Postby socratis » 9. Aug 2014, 13:11

Hey, it's a Mac, you're not supposed to know everything, otherwise you'd be running Slackware without the X-server :D
Do NOT send me Personal Messages (PMs) for troubleshooting, they are simply deleted.
Do NOT reply with the "QUOTE" button, please use the "POST REPLY", at the bottom of the form.
If you obfuscate any information requested, I will obfuscate my response. These are virtual UUIDs, not real ones.
socratis
Site Moderator
 
Posts: 27231
Joined: 22. Oct 2010, 11:03
Location: Greece
Primary OS: Mac OS X other
VBox Version: PUEL
Guest OSses: Win(*>98), Linux*, OSX>10.5

Snow Leopard on Snow Leopard

Postby beefpitas » 30. Aug 2014, 18:03

I'm trying to install a Snow Leopard guest. I have both a SL host and a Lion host, however it has been somewhat more fruitful on the SL host. I have tried several different configurations with mixed results. The first is that the chipset ICH9 results with the "Still waiting for boot device" message, and the PIIX3 results in a kernel panic. The latter of which I have taken a screenshot, and uploaded the log file.
It is the same SL installer I used to update the machine. I have been unable to make any of the modifications via Vboxmanage however (changing the UUID and assigning a serial number), because it says it can not find a virtual machine matching the name "<SNOWY>", even though there is. Editing the .vbox file directly didn't work either for me.
Any help would be terrific.
Attachments
VBoxSVC.log
(3.19 KiB) Downloaded 28 times
SNOWY KERNEL PANIC.jpg
SNOWY KERNEL PANIC.jpg (123.06 KiB) Viewed 3646 times
beefpitas
 
Posts: 2
Joined: 7. Mar 2013, 19:02

PreviousNext

Return to VirtualBox on Mac OS X Hosts

Who is online

Users browsing this forum: No registered users and 24 guests