Page 1 of 1

CD/DVD drive access

PostPosted: 9. Feb 2014, 01:17
by Mike9586
I'm running the latest version of VirtualBox on my MacBook Air (2013 model) on OS X 10.9 Maverick however I cannot seem to use my USB DVD drive with VirtualBox, it just doesn't seem to recognise it at all.

If I add a CD/DVD drive to a virtual machine it asks me if I want to use a virtual disk image or Live CD/DVD. Initially I thought the 'Live CD/DVD' option would use the DVD drive however whenever I start up a virtual machine to install an OS, it cannot detect a CD drive. If I go into the Drives options menu, it allows me to select a virtual disk image for the CD drive but there is no mention of my CD/DVD drive at all.

If I insert a disc it appears fine on my Mac desktop and I can create a DMG image using Disk Utility which I have done with an old Windows 98 CD but I want to install Windows XP without having to go through the hassle of converting it to a DMG image first.

Can anyone advise on what could be the problem? My USB drive is a Samsung Slim CD/DVD/Blu-Ray drive I purchased last year and is plugged directly into my Mac.

Re: CD/DVD drive access

PostPosted: 11. Feb 2014, 16:47
by noteirak
You can access your host drives the same way you add an ISO/Dmg in the VM options, see attached screenshot.

Re: CD/DVD drive access

PostPosted: 11. Feb 2014, 17:39
by mpack
I don't use a MacBook Air - does it have a built in CD drive or are you using an external one? People in the past have had trouble using USB CD/DVD drives in VMs on Mac hosts, though whether those reports are legit or not I have no way to know.

Re: CD/DVD drive access

PostPosted: 13. Feb 2014, 16:20
by Mike9586
Thanks for your reply. My MacBook Air has no internal optical disc drive so the one I use is a USB drive, I've attached a screenshot of what VirtualBox displays on my system. When I took the screenshot there was a disc in the drive and Mac OS X had mounted it as normal but it is not displayed on the menu. I've also tried the 'Live CD/DVD' option without success.

CD.jpg
CD.jpg (84.52 KiB) Viewed 104094 times


I have however managed to get the disc drive to work in my Windows XP VM by sharing the Mac's hidden 'Volumes' folder in VirtualBox as E: in Windows, I can then go into the folder, select the disc drive and it seems to work ok from there.

This method doesn't work for my Windows 98 VM though as GuestAdditions are not compatible so I cannot setup a shared folder for Windows 98 in VirtualBox.

Re: CD/DVD drive access

PostPosted: 13. Feb 2014, 17:18
by socratis
You don't have a physical CD. You have a USB CD. Even if you get it to show up as a USB CD in the virtual machine (with filters), I'm not sure it will boot from that. VirtualBox doesn't support USB boot. Your best bet is to create the DMG file and use that as a virtual CD.

Re: CD/DVD drive access

PostPosted: 12. Jun 2014, 22:51
by ciamurra
VBox 4.3.12

Host System:
Macbook air 12.4 GHz core i7
OS X version 10.8.5
VirtualBox 4.2.16
Memory 16 GB 1600 MHz DDR3

Video details:
Intel HD Graphics 4000
NVIDIA GeForce GT 4000

Guest
Windows 7 SP1 64-bit


Socratis wrote on 13 Feb, 2014:

You don't have a physical CD. You have a USB CD. Even if you get it to show up as a USB CD in the virtual machine (with filters), I'm not sure it will boot from that. VirtualBox doesn't support USB boot. Your best bet is to create the DMG file and use that as a virtual CD.


I used a CD mounted on a USB drive (Macbook Air Superdrive) to install Windows 7, so Virtualbox recognized the CD as a CD. Now I'm trying to install a program in Win 7. The program is on a CD. The CD icon at the bottom of the window is greyed out, so I clicked on the USB icon. Message: driver missing. In the system directory ("Computer") the CD drive shows up as D:

I used the Windows Toubleshooter to find the driver. It came up with "Sun VirtualBox Setup Wizard." Not knowing if I should use that, I attempted to create a disk image using Mac Disk Utility. But the extension is .cdr not .dmg.

I tried to create a shared folder with path Z:\Macintosh HD\Users\myname\Documents\Quicken. I stored the disk image in that folder. But VM VirtualBox Manager Shared Folders has "OK" grayed out when I enter path, folder name and select Auto-mount. So now I don't even know if the disk image will work or how to access it without a shared folder.

Re: CD/DVD drive access

PostPosted: 13. Jun 2014, 01:37
by ciamurra
Update on shared folders:

In the Shared Folders window, I finally succeeded in establishing one using path /Users/[mycomputer]/Documents/[folder name]
and I am able to click OK. BUT in the VM VBox manager, Shared Folders = None.

Re: CD/DVD drive access

PostPosted: 13. Jun 2014, 01:42
by BillG
You do not need to use shared folders. All that is required is that the image file is available on the host. You assign the file on the host to the CD/DVD drive of the virtual machine from the vm settings. VirtualBox will link the file in the host OS to the DVD reader of the guest and the guest can read the file.

You could have installed Windows 7 the same way by loading the Windows 7 install media on the host, assigning it to the DVD drive of the vm and booting it from there.

Re: CD/DVD drive access

PostPosted: 5. Jul 2015, 11:08
by osxguy
It is actually simple. The trick is to mount the DVD drive as a USB device, NOT as a DVD drive (although it will be listed as DVD drive, this will not work).

Re: CD/DVD drive access

PostPosted: 6. Jul 2015, 09:01
by mpack
The trick is usually even simpler: make an ISO image of the disk itself, and mount that in the VM. The ISO is usually preferable anyway.

Re: CD/DVD drive access

PostPosted: 4. Nov 2015, 03:35
by Don Darion
Managed to get VirtualBox to recognise my DVD drive connected by USB. And am now able to use my DVD drive to download and setup software programs from CD/DVDs.
I’m using host Mac OS (El Capitan), guest Windows XP professional 32-bit, VirtualBox 5.0.8.

What worked for me:

I did what noteirak advised above (see his screenshots).
Went to VirtualBox Manager. Settings. Storage. Click on Host Drive, then the CD icon (next to IDE Secondary Master). I had to fiddle around a bit, by disconnecting and reconnecting my USB on the Host before it is recognised. Then select the correct USB port. Make sure ‘Passthrough’ is clicked.
Go to Ports. Add new USB filter (select the correct USB port). Enable USB Controller. Select USB 1.1 Controller. (Not USB 2.0 or 3.0). Click Ok.
(I may have done the Ports part first before the Storage part. Can’t recall now).
Then restart your Windows in VM.

I’m not an expert on this and relied on surfing for bits of information from others along with the VirtualBox manual. This particular forum page was helpful to me. Thought I’d add my two cents on what worked for me.