Page 1 of 9

VM doesn't start on Mountain Lion

PostPosted: 4. Sep 2012, 08:34
by JBD06
Hello,

I have a new Installation of Mountain Lion with the 10.8.2 patch. No other Vitualisation tools are installed

When I try to start a Windows 8 guest I have this error:
./VBoxManage startvm windows
Waiting for VM "windows" to power on...
VBoxManage: error: VT-x is being used by another hypervisor. (VERR_VMX_IN_VMX_ROOT_MODE).
VBoxManage: error: VirtualBox can't operate in VMX root mode. Please close all other virtualization programs. (VERR_VMX_IN_VMX_ROOT_MODE)
VBoxManage: error: Details: code NS_ERROR_FAILURE (0x80004005), component Console, interface IConsole

Thanks,
JB

Re: VM doesn't start on Mountain Lion

PostPosted: 4. Sep 2012, 10:26
by OlegL
hi,
I had something quite similar after upgrading to Mac OS 10.8

I had to launch VirtualBox_uninstall to cleanly remove VB; then reboot my Mac and reinstall VirtualBox

Now everything works well

Hope the helps,
Oleg

Re: VM doesn't start on Mountain Lion

PostPosted: 4. Sep 2012, 11:14
by JBD06
Hello,

I tried to uninstall the previous installation of VirtualBox
I have restarted and reinstalled everything without success.

Thanks,
JB

Re: VM doesn't start on Mountain Lion

PostPosted: 5. Sep 2012, 07:44
by oldchook
I have the same problem!

Re: VM doesn't start on Mountain Lion

PostPosted: 6. Sep 2012, 00:18
by devrac
Same problem here since applying 10.8.2 build 12c35. No problems with 10.8.1
Tried completely uninstalling / reinstalling virtualbox but the problem persists.

Re: VM doesn't start on Mountain Lion

PostPosted: 6. Sep 2012, 13:38
by devrac
10.8.2 build 12c43 was seeded today but the error still persists.

Re: VM doesn't start on Mountain Lion

PostPosted: 10. Sep 2012, 14:47
by JBD06
Hello,

I have tried with the 4.2.0 RC4 but I have still the same issue.

Regards
JB

Re: VM doesn't start on Mountain Lion

PostPosted: 10. Sep 2012, 17:14
by michaln
If you're getting the error message "VirtualBox can't operate in VMX root mode. Please close all other virtualization programs." then no amount of uninstalling and reinstalling VirtualBox is going to make any difference. Really.

If something took over VT-x, then it's taken over and VirtualBox can't use it and can't do anything about it. Only you can.

Re: VM doesn't start on Mountain Lion

PostPosted: 11. Sep 2012, 18:41
by JasonHeffner
I've noticed the same issue with 10.8.2

Re: VM doesn't start on Mountain Lion

PostPosted: 11. Sep 2012, 18:45
by michaln
Ask Apple about this. Seriously.

Re: VM doesn't start on Mountain Lion

PostPosted: 11. Sep 2012, 19:55
by JasonHeffner
I thought I would ask other users of the software about it. Perhaps others also experienced this issue with 10.8.2, and testing might help the developers circumvent problems when Apple releases it. I don't find any of your comments helpful so far.

Re: VM doesn't start on Mountain Lion

PostPosted: 11. Sep 2012, 20:22
by michaln
JasonHeffner wrote:I thought I would ask other users of the software about it

This is not the best place to find other users of unreleased Apple software. The Apple discussion boards, on the other hand, would be an excellent place for it.

Re: VM doesn't start on Mountain Lion

PostPosted: 11. Sep 2012, 20:47
by JasonHeffner
First, we haven't confirmed this is an issue with 10.8.2 or something else; though it does sound like it is. Second, this is a forum for Mac OSX users of VirtualBox. It seems quite appropriate to bring the question up in this forum, though also bringing the question up in Apple forums is also a good idea now that it is highly likely 10.8.2. It does not seem to affect VMWare Fusion, so it could be specific to VirtualBox. We have several laptops we were able to test with.

Do you have any constructive feedback on how we might go about diagnosing the issue?

Can anyone else also confirm it's 10.8.2? Thanks! Perhaps we can submit an early bug report then so when 10.8.2 is released the end of this month it has possibly already been looked at, and a fix could be in the works?

Re: VM doesn't start on Mountain Lion

PostPosted: 12. Sep 2012, 09:18
by serviceHoster
same problem... but only on my macbook air 2012...
no problems with the same 10.8.2 build on my imac 27 2010

today i´m running 10.8.2 12C50 ... doesn´t work

Re: VM doesn't start on Mountain Lion

PostPosted: 12. Sep 2012, 10:04
by JBD06
I have the same issue with the 12c50 build.

For me it's seems to be the good place, because I have issue only with virtualbox.
I have installed to test the last version of Fusion, on my laptop and it works perfectly. I have to ask on apple forum about an issue of a software that is not develloped by it ? For me, that's sounds strange. I suppose that as virtualbox is develloped for mac on mac, developers have access to the last build and they can test and validate it on the new version ?

Regards
JB