VM doesn't start on Mountain Lion

Discussions related to using VirtualBox on Mac OS X hosts.

Re: VM doesn't start on Mountain Lion

Postby Scotter_10 » 21. Sep 2012, 03:02

I had windows 7 running on my Mac just fine until yesterday when I updated. I can no longer start my virtual machine. I had the same sort of error the the last post had.
Scotter_10
 
Posts: 1
Joined: 21. Sep 2012, 02:59

Re: VM doesn't start on Mountain Lion

Postby rpmurray » 21. Sep 2012, 05:20

When you folks updated to 10.8.2 was the new EFI firmware update installed also?
rpmurray
Volunteer
 
Posts: 912
Joined: 3. Mar 2009, 00:29
Location: Between Heaven and Hell
Primary OS: Mac OS X other
VBox Version: PUEL
Guest OSses: Windows Server 2003 SP2, Windows XP SP3, Windows 7

Re: VM doesn't start on Mountain Lion

Postby _Thomas_ » 21. Sep 2012, 07:55

rpmurray wrote:When you folks updated to 10.8.2 was the new EFI firmware update installed also?


No EFI update made.
_Thomas_
 
Posts: 2
Joined: 21. Sep 2012, 07:53

Re: VM doesn't start on Mountain Lion

Postby mandianme » 21. Sep 2012, 08:07

Same issue here. Update to 10.8.2 bricked VB 4.2

My MBPr system details:
Model Name: MacBook Pro Retina
Model Identifier: MacBookPro10,1
Processor Name: Intel Core i7
Processor Speed: 2.3 GHz
Number of Processors: 1
Total Number of Cores: 4
L2 Cache (per Core): 256 KB
L3 Cache: 6 MB
Memory: 8 GB
Boot ROM Version: MBP101.00EE.B02
SMC Version (system): 2.3f32
System Version: OS X 10.8.2 (12C54)
Kernel Version: Darwin 12.2.0
Boot Volume: Macintosh HD
Boot Mode: Normal
Secure Virtual Memory: Enabled
mandianme
 
Posts: 1
Joined: 21. Sep 2012, 08:04

Re: VM doesn't start on Mountain Lion

Postby houen » 21. Sep 2012, 09:10

Bump
houen
 
Posts: 1
Joined: 21. Sep 2012, 09:09

Re: VM doesn't start on Mountain Lion

Postby arajkov » 21. Sep 2012, 09:52

Any news or test builds fixing this problem?! I cant work with my developer machine until this is fixed ... or do I have to switch to parallels? :( Which is not my favorite option.....
arajkov
 
Posts: 1
Joined: 21. Sep 2012, 09:51

Re: VM doesn't start on Mountain Lion

Postby Dyre » 21. Sep 2012, 10:17

Same problem - MBPr, 10.8.2, VB 4.2 - nothing works anymore.

NS_ERROR_FAILURE (0x80004005)

Please please please fix this :)
Dyre
 
Posts: 1
Joined: 21. Sep 2012, 10:14

Re: VM doesn't start on Mountain Lion

Postby Roger Wang » 21. Sep 2012, 10:24

same problem on os x 10.8.2, vb 4.1.22 r80657
Roger Wang
 
Posts: 1
Joined: 21. Sep 2012, 10:23

Re: VM doesn't start on Mountain Lion

Postby Ammasuddet » 21. Sep 2012, 11:57

i also have the problem. i use a Macbook Pro Retina with OS 10.8.2

This is the Error message i get

Failed to open a session in the virtual machine NewTinyDebian.

VT-x is being used by another hypervisor.
(VERR_VMX_IN_VMX_ROOT_MODE).

VirtualBox can't operate in VMX root mode. Please close all other virtualization programs.
(VERR_VMX_IN_VMX_ROOT_MODE).

Details:
Resultscode: NS_ERROR_FAILURE (0x80004005)
Component: Console
Interface: IConsole {1968b7d3-e3bf-4ceb-99e0-cb7c913317bb}
Ammasuddet
 
Posts: 2
Joined: 21. Sep 2012, 11:05

Re: VM doesn't start on Mountain Lion

Postby agnoeo » 21. Sep 2012, 12:11

I also have this issue with OS X 10.8.2 + EFI + VirtualBox 4.2 Update.
agnoeo
 
Posts: 2
Joined: 21. Sep 2012, 12:11

Re: VM doesn't start on Mountain Lion

Postby inka » 21. Sep 2012, 13:02

same problem for me Retina + OS X 10.8.2 + VirtualBox 4.2. 10.8.1 worked without problems.
inka
 
Posts: 1
Joined: 21. Sep 2012, 13:00

Re: VM doesn't start on Mountain Lion

Postby mag » 21. Sep 2012, 13:05

Based on this https://discussions.apple.com/message/19657148#19657148 it seems to be as I expected and Apple is to blame for the root cause...
mag
 
Posts: 9
Joined: 13. Sep 2012, 15:47

Re: VM doesn't start on Mountain Lion

Postby michaln » 21. Sep 2012, 13:55

The issue has nothing to do with the EFI update, only with the OS X update. It turns out that the problem is also only indirectly related to VT-x.

The root cause is that the semantics of some IOKit memory management APIs subtly changed between 10.8.1 and 10.8.2, but only on systems with an IOMMU (aka VT-d).
michaln
Oracle Corporation
 
Posts: 2944
Joined: 19. Dec 2007, 15:45
Primary OS: MS Windows 7
VBox Version: PUEL
Guest OSses: Any and all

Re: VM doesn't start on Mountain Lion

Postby isaacsu » 21. Sep 2012, 13:56

Same problem as you guys. MBP Retina, upgraded EFI and OS X 10.8.2. Bricked VirtualBox 4.2 because of the VT-x issue.

I downgraded to OS X 10.8, and VirtualBox is working again.

To downgrade to 10.8,

1. Grab a copy of the OS X 10.8 InstallESD.dmg,
2. Use Disk Utility to restore to a USB drive (minimum 8gb).
3. Boot from USB (Hold down Option key when booting).
4. Make sure you're disconnected from the Internet (prevents the installer from auto updating).
5. Select "Reinstall Mac OS X"

This overwrites the OS with 10.8, and keeps all user data/applications intact.

Hope this helps someone.
isaacsu
 
Posts: 1
Joined: 21. Sep 2012, 13:54

Re: VM doesn't start on Mountain Lion

Postby michaln » 21. Sep 2012, 13:59

arajkov wrote:Any news or test builds fixing this problem?! I cant work with my developer machine until this is fixed ... or do I have to switch to parallels? :( Which is not my favorite option.....

FYI, we're still waiting for the first official support request... So far it appears that all those poor folks who had to shell out their last buck for a shiny new Apple laptop were so cash-strapped that they couldn't afford the $50 for a VirtualBox license (or didn't think it was worth as much). Which naturally doesn't stop them from wanting this fixed yesterday. That is obviously not a very encouraging attitude from our perspective.

That said, please check https://www.virtualbox.org/ticket/10965#comment:21 for test builds of VirtualBox 4.1 and 4.2 which should fix this problem. Please note that only folks who have a problem with OS X 10.8.2 should install those. And please provide feedback (positive or negative) either on the ticket or here.
michaln
Oracle Corporation
 
Posts: 2944
Joined: 19. Dec 2007, 15:45
Primary OS: MS Windows 7
VBox Version: PUEL
Guest OSses: Any and all

PreviousNext

Return to VirtualBox on Mac OS X Hosts

Who is online

Users browsing this forum: No registered users and 20 guests