VM doesn't start on Mountain Lion

Discussions related to using VirtualBox on Mac OS X hosts.

Re: VM doesn't start on Mountain Lion

Postby Gustavomh » 20. Sep 2012, 14:54

Same problem too me, MBP 13 2012, Montain Lion updated last night....
Gustavomh
 
Posts: 2
Joined: 20. Sep 2012, 14:51

Re: VM doesn't start on Mountain Lion

Postby rpmurray » 20. Sep 2012, 15:19

I'm assuming that the reason all of you were in a tearing hurry to update to 10.8.2 was that it provided some important fix that you couldn't live without.
rpmurray
Volunteer
 
Posts: 912
Joined: 3. Mar 2009, 00:29
Location: Between Heaven and Hell
Primary OS: Mac OS X other
VBox Version: PUEL
Guest OSses: Windows Server 2003 SP2, Windows XP SP3, Windows 7

Re: VM doesn't start on Mountain Lion

Postby Gustavomh » 20. Sep 2012, 15:39

I updated hoping it was repaired the problem of using multiple monitors. But now I have another problem to worry about. I hate to be a beta tester! :-(
Gustavomh
 
Posts: 2
Joined: 20. Sep 2012, 14:51

Re: VM doesn't start on Mountain Lion

Postby enterthewebb » 20. Sep 2012, 15:40

rpmurray wrote:I'm assuming that the reason all of you were in a tearing hurry to update to 10.8.2 was that it provided some important fix that you couldn't live without.


Maybe I'm taking that comment the wrong way, but in much the same way as if I started up Virtual Box like many of us do every day and it said: "Hey, there's a new version, would like to download it now?", generally the answer is yes. Sure, there are plenty of changes from 10.8.1 to 10.8.2, but I'd take the sarcasm better if we were talking about something like a 10.7 to 10.8 upgrade, for instance.

If that makes us lemmings, then so be it, but I have similar experiences in my line of work, and I'd rather take a problem to the vendor on the latest releases of their software and the OS then get the: "I know I'm running 2 major releases behind on an OS that the manufacturer doesn't even support anymore, but I'm having this problem and I really need it fixed..."

Sorry for wanting to stay up-to-date. Gotta run, my pager is going off and I need to find a pay phone...
enterthewebb
 
Posts: 2
Joined: 20. Sep 2012, 15:24

Re: VM doesn't start on Mountain Lion

Postby michaln » 20. Sep 2012, 15:57

enterthewebb wrote:Maybe I'm taking that comment the wrong way, but in much the same way as if I started up Virtual Box like many of us do every day and it said: "Hey, there's a new version, would like to download it now?", generally the answer is yes.

Actually... you may have noticed that we don't always notify users of new versions. For example right now users aren't prompted to update to 4.2.0; we'll only do that once we get enough feedback (or lack of feedback) indicating that the new version is sufficiently stable.

Sure, there are plenty of changes from 10.8.1 to 10.8.2, but I'd take the sarcasm better if we were talking about something like a 10.7 to 10.8 upgrade, for instance.

Well... we also wonder why Apple decided to make some relatively significant kernel change in an ostensibly minor update, or why this only affects certain models. Right now only Apple has those answers I'm afraid.

Incidentally, has anyone noticed anything in the OS X 10.8.2 release notes that sounded even remotely relevant to this issue?
michaln
Oracle Corporation
 
Posts: 2938
Joined: 19. Dec 2007, 15:45
Primary OS: MS Windows 7
VBox Version: PUEL
Guest OSses: Any and all

Re: VM doesn't start on Mountain Lion

Postby enterthewebb » 20. Sep 2012, 16:08

I couldn't agree more with that - it does seem like there are pretty significant changes for a Service Release or Update or whatever Apple likes to call it. At the end of the day, we're talking about an incremental to an existing Major.Minor release, yet they've apparently made some pretty significant changes that I agree don't seem to be publicized in any of the release notes I read (I do at least read those before I click "Update"!)...

The comment just struck me the wrong way, I suppose. Stuff happens, and I am all for keeping humor and light-hearted sarcasm in the mix (I think we'd all go postal in the software industry if we didn't!!), but it didn't seem very constructive to the overall discussion.

I guess I really am getting old and grumpy...crap! :D
enterthewebb
 
Posts: 2
Joined: 20. Sep 2012, 15:24

Re: VM doesn't start on Mountain Lion

Postby zx5000 » 20. Sep 2012, 16:21

FYI ... 10.8.2 forced itself onto millions of Mountain Lion systems last night without any choice for the end user. "Your system was updated restart now". This is a very Redmond-esque thing to do. We the users are innocent of any wrong doing.

Apple says it's an Oracle issue. Here's a quote from the apple forum that reveals their attitude. "VirtualBox is a low-level system modification. If you're going to use such things, you cannot install system updates from Apple until you know that the modifications are compatible, or until they're updated to be compatible." And as I said we the users had no choice.

Someone needs to quit pointing fingers and do some engineering to figure this out. I have to wonder if Oracle actually cares since there is no revenue stream here.

In the mean time there are hundreds of users who are losing productivity since we depend on VB to provide our development environments.
zx5000
 
Posts: 3
Joined: 20. Sep 2012, 16:09

Re: VM doesn't start on Mountain Lion

Postby vickumar » 20. Sep 2012, 17:41

I'm having the same issue. Virtual Box was working fine until I ran the update for OS X 10.8.2.

So I guess the plan is to never update my Mac anymore b/c it might break something that's working, and Apple will just say it's not their fault.
vickumar
 
Posts: 1
Joined: 20. Sep 2012, 17:39

Re: VM doesn't start on Mountain Lion

Postby bleve » 20. Sep 2012, 19:12

From https://www.virtualbox.org/ticket/10965:

Just to mention it, we are aware of that issue and working on a fix. Once we have one we will quickly provide test builds for VBox 4.2.x and 4.1.x.


So VB development is working on it. From the apple communities many are exporting the VBs and importing them in VMware with success.
bleve
 
Posts: 7
Joined: 12. Jan 2010, 22:47
Primary OS: Fedora other
VBox Version: OSE Fedora
Guest OSses: Windows XP

Re: VM doesn't start on Mountain Lion

Postby felix822 » 20. Sep 2012, 19:16

I just imported my VM to Parallels with success.
felix822
 
Posts: 9
Joined: 13. Aug 2012, 18:59

Re: VM doesn't start on Mountain Lion

Postby rpmurray » 20. Sep 2012, 19:25

vickumar wrote:So I guess the plan is to never update my Mac anymore b/c it might break something that's working, and Apple will just say it's not their fault.


No, the plan is to not update until those that live on the bleeding edge have shaken out the bugs.

I still run 10.6.8 mainly because I've seen no compelling reason to jump on the upgrade bandwagon yet and some of the "improved" features in Lion/Mountain Lion sound more like a downgrade to me. If what a previous poster said about the update automatically installing is true then that's one more reason for me to be wary and stay away. Generally I've always turned off the "check for updates" feature in Software Update because I don't want to be surprised like this on my production machine.
rpmurray
Volunteer
 
Posts: 912
Joined: 3. Mar 2009, 00:29
Location: Between Heaven and Hell
Primary OS: Mac OS X other
VBox Version: PUEL
Guest OSses: Windows Server 2003 SP2, Windows XP SP3, Windows 7

Re: VM doesn't start on Mountain Lion

Postby bleve » 20. Sep 2012, 20:14

For me it did not install the update automatically, so there must be a setting for that. For me I went to 10.8.2 to fix a known problem that is fixed in the update. I had to actually go into the App Store and tell it to upgrade.
bleve
 
Posts: 7
Joined: 12. Jan 2010, 22:47
Primary OS: Fedora other
VBox Version: OSE Fedora
Guest OSses: Windows XP

Re: VM doesn't start on Mountain Lion

Postby GregK » 20. Sep 2012, 21:05

For some reason VMWare wouldn't recognize my VB file when I tried to convert it. I ended up using a Parallels trial.

Can someone from Oracle give us a timeframe on a fix? Within 14 days I hope?
GregK
 
Posts: 1
Joined: 20. Sep 2012, 20:08

Re: VM doesn't start on Mountain Lion

Postby michaln » 20. Sep 2012, 22:44

GregK wrote:Can someone from Oracle give us a timeframe on a fix? Within 14 days I hope?

Giving timeframes on issues such as this without fully understanding the problem would be either stupidity or lying. I'm sure you don't really want either :)

That said, I believe we're now far enough along to say that there will highly likely be at least a test build pretty soon. Certainly sooner than in two weeks...
michaln
Oracle Corporation
 
Posts: 2938
Joined: 19. Dec 2007, 15:45
Primary OS: MS Windows 7
VBox Version: PUEL
Guest OSses: Any and all

Re: VM doesn't start on Mountain Lion

Postby snowyau » 21. Sep 2012, 02:02

rpmurray wrote:I'm assuming that the reason all of you were in a tearing hurry to update to 10.8.2 was that it provided some important fix that you couldn't live without.


Users on this thread are looking for a constructive suggestion or fix to a specific problem narrowed down to software versions; not childish sarcasm, gloating nor general prevention tips.
snowyau
 
Posts: 3
Joined: 21. Sep 2012, 01:49

PreviousNext

Return to VirtualBox on Mac OS X Hosts

Who is online

Users browsing this forum: No registered users and 11 guests