VM doesn't start on Mountain Lion

Discussions related to using VirtualBox on Mac OS X hosts.

VM doesn't start on Mountain Lion

Postby JBD06 » 4. Sep 2012, 08:34

Hello,

I have a new Installation of Mountain Lion with the 10.8.2 patch. No other Vitualisation tools are installed

When I try to start a Windows 8 guest I have this error:
./VBoxManage startvm windows
Waiting for VM "windows" to power on...
VBoxManage: error: VT-x is being used by another hypervisor. (VERR_VMX_IN_VMX_ROOT_MODE).
VBoxManage: error: VirtualBox can't operate in VMX root mode. Please close all other virtualization programs. (VERR_VMX_IN_VMX_ROOT_MODE)
VBoxManage: error: Details: code NS_ERROR_FAILURE (0x80004005), component Console, interface IConsole

Thanks,
JB
JBD06
 
Posts: 5
Joined: 4. Sep 2012, 08:29

Re: VM doesn't start on Mountain Lion

Postby OlegL » 4. Sep 2012, 10:26

hi,
I had something quite similar after upgrading to Mac OS 10.8

I had to launch VirtualBox_uninstall to cleanly remove VB; then reboot my Mac and reinstall VirtualBox

Now everything works well

Hope the helps,
Oleg
OlegL
 
Posts: 9
Joined: 3. Sep 2012, 16:42
Primary OS: Mac OS X other
VBox Version: OSE other
Guest OSses: Scientific Linux

Re: VM doesn't start on Mountain Lion

Postby JBD06 » 4. Sep 2012, 11:14

Hello,

I tried to uninstall the previous installation of VirtualBox
I have restarted and reinstalled everything without success.

Thanks,
JB
JBD06
 
Posts: 5
Joined: 4. Sep 2012, 08:29

Re: VM doesn't start on Mountain Lion

Postby oldchook » 5. Sep 2012, 07:44

I have the same problem!
oldchook
 
Posts: 7
Joined: 23. Aug 2012, 05:40

Re: VM doesn't start on Mountain Lion

Postby devrac » 6. Sep 2012, 00:18

Same problem here since applying 10.8.2 build 12c35. No problems with 10.8.1
Tried completely uninstalling / reinstalling virtualbox but the problem persists.
devrac
 
Posts: 7
Joined: 6. Sep 2012, 00:15

Re: VM doesn't start on Mountain Lion

Postby devrac » 6. Sep 2012, 13:38

10.8.2 build 12c43 was seeded today but the error still persists.
devrac
 
Posts: 7
Joined: 6. Sep 2012, 00:15

Re: VM doesn't start on Mountain Lion

Postby JBD06 » 10. Sep 2012, 14:47

Hello,

I have tried with the 4.2.0 RC4 but I have still the same issue.

Regards
JB
JBD06
 
Posts: 5
Joined: 4. Sep 2012, 08:29

Re: VM doesn't start on Mountain Lion

Postby michaln » 10. Sep 2012, 17:14

If you're getting the error message "VirtualBox can't operate in VMX root mode. Please close all other virtualization programs." then no amount of uninstalling and reinstalling VirtualBox is going to make any difference. Really.

If something took over VT-x, then it's taken over and VirtualBox can't use it and can't do anything about it. Only you can.
michaln
Oracle Corporation
 
Posts: 1246
Joined: 19. Dec 2007, 15:45
Primary OS: MS Windows 7
VBox Version: PUEL
Guest OSses: Any and all

Re: VM doesn't start on Mountain Lion

Postby JasonHeffner » 11. Sep 2012, 18:41

I've noticed the same issue with 10.8.2
JasonHeffner
 
Posts: 6
Joined: 11. Sep 2012, 18:41

Re: VM doesn't start on Mountain Lion

Postby michaln » 11. Sep 2012, 18:45

Ask Apple about this. Seriously.
michaln
Oracle Corporation
 
Posts: 1246
Joined: 19. Dec 2007, 15:45
Primary OS: MS Windows 7
VBox Version: PUEL
Guest OSses: Any and all

Re: VM doesn't start on Mountain Lion

Postby JasonHeffner » 11. Sep 2012, 19:55

I thought I would ask other users of the software about it. Perhaps others also experienced this issue with 10.8.2, and testing might help the developers circumvent problems when Apple releases it. I don't find any of your comments helpful so far.
JasonHeffner
 
Posts: 6
Joined: 11. Sep 2012, 18:41

Re: VM doesn't start on Mountain Lion

Postby michaln » 11. Sep 2012, 20:22

JasonHeffner wrote:I thought I would ask other users of the software about it

This is not the best place to find other users of unreleased Apple software. The Apple discussion boards, on the other hand, would be an excellent place for it.
michaln
Oracle Corporation
 
Posts: 1246
Joined: 19. Dec 2007, 15:45
Primary OS: MS Windows 7
VBox Version: PUEL
Guest OSses: Any and all

Re: VM doesn't start on Mountain Lion

Postby JasonHeffner » 11. Sep 2012, 20:47

First, we haven't confirmed this is an issue with 10.8.2 or something else; though it does sound like it is. Second, this is a forum for Mac OSX users of VirtualBox. It seems quite appropriate to bring the question up in this forum, though also bringing the question up in Apple forums is also a good idea now that it is highly likely 10.8.2. It does not seem to affect VMWare Fusion, so it could be specific to VirtualBox. We have several laptops we were able to test with.

Do you have any constructive feedback on how we might go about diagnosing the issue?

Can anyone else also confirm it's 10.8.2? Thanks! Perhaps we can submit an early bug report then so when 10.8.2 is released the end of this month it has possibly already been looked at, and a fix could be in the works?
JasonHeffner
 
Posts: 6
Joined: 11. Sep 2012, 18:41

Re: VM doesn't start on Mountain Lion

Postby serviceHoster » 12. Sep 2012, 09:18

same problem... but only on my macbook air 2012...
no problems with the same 10.8.2 build on my imac 27 2010

today i´m running 10.8.2 12C50 ... doesn´t work
serviceHoster
 
Posts: 2
Joined: 12. Sep 2012, 09:16

Re: VM doesn't start on Mountain Lion

Postby JBD06 » 12. Sep 2012, 10:04

I have the same issue with the 12c50 build.

For me it's seems to be the good place, because I have issue only with virtualbox.
I have installed to test the last version of Fusion, on my laptop and it works perfectly. I have to ask on apple forum about an issue of a software that is not develloped by it ? For me, that's sounds strange. I suppose that as virtualbox is develloped for mac on mac, developers have access to the last build and they can test and validate it on the new version ?

Regards
JB
JBD06
 
Posts: 5
Joined: 4. Sep 2012, 08:29

Next

Return to VirtualBox on Mac OS X Hosts

Who is online

Users browsing this forum: No registered users and 20 guests