Virtualbox Hangs at startup

Discussions related to using VirtualBox on Mac OS X hosts.

Virtualbox Hangs at startup

Postby Lorenzo » 7. Aug 2012, 17:48

hi, I have this virtual box, 4.1.18, it worked beautifully until I restarted Mountain Lion.

after the restart, it won't load anymore. The VM was shut down before the host restart, so it is not that which crashed.

when loading the vm or the app, the icon bounce on the dock without any message or showing any windows.

when launched from the command line, anything hangs, without crashing and without giving any message. (tested with VBoxManage list and startvm)

I've tried repairing disk permissions, rebooting the service and reloading the kext, uninstalling reinstalling, uninstalling and installing the beta, rebooting, removing the /tmp/*ipc but nothing changes: it just won't start.


problem is, I don't heven have a log or a hint on what the error is. so, first step: how do I get some more logging out of the vbox startup process?
Lorenzo
 
Posts: 3
Joined: 7. Aug 2012, 17:42

Re: Virtualbox Hangs at startup

Postby jhelling » 7. Aug 2012, 18:03

Hi,
Guess I'm in a same kind of situation as you are.
Don't you get a message such as that a com server can not be found?
"Failed to initialize COM or to find the VirtualBox COM server. Most likely, the VirtualBox server is not running or failed to start.
The application will now terminate.
Callee RC: NS_ERROR_FAILURE (0x80004005)"

I reinstalled vbox already but don't seem to be able to solve the problem.
My other mac (MBP with lion server) was upgraded too and shows the message the VB is not allowed to start. Guess the version has not been upgraded up to *.18.

I can not determine if the problem came after installing os x server or before on top of mountain lion ...

Greetings,
Jan.
jhelling
 
Posts: 9
Joined: 7. Aug 2012, 11:29
Primary OS: Mac OS X other
VBox Version: OSE other
Guest OSses: 4.3

Re: Virtualbox Hangs at startup

Postby Lorenzo » 7. Aug 2012, 18:19

jhelling wrote:Hi,

Don't you get a message such as that a com server can not be found?




no, no message at all. it doesn't crash, it just hangs at startup.

is there some other log to check than the one in ~/Library/VirtualBox?

this is all the log I get:

Code: Select all   Expand viewCollapse view
VirtualBox XPCOM Server 4.2.0_BETA1 r79756 darwin.amd64 (Aug  3 2012 14:06:10) release log
00:00:00.002213 main     Log opened 2012-08-07T15:03:00.516723000Z
00:00:00.002227 main     OS Product: Darwin
00:00:00.002231 main     OS Release: 12.0.0
00:00:00.002235 main     OS Version: Darwin Kernel Version 12.0.0: Sun Jun 24 23:00:16 PDT 2012; root:xnu-2050.7.9~1/RELEASE_X86_64
00:00:00.002352 main     DMI Product Name: MacBookPro10,1
00:00:00.002418 main     DMI Product Version: 1.0
00:00:00.002425 main     Executable: /Applications/VirtualBox.app/Contents/MacOS/VBoxSVC
00:00:00.002426 main     Process ID: 33286
00:00:00.002426 main     Package type: DARWIN_64BITS_GENERIC
Lorenzo
 
Posts: 3
Joined: 7. Aug 2012, 17:42

Re: Virtualbox Hangs at startup

Postby jhelling » 7. Aug 2012, 22:55

Can you have a look in /Library/Application Support/CrashReporter
Over there I found a file which reports something for VboxSVC ...
When I open that file (it's binary) I see a location for a diagnostics file:
/Library/Logs/DiagnosticReports
Cannot find the mentioned file however.
Starting the vm manually via command line shows me the following:
Code: Select all   Expand viewCollapse view
 ./Vboxmanage startvm FMW_ConseilMiddlewareServer
Waiting for VM "FMW_ConseilMiddlewareServer" to power on...
VBoxManage: error: The virtual machine 'FMW_ConseilMiddlewareServer' has terminated unexpectedly during startup with exit code 1
VBoxManage: error: Details: code NS_ERROR_FAILURE (0x80004005), component Machine, interface IMachine, callee

I guess you don't see the same kind of message?
If not I will start an other tread not to block your quest for an answer ... :(
jhelling
 
Posts: 9
Joined: 7. Aug 2012, 11:29
Primary OS: Mac OS X other
VBox Version: OSE other
Guest OSses: 4.3

Re: Virtualbox Hangs at startup

Postby jhelling » 7. Aug 2012, 23:02

It doesn't hang with me ... it immediately crashes ...
One of the things that seems to be removed was the x11 server.
Have to install that yourself (start x11.app in the utiliteis folder)
jhelling
 
Posts: 9
Joined: 7. Aug 2012, 11:29
Primary OS: Mac OS X other
VBox Version: OSE other
Guest OSses: 4.3

Re: Virtualbox Hangs at startup

Postby jhelling » 7. Aug 2012, 23:05

Anyway ... I guess our problems come from the same binary : vboxsvc ...
I do not know anything about COM ... but seems vboxsvc uses that.
I found somewhere that if you get a hang it may be due to the fact that X is missing ...
Start the vm manually from the commandline as I did but with the option -type headless.
Does that make a difference for you?
For me it doesn't ... :(
jhelling
 
Posts: 9
Joined: 7. Aug 2012, 11:29
Primary OS: Mac OS X other
VBox Version: OSE other
Guest OSses: 4.3

Re: Virtualbox Hangs at startup

Postby jhelling » 8. Aug 2012, 07:24

btw ... did you install OS X Server ?
Seems you are also using the beta release of VB.
I'm still on 4.1.18.
jhelling
 
Posts: 9
Joined: 7. Aug 2012, 11:29
Primary OS: Mac OS X other
VBox Version: OSE other
Guest OSses: 4.3

Re: Virtualbox Hangs at startup

Postby Lorenzo » 8. Aug 2012, 12:44

I've tried reinstalling with the 4.2 BETA at some point, but the problem remained. After another some more restarts the problem went away.

Now it keeps randomly happening. The situation is stable: if it starts, it keeps going without problem. If after a restarts it stalls at launch, for all that session it remains stuck.

I guess it has something to do with the startup order of components? Dunno. I'd say this helped a lot in finalizing the switch to osx from windows, so I'm happy anyhow.
Lorenzo
 
Posts: 3
Joined: 7. Aug 2012, 17:42


Return to VirtualBox on Mac OS X Hosts

Who is online

Users browsing this forum: No registered users and 20 guests