Disable Host+C "Scale Mode" shortcut

Discussions related to using VirtualBox on Mac OS X hosts.

Disable Host+C "Scale Mode" shortcut

Postby zantoro » 7. Feb 2012, 09:38

Hello,
I would like to disable the Host+C shortcut.
whenever I hit it my guest machine goes crazy and stops working.
Given that I only use the full screen mode, I'd rather simply disable the Host+C shortcut, than look for a solution to fix the "Scale Mode" problem (especially since I hit this combination only when mixing up Copy and paste shortcuts between windows and mac).

Thanks,
Roberto.
zantoro
 
Posts: 1
Joined: 7. Feb 2012, 09:34

Re: Disable Host+C "Scale Mode" shortcut

Postby frank » 7. Feb 2012, 09:44

Code: Select all   Expand viewCollapse view
VBoxManage setextradata global GUI/Input/MachineShortcuts "ScaleMode=None"

This should work with VBox 4.1.8 and this will be documented as of the next maintenenace release.
frank
Oracle Corporation
 
Posts: 3362
Joined: 7. Jun 2007, 09:11
Location: Dresden, Germany
Primary OS: Debian Sid
VBox Version: PUEL
Guest OSses: Linux, Windows

Re: Disable Host+C "Scale Mode" shortcut

Postby TDQ » 24. Apr 2012, 00:12

Thanks for this tip. My Mac host couldn't handle the accidental Host+C at all - display refresh just went away.
___
Macbook Pro — i7 2.3GHz quad core; RAM: 4GB; HDD: 750GB @ 5400RPM
TDQ
 
Posts: 4
Joined: 6. Mar 2011, 22:21
Location: Toronto
Primary OS: Mac OS X Leopard
VBox Version: OSE other
Guest OSses: Windows 7


Return to VirtualBox on Mac OS X Hosts

Who is online

Users browsing this forum: Knarfje and 19 guests