Error after running VM once.

Discussions related to using VirtualBox on Mac OS X hosts.

Error after running VM once.

Postby spiffyfitz » 19. Feb 2008, 20:06

I just got a new Mac Pro, and I'm trying to use VB on it to use some linux distros. 6 GB of RAM, plenty of hard drive space, lots of processing power. Perfect for running VMs.

So I set up my virtual machine, set it up to install Ubuntu (I give it 256 MB of RAM, nothing too generous), and it runs and installs like a dream. Upon rebooting, I get an error:


Unknown error creating VM.
VBox status code: -32 (VERR_INTERNAL_ERROR).


Result Code: 0x80004005
Component: Console
Interface: IConsole {d5a1cbda-f5d7-4824-9afe-d640c94c7dcf}


This happens every time I run a VM from now on. It doesn't matter if it's a new VM, new VDI, or anything. It always happens. The only way to get rid of it is to reinstall VirtualBox... but even then, after the first run I get the same error.

So I have done some Googling and turned up empty-handed. If anyone can help resolve this problem, I'd appreciate it!

:D :D
spiffyfitz
 
Posts: 2
Joined: 19. Feb 2008, 20:00

Encountered same Error after running VM once

Postby TechieSponge » 22. Feb 2008, 16:44

I got exactly the same error output and had to recreate my Virtual machine to get it running again.

On my second virtual machine I took a snapshot before closing and saving. After trying to start this virtual machine again I encountered the error, but reverted to my snapshot and tried starting up again. This worked!

However, this method did not continue to fix my start up issue. I made several updates to my guest OS CentOS51 i386, and ended up getting stuck in the same error condition, which reverting to the snapshot failed to fix.

Anyone else have a better solution to this problem?
TechieSponge
 
Posts: 2
Joined: 22. Feb 2008, 16:24

Re: Encountered same Error after running VM once

Postby spiffyfitz » 27. Feb 2008, 21:01

TechieSponge wrote:I got exactly the same error output and had to recreate my Virtual machine to get it running again.

On my second virtual machine I took a snapshot before closing and saving. After trying to start this virtual machine again I encountered the error, but reverted to my snapshot and tried starting up again. This worked!

However, this method did not continue to fix my start up issue. I made several updates to my guest OS CentOS51 i386, and ended up getting stuck in the same error condition, which reverting to the snapshot failed to fix.

Anyone else have a better solution to this problem?


interesting note about the snapshop revert... i never tried to do that.

unfortunately for me, every new VM I make now gives the same error. it's frustrating because virtualbox is my VM software of choice, i like it better than VMware fusion. Hopefully someone can help us get out of this problem.
spiffyfitz
 
Posts: 2
Joined: 19. Feb 2008, 20:00

Postby Olaf » 28. Feb 2008, 00:45

Same problem here on MacBook with Mac OS X 10.5.2...

Here it helps just to reboot the MacBook.

The best way seems to be, simply not to shutdown the guest but let it go to sleep if it is unused and put it in background. The problem doesn't seem to occure here as long as one guest is running.

Hopefully the next version will fix this problem and the others (USB-support, brigded-networking, shared folders...)
Olaf
 
Posts: 1
Joined: 28. Feb 2008, 00:21

VERR_INTERNAL_ERROR

Postby anotheruser » 5. Mar 2008, 23:34

Same problem here. OSX 10.4.11 dual core intel

I'm going to try getting a license for vmware fusion
anotheruser
 
Posts: 1
Joined: 5. Mar 2008, 23:30

Postby Rodney » 21. Mar 2008, 14:43

same problem:


Unknown error creating VM.
VBox status code: -32 (VERR_INTERNAL_ERROR).


Result Code:
0x80004005
Component:
Console
Interface:
IConsole {d5a1cbda-f5d7-4824-9afe-d640c94c7dcf}

Too bad, the install and running the vm seemed great! I was impressed, until i shut down the system and tried to restart the vm.
Rodney
 
Posts: 1
Joined: 21. Mar 2008, 00:33

Postby G. I. » 24. Mar 2008, 21:54

I got these:


Unknown error creating VM.
VBox status code: -8 (VERR_NO_MEMORY).

Result Code:
0x80004005
Component:
Console
Interface:
IConsole {d5a1cbda-f5d7-4824-9afe-d640c94c7dcf}



VM creation failed (GVMM).
VBox status code: -32 (VERR_INTERNAL_ERROR).

Result Code:
0x80004005
Component:
Console
Interface:
IConsole {d5a1cbda-f5d7-4824-9afe-d640c94c7dcf}
G. I.
 
Posts: 10
Joined: 26. Oct 2007, 10:42

Postby G. I. » 25. Mar 2008, 10:31

I think it may never happened before I updated my MBP3,1 to 4GB RAM.
G. I.
 
Posts: 10
Joined: 26. Oct 2007, 10:42

Postby jhowk » 27. Mar 2008, 05:45

G. I. wrote:I think it may never happened before I updated my MBP3,1 to 4GB RAM.


it's funny you should say that. I did the same thing as well. I've bumped the new mac pro (not the macbook though) to 4gb as well...
jhowk
 
Posts: 17
Joined: 19. Sep 2007, 00:00
Primary OS: Ubuntu other
VBox Version: PUEL
Guest OSses: Any and All

Postby G. I. » 27. Mar 2008, 10:01

Yeah, that VERR_NO_MEMORY error is also leads in this direction?... Anyways after a machine reboot it works again, I open and close VMs multiple times but keep the main Virtualbox VM app running, looks like it doesn't like to be started more than once (on 4GB RAM?).
G. I.
 
Posts: 10
Joined: 26. Oct 2007, 10:42

Postby G. I. » 30. Mar 2008, 00:37

Failed to allocate 7456 bytes of contiguous memory for the world switcher code.
VBox status code: -8 (VERR_NO_MEMORY).


Result Code:
0x80004005
Component:
Console
Interface:
IConsole {d5a1cbda-f5d7-4824-9afe-d640c94c7dcf}
G. I.
 
Posts: 10
Joined: 26. Oct 2007, 10:42

Postby Buckyjunior » 20. Apr 2008, 21:46

I am getting the same creation error same hex codes.


VM creation failed (GVMM).
VBox status code: -32 (VERR_INTERNAL_ERROR).

Result Code:
0x80004005
Component:
Console
Interface:
IConsole {d5a1cbda-f5d7-4824-9afe-d640c94c7dcf}


This is getting frustrating. It works fine on the Mac Mini with 2GB of RAM. I get a failure on my MacPro with 5GB of RAM.

I'm not sure where to look to solve this. I'm certainly not about to downgrade my RAM. Otherwise on my Mac Mini in the office, it's a great test environment.
Buckyjunior
Buckyjunior
 
Posts: 6
Joined: 20. Apr 2008, 21:28

Ditto on the "VERR_NO_MEMORY" error

Postby zemplar » 25. Apr 2008, 15:36

00:00:02.095 ******************** End of CPUID dump **********************
00:00:02.096 ERROR [COM]: aRC=0x80004005 aIID={d5a1cbda-f5d7-4824-9afe-d640c94c7dcf} aComponent={Console} aText={Unknown error creating VM.
00:00:02.096 VBox status code: -8 (VERR_NO_MEMORY)} aPreserve=false
00:00:02.103 Power up failed (vrc=VERR_NO_MEMORY, hrc=0x80004005)


I'm unable to start any VirtualBox guests with the above error.

My hardware is a MacPro, Leopard 10.5.2, 8GB RAM, and hundreds of GB of disk space available.

Oh well, at least VMware updated Fusion to ver 1.1.2 today to fix the Mac Pro sound issues.
zemplar
 
Posts: 1
Joined: 25. Apr 2008, 15:30

Postby G. I. » 1. May 2008, 20:14

So when will this problem be solved. With over 2GB RAM VB is near to useless.
G. I.
 
Posts: 10
Joined: 26. Oct 2007, 10:42

Postby Buckyjunior » 1. May 2008, 21:00

So, is the problem we're having caused by having too much physical RAM? There was a program that I had some time ago (I forget which and forget when) that failed because of too much RAM.

Yes, it would be terrific if this free program would work with our souped up Macs. I have to remember that I haven't contributed any code to this project, nor have I contributed any €, ¥, or $ to the authors.

VirtualBox continues to work on my 2GB RAM Mac Mini at the office and I picked up a good deal with http://www.macupdate.com. In a ~$75 bundle, there were some programs I wanted, plus Parallels, which runs Win2Kpro so I can see what the rest of the world sees on my web sites.

Best wishes all. I'll be watching for updates.
Bucky
Buckyjunior
 
Posts: 6
Joined: 20. Apr 2008, 21:28

Next

Return to VirtualBox on Mac OS X Hosts

Who is online

Users browsing this forum: No registered users and 18 guests