VirtualBox error while using Vagrant

Discussions related to using VirtualBox on Mac OS X hosts.

VirtualBox error while using Vagrant

Postby hekevintran » 23. Sep 2011, 12:20

I want to use Vagrant to create a virtual machine for a development environment. I am getting an error when it tries to install the virtual machine into VirtualBox. The output of VBoxManage import is below. My colleague is able to run this command without any problem. I am on Mac OS X 10.6.8 and he is on Debian.

Does anyone have an idea of the meaning of this error?

Code: Select all   Expand viewCollapse view
20:41:26:haitran:vagrant $  vagrant up
[default] Box ubuntu1104 was not found. Fetching box from specified URL...
[default] Downloading with Vagrant::Downloaders::HTTP...
[default] Downloading box: http://dl.dropbox.com/u/7490647/talifun-ubuntu-11.04-server-amd64.box
[default] Extracting box...
[default] Verifying box...
[default] Cleaning up downloaded box...
[default] Importing base box 'ubuntu1104'...
The VM import failed! Try running `VBoxManage import` on the box file
manually for more verbose error output.
21:06:54:haitran:vagrant $  VBoxManage import ~/.vagrant.d/boxes/ubuntu1104/box.ovf
0%...10%...20%...30%...40%...50%...60%...70%...80%...90%...100%
Interpreting /Users/haitran/.vagrant.d/boxes/ubuntu1104/box.ovf...
OK.
Disks:  vmdisk1 41943040000     -1      http://www.vmware.com/interfaces/specifications/vmdk.html#streamOptimized       box-disk1.vmdk  -1      -1
Virtual system 0:
 0: Suggested OS type: "Ubuntu_64"
    (change with "--vsys 0 --ostype <type>"; use "list ostypes" to list all possible values)
 1: Suggested VM name "talifun-ubuntu-11.04-server-amd64"
    (change with "--vsys 0 --vmname <name>")
 2: Number of CPUs: 1
    (change with "--vsys 0 --cpus <n>")
 3: Guest memory: 360 MB
    (change with "--vsys 0 --memory <MB>")
 4: Network adapter: orig NAT, config 2, extra slot=0;type=NAT
 5: CD-ROM
    (disable with "--vsys 0 --unit 5 --ignore")
 6: IDE controller, type PIIX4
    (disable with "--vsys 0 --unit 6 --ignore")
 7: IDE controller, type PIIX4
    (disable with "--vsys 0 --unit 7 --ignore")
 8: SATA controller, type AHCI
    (disable with "--vsys 0 --unit 8 --ignore")
 9: Hard disk image: source image=box-disk1.vmdk, target path=/Users/haitran/VirtualBox VMs/talifun-ubuntu-11.04-server-amd64/box-disk1.vmdk, controller=8;channel=0
    (change target path with "--vsys 0 --unit 9 --disk path";
    disable with "--vsys 0 --unit 9 --ignore")
0%...
Progress state: VBOX_E_FILE_ERROR
VBoxManage: error: Could not create the clone medium '/Users/haitran/VirtualBox VMs/talifun-ubuntu-11.04-server-amd64/box-disk1.vmdk' (VERR_GENERAL_FAILURE)
VBoxManage: error: Details: code VBOX_E_FILE_ERROR (0x80bb0004), component Appliance, interface IAppliance, callee
Context: "ImportAppliance" at line 793 of file VBoxManageAppliance.cpp
hekevintran
 
Posts: 1
Joined: 23. Sep 2011, 12:18
Primary OS: Mac OS X other
VBox Version: OSE other
Guest OSses: Ubuntu

Re: VirtualBox error while using Vagrant

Postby mconigliaro » 28. Sep 2011, 18:38

Funny, I'm getting the exact same error. Did you ever find a solution?

Code: Select all   Expand viewCollapse view
$ vagrant up
[default] Box access_manager was not found. Fetching box from specified URL...
[default] Downloading with Vagrant::Downloaders::HTTP...
[default] Downloading box: http://dl.dropbox.com/u/[removed]
[default] Extracting box...
[default] Verifying box...
[default] Cleaning up downloaded box...
[default] Importing base box 'access_manager'...
The VM import failed! Try running `VBoxManage import` on the box file
manually for more verbose error output.
$ VBoxManage import /Users/mikec/.vagrant.d/boxes/access_manager/box.ovf
0%...10%...20%...30%...40%...50%...60%...70%...80%...90%...100%
Interpreting /Users/mikec/.vagrant.d/boxes/access_manager/box.ovf...
OK.
Disks:  vmdisk1   10737418240   -1   http://www.vmware.com/interfaces/specifications/vmdk.html#streamOptimized   box-disk1.vmdk   -1   -1   
Virtual system 0:
 0: Suggested OS type: "RedHat"
    (change with "--vsys 0 --ostype <type>"; use "list ostypes" to list all possible values)
 1: Suggested VM name "vagrant_1317142778"
    (change with "--vsys 0 --vmname <name>")
 2: Number of CPUs: 1
    (change with "--vsys 0 --cpus <n>")
 3: Guest memory: 1024 MB
    (change with "--vsys 0 --memory <MB>")
 4: Network adapter: orig NAT, config 3, extra slot=0;type=NAT
 5: CD-ROM
    (disable with "--vsys 0 --unit 5 --ignore")
 6: IDE controller, type PIIX4
    (disable with "--vsys 0 --unit 6 --ignore")
 7: IDE controller, type PIIX4
    (disable with "--vsys 0 --unit 7 --ignore")
 8: SATA controller, type AHCI
    (disable with "--vsys 0 --unit 8 --ignore")
 9: Hard disk image: source image=box-disk1.vmdk, target path=/Users/mikec/VirtualBox VMs/vagrant_1317142778/box-disk1.vmdk, controller=8;channel=0
    (change target path with "--vsys 0 --unit 9 --disk path";
    disable with "--vsys 0 --unit 9 --ignore")
0%...10%...
Progress state: VBOX_E_FILE_ERROR
VBoxManage: error: Could not create the clone medium '/Users/mikec/VirtualBox VMs/vagrant_1317142778/box-disk1.vmdk' (VERR_GENERAL_FAILURE)
VBoxManage: error: Details: code VBOX_E_FILE_ERROR (0x80bb0004), component Appliance, interface IAppliance, callee
Context: "ImportAppliance" at line 793 of file VBoxManageAppliance.cpp
mconigliaro
 
Posts: 2
Joined: 28. Sep 2011, 18:00
Primary OS: Mac OS X Leopard
VBox Version: OSE other
Guest OSses: Linux

Re: VirtualBox error while using Vagrant

Postby mconigliaro » 28. Sep 2011, 21:28

mconigliaro
 
Posts: 2
Joined: 28. Sep 2011, 18:00
Primary OS: Mac OS X Leopard
VBox Version: OSE other
Guest OSses: Linux


Return to VirtualBox on Mac OS X Hosts

Who is online

Users browsing this forum: No registered users and 9 guests