XP in Seamless Mode - Desktop Mask?

Discussions related to using VirtualBox on Mac OS X hosts.

XP in Seamless Mode - Desktop Mask?

Postby rhman » 12. May 2010, 04:11

I am trying to figure out this minor problem... I have an XP VM installed on Snow Leopard. When I run this in seamless mode, the desktop of the XP machine still is visible in the top left of the Mac desktop. Based on what I have read, in seamless mode, all I should see is the XP taskbar. Here is a partial screen shot to illustrate what I mean.

Image

Is there a way to make no part of the XP desktop wallpaper visible? Thanks!
rhman
 
Posts: 2
Joined: 12. May 2010, 04:01
Primary OS: Mac OS X other
VBox Version: OSE Debian
Guest OSses: Windows XP

(Add Windows 7) Re: XP in Seamless Mode - Desktop Mask?

Postby tonychung » 5. Jun 2010, 03:27

I hate to hijack a topic, but I wanted to share that a similar problem exists on a Windows 7 32-bit guest on an OS X (Snow Leopard) host. Only a portion of the guest OS desktop showed in seamless mode.

The problem went away when I used Mac OS X VirtualBox 3.1.8 with Windows 7 64-bit guest OS. Seamless mode worked perfectly. When I updated to VirtualBox 3.2.0, seamless mode retains the entire guest OS desktop. I just upgraded to 3.2.2 and the entire guest OS desktop still shows.

I installed Guest Additions with 3D GL graphics support. Could that be the problem?

-Tony
tonychung
 
Posts: 6
Joined: 9. Jan 2010, 07:26
Primary OS: Mac OS X other
VBox Version: PUEL
Guest OSses: WinXP, Win2003Server, Ubuntu

Re: XP in Seamless Mode - Desktop Mask?

Postby dilbertjcg » 11. Jun 2010, 06:33

I had this problem too. I did the following. I don't know which fixed it but it could be a combination of them all. Who knows. Either way, here are the fixes. First I uninstalled the guest addition software. Rebooted, then reinstalled and this time didn't check the option for the 3d graphics.

Then I shut down the guest windows system and opened up the Virtualbox.app and selected the Windows machine. Once there I select the display options and disabled 3d and 2d support.

As soon as I rebooted and threw it back into seamless mode it worked perfectly.
dilbertjcg
 
Posts: 1
Joined: 11. Jun 2010, 06:22
Primary OS: Mac OS X Leopard
VBox Version: OSE other
Guest OSses: Windows 7

Re: XP in Seamless Mode - Desktop Mask?

Postby marinkovic.dragan » 12. Jun 2010, 10:18

I had the same problem with VrtualBox 3.2.4 for Mac OSX Leopard running WinXP as a guest. I've shutdown guest OS, disabled both 2D and 3D acceleration and booted WinXP guest. Seamless mode started working without problems. Disabling only one of the acceleration options didn't really help.
marinkovic.dragan
 
Posts: 3
Joined: 12. Jun 2010, 10:05
Primary OS: Mac OS X Leopard
VBox Version: OSE other
Guest OSses: Windows XP

Re: XP in Seamless Mode - Desktop Mask?

Postby jake123 » 12. Jun 2010, 11:05

I'd been having trouble with Seamless mode in 3.2.x and tried the above and it worked. Thank you!

Just an extra note, I found I could leave 3D acceleration enabled (only disable 2D acceleration) and it still worked too.
jake123
 
Posts: 1
Joined: 11. Nov 2009, 20:18
Primary OS: Mac OS X other
VBox Version: PUEL
Guest OSses: Windows XP

Re: XP in Seamless Mode - Desktop Mask?

Postby marinkovic.dragan » 12. Jun 2010, 20:47

Thanks. I've been lazy and haven't tried all 2D/3D combinations :) I'll try leaving 3D acceleration enabled, and see if it works for me.
marinkovic.dragan
 
Posts: 3
Joined: 12. Jun 2010, 10:05
Primary OS: Mac OS X Leopard
VBox Version: OSE other
Guest OSses: Windows XP

Re: XP in Seamless Mode - Desktop Mask?

Postby marinkovic.dragan » 12. Jun 2010, 21:02

Yup, I've enabled 3D accel leaving 2D accel disabled, and seamless mode still works. Thanks!
marinkovic.dragan
 
Posts: 3
Joined: 12. Jun 2010, 10:05
Primary OS: Mac OS X Leopard
VBox Version: OSE other
Guest OSses: Windows XP

Re: XP in Seamless Mode - Desktop Mask?

Postby tonychung » 25. Jun 2010, 07:09

Hi all! I just wanted to confirm that the following restored seamless mode operation on Mac OS X host, VBox 3.2.4 with Windows 7 guest:
1) Shut down guest OS.
2) Disable 2D acceleration.
3) Restart guest OS.

Note this only works with a single monitor. I'm not sure what happened when I tried adding a second monitor, but seamless mode didn't work at all! Plus, the second monitor was blank.

I'd really like to figure out how to get seamless mode working on the secondary monitor, or use both monitors like the Mac. But I'm happy for now.

Thanks for all the tips. VBox and this forum are great!

-Tony
tonychung
 
Posts: 6
Joined: 9. Jan 2010, 07:26
Primary OS: Mac OS X other
VBox Version: PUEL
Guest OSses: WinXP, Win2003Server, Ubuntu

Re: XP in Seamless Mode - Desktop Mask?

Postby ZeB » 25. Jun 2010, 18:40

This problem still occurs in last public release (3.2.6) with last GA installed.

(but the last release fixes lots of bugs, so let's have patience, and keep 2D acceleration off for now :) )


[EDIT] New ticket opened here : http://www.virtualbox.org/ticket/7076
ZeB
 
Posts: 16
Joined: 8. May 2008, 16:52

Re: XP in Seamless Mode - Desktop Mask?

Postby dafyre » 15. Jul 2010, 15:33

I have my XP/SP3 guest setup and working succesfully with two virtual screens (not in seamless mode), and everything works well from what I can see. In single window mode, you can now leave 2D enabled. For the two screen mode, when you activate Seamless mode and 2D is disabled, I get a proper Seamless mode for screen one. However, the (Windows XP) background for screen two still shows. Upon opening my first Windows XP application, the XP Background disappears returning my OS X desktop anda ll of the windows behind it into view (regardless of which screen the app opens on). :shock:

Sounds like they're getting closer. Should I put in a new ticket for this or add it to the existing one linked above?

edit: After using the system a bit, a portion of the Windows XP Background returned! :|
See yas
~DaFyre
dafyre
 
Posts: 3
Joined: 26. Aug 2008, 18:15

Re: XP in Seamless Mode - Desktop Mask?

Postby kurbads » 7. Apr 2013, 19:56

Let me add my bit:

1) After fresh guest OS/add-on install, seamless mode worked.
2) Then after accidentally entering scale mode (which I did by pressing Host+C instead of Ctrl+C to copy text) and then switching to seamless mode it showed desktop over most of the screen.
3) I tried to disable 2D/3D, but found them disabled.
4) I reinstalled the guest add-ons with 3D experimental enabled which required Safe Mode to install.
5) I increased the video memory to 128Mb and enabled both 2D and 3D in settings.
6) Everything works now.

To prove the concept I again entered scale mode Host+C and the seamless mode Host+L. I've got the background back but it cleared when I clicked the start menu.

System:
Host: ML 10.8.3 on Intel NUC
Guest: nLite stripped XP
RAM: 8GB
kurbads
 
Posts: 1
Joined: 7. Apr 2013, 19:38


Return to VirtualBox on Mac OS X Hosts

Who is online

Users browsing this forum: Yahoo [Bot] and 28 guests