Version 3.0.8 on Snow Leopard hangs

Discussions related to using VirtualBox on Mac OS X hosts.

Version 3.0.8 on Snow Leopard hangs

Postby jrmac » 27. Oct 2009, 06:21

I have read many of the related posts and checked my fonts. There do not appear to be any duplicates.

I am using a MacBook with 10.6.1, 4GB Ram, and 2.26 GHz Intel Duo.

A lot of this is over my head. I want to know if I do indeed need to first install and successfully launch VB before attempting to install my newly purchased Windows 7. I also just bought the MacBook and used Migration Assistant to transfer all the files from my old PB G4 with OS 10.4.11. I performed all updates available on the new MacBook and have reinstalled VB 2 times with the same problem. I launch VB and after about 2 seconds I get the spinning rainbow pinwheel.
jrmac
 
Posts: 5
Joined: 27. Oct 2009, 06:06
Primary OS: Mac OS X Leopard
VBox Version: PUEL
Guest OSses: windows 7

Re: Version 3.0.8 on Snow Leopard hangs

Postby ginopunsalan » 27. Oct 2009, 10:40

I have a Late 2007 MacBook 2.2ghz, 4gb ram, 128mb video ram. This is how I installed Windows 7 RC:

- Installed VirtualBox 3.0.8
- Created 20gb virtual hard drive
- Created 1gb virtual memory
- Installed Windows 7 RC
- Installed Guest Additions (Devices>Install Guest additions)
- Downloaded and installed Realtek ICH AC97 audio drivers
- Shut down Windows
- Plugged and install each usb plug and plat device in Settings>Details>USB
- In Settings>Details>Network, I bridged the default network adapter to en1:Airport
- Launched Windows 7 rc and enjoyed!
ginopunsalan
 
Posts: 13
Joined: 21. Oct 2009, 04:44
Primary OS: Mac OS X other
VBox Version: OSE other
Guest OSses: Windows 7 RC

Re: Version 3.0.8 on Snow Leopard hangs

Postby jrmac » 29. Oct 2009, 17:37

ginopunsalan

**Thanks for your reply.

- Installed VirtualBox 3.0.8

**Ok, Thanks. I did step 1 like you did--I installed v. 3.0.8; and when I launch VBox it just spins--I have to force quit.

- Created 20gb virtual hard drive
- Created 1gb virtual memory

**Don't you create the 20G Virtual Drive and the 1gb virtual memory using VBox? Or do you use something else to do this ahead of time? Because I can't do anything with VBox.

jrmac
jrmac
 
Posts: 5
Joined: 27. Oct 2009, 06:06
Primary OS: Mac OS X Leopard
VBox Version: PUEL
Guest OSses: windows 7

Re: Version 3.0.8 on Snow Leopard hangs

Postby drowe » 30. Oct 2009, 02:19

I am also getting a problem with VirtualBox hanging immediately after launch.

I used to run under MacOS 10.5 and VirtualBox ran perfectly well with guest OS: Ubuntu 9.04 and Fedora 11.

I then upgraded Macos to 10.6.1 and Virtualbox no longer starts up. When you click on the VB icon in the dock, the main widow opens saying 'Welcome to VirtualBox', the cursor turns to the spinning wheel - and thats it. The application hangs. The Virtualbox menu never appears at the head of the window. You can however switch to other programs - so it is VB that is hanging - not the system as a whole. You cannot get VB to respond to anything, so the only way out is to force quit.

I have tried:
Uninstalling and then reinstalling VB to version 3.0.8
Upgrading to the latest 3.0.10
Going to my home directory and trashing
~/Library/Preferences/org.virtualbox.app.VirtualBox.plist
~/Library/Preferences/org.virtualbox.app.VirtualBoxVM.plist
~/Library/VirtualBox/*

But to no avail.

Are there any suggestions on how to get round this problem? Does anyone have VB working under Snow Leopard?

David Rowe
drowe
 
Posts: 1
Joined: 30. Oct 2009, 01:14
Primary OS: Mac OS X other
VBox Version: PUEL
Guest OSses: Ubuntu 9.04

Re: Version 3.0.8 on Snow Leopard hangs

Postby jrmac » 30. Oct 2009, 08:41

I just tried the upgrade to VB 3.0.10 and I still get the same response. Dave, you described it better. Thanks.

I watched a utube by Stevesmacfix on installing Vbox and did it just like he showed. Opened it up and it just starts spinning.

Jay
jrmac
 
Posts: 5
Joined: 27. Oct 2009, 06:06
Primary OS: Mac OS X Leopard
VBox Version: PUEL
Guest OSses: windows 7

Re: Version 3.0.8 on Snow Leopard hangs

Postby jrmac » 1. Nov 2009, 05:46

Ok, I have tried versions 3.0.8, then 3.0.10, and then went back and tried 3.0.6. I uninstalled the previous version each time. On the Force Quit Reasons, it all seems the same each time to me, but it is a very long report and I know basically nothing about the information in the Reasons report.

I still start Vbox and it hangs with the spinning cursor each time. I am copying in the beginning section only of the Reasons report in the hope someone else may be able to see something to help me track down the problem. In this report, about the only differences I can see in the different times I have looked at it with the different versions were the leading number in the "user stack part," which in this pasted report was "9".

I will take any inputs, please.

***
Date/Time: 2009-10-31 01:57:34 -0700
OS Version: 10.6.1 (Build 10A2047)
Architecture: x86_64
Report Version: 6

Command: VirtualBox
Path: /Applications/VirtualBox.app/Contents/MacOS/VirtualBox
Version: 3.0.6 (3.0.6)
Parent: launchd [123]

PID: 809
Event: hang
Duration: 2.99s (sampling started after 2 seconds)
Steps: 9 (100ms sampling interval)

Pageins: 0
Pageouts: 0


Process: VirtualBox [809]
Path: /Applications/VirtualBox.app/Contents/MacOS/VirtualBox
UID: 501


Process: AirPort Base Station Agent [204]
Path: /System/Library/CoreServices/AirPort Base Station Agent.app/Contents/MacOS/AirPort Base Station Agent
UID: 501

Thread 95c57a8 DispatchQueue 1
User stack:
9 ??? (in AirPort Base Station Agent + 5344) [0x1000014e0]
9 ??? (in AirPort Base Station Agent + 70666) [0x10001140a]
9 CFRunLoopRun + 70 (in CoreFoundation) [0x7fff804a4dc6]
9 CFRunLoopRunSpecific + 575 (in CoreFoundation) [0x7fff804a503f]
9 __CFRunLoopRun + 2002 (in CoreFoundation) [0x7fff804a5ce2]
9 mach_msg_trap + 10 (in libSystem.B.dylib) [0x7fff815a8d5a]

(FROM HERE THERE ARE MANY SOMEWHAT REPETITIVE SECTIONS THAT LOOK LIKE THIS AND QUITE A LARGE REPORT)
jrmac
 
Posts: 5
Joined: 27. Oct 2009, 06:06
Primary OS: Mac OS X Leopard
VBox Version: PUEL
Guest OSses: windows 7

Re: Version 3.0.8 on Snow Leopard hangs

Postby jrmac » 1. Nov 2009, 08:09

I just created a new user and installed v. 3.0.10. Now it works fine and I am installing Windows 7 with no apparent problems so far.

So I must have a glitch somewhere from when I bought the new MacBook and used Migration Assistant to import all my files and settings from my Powerbook G4 12" using OS 10.4.11.
jrmac
 
Posts: 5
Joined: 27. Oct 2009, 06:06
Primary OS: Mac OS X Leopard
VBox Version: PUEL
Guest OSses: windows 7

Re: Version 3.0.8 on Snow Leopard hangs

Postby emiliano » 3. Nov 2009, 22:41

Here is my small experience with 3.0.8 on Snow Leopard Server:

Fresh install of Snow Leopard Server on a MacBookPro 2,2, then updated to 10.6.1, then installed VirtualBox 3.0.8.
I'm running a few SystemRescueCD (a Gentoo based livecd) virtual machines without virtual hard drive (to test the virtual networking). All the VM are running in console (no X11) and everything work really fine.
emiliano
 
Posts: 3
Joined: 3. Nov 2009, 22:24
Primary OS: Mac OS X other
VBox Version: PUEL
Guest OSses: Linux


Return to VirtualBox on Mac OS X Hosts

Who is online

Users browsing this forum: AMT7565 and 13 guests