Page 1 of 1

Disable menu bar in fullscreen mode

PostPosted: 26. Aug 2009, 21:00
by qqilihq
Hi,

is it possible to disable the displaying of the menu bar when I touch the upper screen edge with my mouse cursor? It is pretty annoying for my workflow as I have my Ubuntu toolbar at the upper screen edge.

I already tried
Code: Select all   Expand viewCollapse view
VBoxManage setextradata global GUI/Customizations noMenuBar,noStatusBar
, but this does not help for my particular problem.

Regards,
qqilihq.

Re: Disable menu bar in fullscreen mode

PostPosted: 27. Aug 2009, 00:30
by Perryg
Have you tried to open the VBox program GUI and then in Settings -> General -> Advanced, take the check mark out of the mini toolbar?

Re: Disable menu bar in fullscreen mode

PostPosted: 27. Aug 2009, 08:04
by qqilihq
Yes, but this has no effect on the Mac’s menu bar.

Re: Disable menu bar in fullscreen mode

PostPosted: 27. Aug 2009, 11:33
by Sasquatch
So you're not talking about the mini-toolbar that was added in 3.0.0. In that case, you have to look for the problem on your Host itself. Do other fullscreen applications have the same problem (like browser, video, or picture viewer)?

Re: Disable menu bar in fullscreen mode

PostPosted: 28. Aug 2009, 08:37
by qqilihq
There are fullscreen applications on the mac which do not show the menu bar when touching the upper screen edge (like Skim). So, in principle this is definitely possible in Mac OS X.

Re: Disable menu bar in fullscreen mode

PostPosted: 29. Aug 2009, 05:27
by mocha
yep, i agree this can be real aggravating. and now with the mini-toolbar there is even less reason for the regular mac menu bar to pop down when you get too close to the top edge of the screen. there should be a preference to disable this.

Re: Disable menu bar in fullscreen mode

PostPosted: 29. Aug 2009, 10:00
by qqilihq
… I found out, that there is already a ticket for this:

http://www.virtualbox.org/ticket/4866

Let’s hope this will be added in the future.

Re: Disable menu bar in fullscreen mode

PostPosted: 6. Sep 2009, 23:06
by iVirtualize
Perryg wrote:Have you tried to open the VBox program GUI and then in Settings -> General -> Advanced, take the check mark out of the mini toolbar?


I was looking for how to do this. I was blind, and didn't see it. Thanks.

Re: Disable menu bar in fullscreen mode

PostPosted: 11. Sep 2009, 22:17
by fhellwig
I too want to echo my desire for disabling this feature. It's distracting to get the Mac OS menu bar when trying to close a maximized window (the close button is just a few pixels away).

It is also pretty useless since the dock does not persist. As an aside, I have found using spaces works especially well on the Mac - left side for Mac, right side for Windows VM (full screen). The intrusion of the menu bar distracts from this full screen experience.

Re: Disable menu bar in fullscreen mode

PostPosted: 16. Oct 2009, 17:42
by hooby3d
If I disable mouse integration this stop happening. But it would be nice for it to work without doing that!

Re: Disable menu bar in fullscreen mode

PostPosted: 28. Sep 2011, 03:24
by ulysestemp@gmail.com
As of VirtualBox 4.1.2 on OS X 10.7.1 (Lion), the preference to hide the menu bar (untick "auto show" in the global preferences pane) only works when changing INTO full screen mode. That is, if you VM starts up already in full screen, the menu bar is not hidden. Also, if you change to another Mac desktop then back to the full screen VM, the menu bar is re-enabled. What an annoying bug! I have made an Applescript to press Command-F twice after starting the VM, so that the menu bar will stay hidden.

Re: Disable menu bar in fullscreen mode

PostPosted: 5. Dec 2011, 11:57
by bulletmark
As above, I agree this is incredibly annoying. Does anybody know if there is a bug raised on this?

Re: Disable menu bar in fullscreen mode

PostPosted: 6. Dec 2011, 01:54
by bulletmark
To follow my above post up, yes there are bugs 6817 and 9570 open on this frustrating issue (I am not allowed to post direct links yet sorry). Both bugs have been around for ages which really surprises me given it seems a trivial issue to address?

Re: Disable menu bar in fullscreen mode

PostPosted: 28. Nov 2014, 01:14
by Maestro
See below for the solution that worked for me, on OSX 10.9 (Mavericks).

This issue seems to have been in and out of forums for the last 5 years or so. The most commonly suggested solution is to edit the VirtualBox Info.plist file and add LSUIPresentationMode = 4. Documentation can be found on the apple developer website, under: information property (plist) key reference -> launch services keys.

This should work for most apps, but because of how VirtualBox operates, it only provides a temporary fix. Switching apps, exiting full-screen or changing spaces causes the menu to re-appear. My solution is to force VirtualBoxVM.app (NOT VirtualBox.app), to run as an agent app; by editing it's Info.plist file. This has the effect of disabling the menu bar (in windowed AND fullscreen mode) and also, unfortunately, removing the virtual machine from the application switcher. On Mavericks, the dock will still appear in fullscreen after moving the cursor to the bottom of the screen, and then moving it down again. It is actually quite difficult to get it to appear, so this seems to be an adequate solution. After starting the virtual machine, or exiting fullscreen, the menu bar may reappear. But it is non-functional, and will disappear after switching apps, etc. This is a hack that achieves the goal of disabling the VirtualBox menu bar in fullscreen, but it also causes some weird behaviour and is not the best solution; but it may be of use to you.

Proviso:
Editing plist files can damage your apps or operating system; so keep backups of the original plist files, and don't change anything unless you understand what you are doing. You have been warned! This method also uses a text editor to modify the plist files, which can cause file corruption if there are any non-unicode characters present in the plist files (a distinct possibility). I have not had any issues yet, but you can use a different method if you are worried (i.e. a plist editor app, or defaults.write in terminal). Some plist files are encoded in binary, and further steps will be necessary if you are trying to edit them.

Method:
Go to Applications Folder

Right click on VirtualBox.app > Show Package Contents. Go to Contents/Resources; right click on VirtualBoxVM.app > Show Package Contents.

You won't have write permissions for the Info.plist file, so an easy option is to copy it the desktop; make the required additions; then move it back and overwrite the original file (admin password required). Copy this file (not the VirtualBox.app one!): Applications/VirtualBox.app/Contents/Resources/VirtualBoxVM.app/Contents/Info.plist

Add this line to the copied Info.plist file using a good text editor (I use gedit): " <key>LSUIElement</key> <string>1</string>", without the quotation marks. The command needs to be inserted at the correct place, i.e. between "LSCanProvideIMVideoDataSource" and "NSHighResolutionCapable"; or else it will not work.

Make sure VirtualBox is not running and move the Info.plist file back to the original location; overwriting the one inside VirtualBoxVM.app/Contents (admin password required).

OS X Mavericks actually keeps plist data in RAM, so logging out, restarting, or resetting the parameter RAM may be also be required before the Info.plist file changes will take effect. Then launch VirtualBox.app, and start up your virtual machine. The VirtualBox.app menu should still be there, but the VirtualBoxVM.app instance will lose its menu bar and application switcher icon.