Page 1 of 1

Networking issues with 3.0.0 and VT-x/AMD-V enabled.

PostPosted: 2. Jul 2009, 08:54
by Hajitorus
Hi,

I'm running a Windows XP virtual machine on my MacBook Pro. I'm pretty much only using it for the ability to run Cisco's Fabric Manager (mostly just an SNMP frontend for Cisco fabric switches). I noticed that after the upgrade to the 3.0.0 BETA as well as the 3.0.0 release, Fabric Manager was operating incorrectly. Today I tried reinstalling 2.2.4 to get it working again, and noticed that that resolved my issue. However, I also glanced through the release notes and saw:

"VMM: performance improvements for network I/O (VT-x/AMD-V only)"

Tried disabling the VT-x/AMD-V, and this resolved my issue. Just wanted to provide the forums/Google some juice to let other people know if they're experiencing this issue. I don't use my VM for very much aside from Fabric Manager and Software Update, so I'm not sure if this issue has been reported as some wider networking breakage. (Couldn't find anything via the forum search.)

Short version: 3.0.0 breaks (at least some) networking on my Macbook Pro running Mac OS X, primarily for Cisco Fabric Manager. Disable VT-x/AMD-V to resolve. (Settings -> System -> Acceleration).

Edited to add: Device Manager still fails though. Downgrading to 2.2.4 to get things working again.

Re: Networking issues with 3.0.0 and VT-x/AMD-V enabled.

PostPosted: 3. Jul 2009, 16:16
by netballi
hi

I have recently loaded Virtualbox 3.0.0 on my Mac OS 10.5.5 and trying to run a xp system in it but the as soon as I start the virtual machine I get error stating cannot find VT-x/AMD-V which is enabled by default. i cannot disable it as it is greyed out.

Any suggestion how to disable VT-x/AMD-V .

Netballi :?: