ERROR: VT-X is not avaiable

Discussions related to using VirtualBox on Mac OS X hosts.

Re: ERROR: VT-X is not avaiable

Postby nickggr » 1. Jan 2010, 05:44

Hello everyone,
I am new here and had the same issue with Virtualbox.
Just editing the XML file did not work for me. Every time I opened Virtualbox the XML file was overwritten again, enabling the Hardware Virtualization option.

According to this link you not only have to edit the file, but they say that you need to lock the file before running Virtualbox again. I followed their suggestion and it worked. I thought that it might help you.
nickggr
 
Posts: 1
Joined: 1. Jan 2010, 05:39
Primary OS: Mac OS X Leopard
VBox Version: OSE other
Guest OSses: Windows XP, Linux

Re: ERROR: VT-X is not avaiable

Postby pvgorp » 19. Jan 2010, 11:58

I get the "no vt-x" available error" (VERR_VMX_NO_VMX) on Ubuntu 8.10 (kernel 2.6.28-17-generic) on an Intel Q9650 with VT-X enabled in the BIOS (3 checkboxes enabled).

According to http://ark.intel.com/Product.aspx?id=35428, VT-X should however be available for that processor. I already recompiled the VirtualBox kernel modules (sudo /etc/init.d/vboxdrv setup) but that doesn't solve the problem. Obviously, I also restarted VirtualBox. Bypassing the VirtualBox GUI (using VBoxManage ... --cpus) does not help either.

The reason that I'm trying to enable VT-X is that I want to use more than one processor core for my VMs...

Is there any other level (Ubuntu host OS perhaps?) where I should enable some property before VT-X becomes available to VirtualBox?

Looking forward to your reply, thanks in advance,
Pieter Van Gorp
pvgorp
 
Posts: 34
Joined: 5. Nov 2008, 10:11

Re: ERROR: VT-X is not avaiable

Postby pvgorp » 19. Jan 2010, 12:06

I just notice that this is an OS X related subsection of the forum. I am very sorry if my message is therefore off- :oops: topic.

Please let me know if I should repost, or (admin) please feel free to move the message to another subsection...

Regards,
Pieter
pvgorp
 
Posts: 34
Joined: 5. Nov 2008, 10:11

Re: ERROR: VT-X is not avaiable

Postby vbox4me2 » 19. Jan 2010, 12:06

Did you try the vt-x tricks from the FAQ? sometimes vt-x bios options don't always mean vt-x gets enabled, ea. 2 out of 3 enabled=vt-x on or something in that order.
vbox4me2
Volunteer
 
Posts: 5218
Joined: 21. Nov 2008, 20:27
Location: Rotterdam

Re: ERROR: VT-X is not avaiable

Postby pvgorp » 19. Jan 2010, 12:34

OMG... didn't know about the need to unplug the power cord etc...

Will try those hints with our sysadmin now...

Thanks for the pointer to viewtopic.php?t=8669

Sincerely,
Pieter
pvgorp
 
Posts: 34
Joined: 5. Nov 2008, 10:11

Re: ERROR: VT-X is not avaiable

Postby pvgorp » 19. Jan 2010, 13:15

Solved: now we have only the first option for hardware virtualization enabled in the BIOS.

The other 2 (related to I/O stuff) are disabled. Otherwise, it wouldn't work.

Thanks for pointing out and best regards,
Pieter
pvgorp
 
Posts: 34
Joined: 5. Nov 2008, 10:11

Re: ERROR: VT-X is not avaiable

Postby albatroz » 15. May 2011, 21:38

I am using version 4.0.6 of Virtualbox on a t5800 core2duo HP Pavillion laptop and I am getting the same error.
After looking into the XML file mentioned I found that the format of the XML file seems different as you can see below:

<Hardware version="2">
<CPU count="1" hotplug="false">
<HardwareVirtEx enabled="false" exclusive="false"/>
<HardwareVirtExNestedPaging enabled="true"/>
<HardwareVirtExVPID enabled="true"/>
<PAE enabled="true"/>
<HardwareVirtExLargePages enabled="false"/>
<HardwareVirtForce enabled="false"/>
</CPU>

¿Any ideas?
albatroz
 
Posts: 1
Joined: 15. May 2011, 21:30
Primary OS: MS Windows 7
VBox Version: OSE other
Guest OSses: linux

Re: ERROR: VT-X is not avaiable

Postby Perryg » 15. May 2011, 23:19

t5800 core2duo does not support hardware-virtualization (VT-x)
http://ark.intel.com/Product.aspx?id=35581
Perryg
Site Moderator
 
Posts: 33868
Joined: 6. Sep 2008, 22:55
Primary OS: Linux other
VBox Version: OSE self-compiled
Guest OSses: *NIX

Re: ERROR: VT-X is not avaiable

Postby nicpaillard » 11. Aug 2011, 16:26

The location of the file has changed under OSX.

It now resides in ~/user/VirtualBox VMs/

The file is no longer called XXXXX.xml but XXXXX.vbox. In all respect, it's a xml file and you can still edit it with Textedit.

The right settings that worked for me are:
Code: Select all   Expand viewCollapse view
      <CPU count="1" hotplug="false">
        <HardwareVirtEx enabled="false" exclusive="false"/>
        <HardwareVirtExNestedPaging enabled="false"/>
        <HardwareVirtExVPID enabled="false"/>
        <PAE enabled="false"/>
        <HardwareVirtExLargePages enabled="false"/>
        <HardwareVirtForce enabled="false"/>
      </CPU>


I hope that helps someone.
nicpaillard
 
Posts: 1
Joined: 11. Aug 2011, 16:21
Primary OS: Mac OS X other
VBox Version: OSE other
Guest OSses: WinXP

Re: ERROR: VT-X is not available

Postby nmiller » 23. Aug 2011, 08:26

Rather than editing the <VMname>.vbox file with a text editor, you can just issue the following command in a Terminal after shutting down VirtualBox:
Code: Select all   Expand viewCollapse view
VBoxManage modifyvm <VMname> --hwvirtex off


HTH--
=N=
nmiller
 
Posts: 8
Joined: 9. Feb 2010, 22:31
Primary OS: OpenSolaris 10
VBox Version: PUEL
Guest OSses: XP, Linux, Solaris 10

Re: ERROR: VT-X is not avaiable

Postby the_oracle » 31. Aug 2013, 06:01

Realize this thread is old..but for anybody googling forums for a solution as i was, something worth noting = If virtual memory for the machine is set to anything higher than 3584 MB, you will receive this error when trying to boot 32-bit software. :oops:
the_oracle
 
Posts: 1
Joined: 31. Aug 2013, 05:57

Previous

Return to VirtualBox on Mac OS X Hosts

Who is online

Users browsing this forum: No registered users and 8 guests