Win Me on XP (More or less solved)

Discussions about using Windows guests in VirtualBox.

Win Me on XP (More or less solved)

Postby scbs29 » 26. Apr 2009, 19:22

Hello all
I dual boot between PCLinuxOS and XP.
I successfully installed XP in VirtualBox 2.2 in PCLos, and I am now trying
to install Win Me in VirtualBox 2.2 in XP.
I tried Win95 initially but as you can imagine I had no success at all.
I have been using a dos 6.2 boot disk and a WinMe iso for the cd.
For trying Me in XP I boot the virtual machine with a dos6.2 boot disk, then cd to d:,
which is the cd (Win Me iso) and enter setup.
Installation proceeds ok, switching the cd to a Win95 iso for previous os that satisfies the
upgrade criterion, then switching back to the Win Me iso.
Installation goes ok until I reach the part where the installation wants to create a boot floppy.
then whether I say to create the boot floppy or not I get the error
Application Error
SUWIN caused a general protection fault in module
user.exe at 001:5189

Can anyone help ?
TIA
scbs29
 
Posts: 10
Joined: 26. Apr 2009, 19:10
Primary OS: PCLinuxOS
VBox Version: PUEL
Guest OSses: XP

Re: Win Me on XP (More or less solved)

Postby scbs29 » 27. Apr 2009, 15:36

Managed to sort this out eventually.
Created Me vdi in XP. Booted using DOS boot disk, fdisk and format
for the vdi. Installed DOS 6.22. Then installed Me from cd iso using a Win95
iso for the qualifying software for upgrade. Installation kept falling over for
various reasons when setting up. I then took a snapshot and tried booting the vdi again.
Finally booted. Took a long time, about 1 1/2 hours
for the setting up after installation, but works. Problem is it runs extremely slowly,
possibly too slowly for what I want.
Then tried Me in Vbox onPCLinuxOS.
Created vdi, tried to boot from DOS boot floppy, just hung. Tried from DOS floppy
iso, same problem. Tried to boot using DOS6.22 iso and it kept asking for the setup
disks in drive E:
In the end copied vdi from XP, associated it with the hard disk in Vbox, booted and
let it do its thing. Eventually I had a working Me. Still runs very slowly but I think faster
than on XP.
scbs29
 
Posts: 10
Joined: 26. Apr 2009, 19:10
Primary OS: PCLinuxOS
VBox Version: PUEL
Guest OSses: XP


Return to Windows Guests

Who is online

Users browsing this forum: No registered users and 12 guests