VBoxManage problem

Discussions related to using VirtualBox on Mac OS X hosts.

VBoxManage problem

Postby pensak » 9. Apr 2009, 05:13

I just upgraded to 2.2 today. My VM's all work just fine

However - every command I issue to VBoxManage (even ones like showvminfo) return the following message

VirtualBox Command Line Management Interface Version 2.2.0
(C) 2005-2009 Sun Microsystems, Inc.
All rights reserved.

WARNING! The following VirtualBox settings files have been automatically
converted to the new settings file format version '1.7-macosx':

/var/root/Library/VirtualBox/VirtualBox.xml (1.3-macosx)

The current command was aborted to prevent overwriting the above settings
files with the results of the auto-conversion without your permission.
Please put one of the following command line switches to the beginning of
the VBoxManage command line and repeat the command:

--convertSettings - to save all auto-converted files (it will not
be possible to use these settings files with an
older version of VirtualBox in the future);
--convertSettingsBackup - to create backup copies of the settings files in
the old format before saving them in the new format;
--convertSettingsIgnore - to not save the auto-converted settings files.

Note that if you use --convertSettingsIgnore, the auto-converted settings files
will be implicitly saved in the new format anyway once you change a setting or
start a virtual machine, but NO backup copies will be created in this case.

I've tried putting the --convertSettings into the command line both before and after the showvminfo and I still get the exact same message above.

I know I am going to feel very stupid when someone tells me what I am doing wrong, but I don't have too many more hairs to pull out.
Posts: 4
Joined: 9. Apr 2009, 05:04
Primary OS: Mac OS X Leopard
VBox Version: PUEL
Guest OSses: Windows xp

Re: VBoxManage problem

Postby SlaunchaMan » 9. Apr 2009, 06:33

/private/var/root is the root user's home directory. If you're getting that error message, try running your commands as root to see if that clears it up (though you probably shouldn't run VirtualBox as root if you don't have to).
Posts: 65
Joined: 6. Apr 2009, 22:28
Location: Detroit, MI
Primary OS: Mac OS X other
VBox Version: PUEL
Guest OSses: Ubuntu 18.04

Re: VBoxManage problem

Postby schtebo » 11. Apr 2009, 12:18

i have the same problem, i upgraded from virtualbox2-1 to virtualbox2-2

could someone plaese give me an exampele how to use the "--convertsettings" command?

thank you
Posts: 25
Joined: 11. Apr 2009, 12:16
Primary OS: Debian Lenny
VBox Version: OSE Debian
Guest OSses: windows 7/xp, debian lenny / ubuntu lucidlynx

Re: VBoxManage problem

Postby OSX@Linux » 14. Apr 2009, 02:24

"sudo VirtualBox --convertsettings"

I think that's what I did and it worked :wink:
Posts: 28
Joined: 13. Apr 2009, 01:37
Location: San Diego, CA
Primary OS: Mac OS X Leopard
VBox Version: PUEL
Guest OSses: Windows XP

Re: VBoxManage problem

Postby tatoon » 14. Apr 2009, 18:27

Type it like this:

VBoxManage --convertSettings list vms

It will upgrade all your vm's files.
Posts: 4
Joined: 14. Apr 2009, 18:25
Primary OS: Linux other
VBox Version: OSE other
Guest OSses: Windows XP

Return to VirtualBox on Mac OS X Hosts

Who is online

Users browsing this forum: No registered users and 14 guests