Audio CDs are not recognized in Windows guest

Discussions related to using VirtualBox on Mac OS X hosts.

Audio CDs are not recognized in Windows guest

Postby wdonne » 3. Mar 2009, 15:52

Hi,

I have a Mac OS X 10.5.6 host and a Windows XP SP3 guest with the CD-ROM device mounted.
When I insert an audio CD it is visible in Explorer but it is not recognized as an audio CD.
Windows Media Player, for example, says an audio CD should be inserted. This problem also
existed when the guest was still at SP2. Audio works fine in the guest.

Best regards,

Werner.
wdonne
 
Posts: 9
Joined: 23. Dec 2008, 20:24

Re: Audio CDs are not recognized in Windows guest

Postby tkwm » 3. Mar 2009, 16:47

I havn't tried this by myself, but may be it helps if you activate Passthrough for the cd-drive in the vm's properties and insert the cd when the guest already has started.
tkwm
Volunteer
 
Posts: 147
Joined: 3. Mar 2008, 17:56

Re: Audio CDs are not recognized in Windows guest

Postby wdonne » 3. Mar 2009, 18:06

Thanks for your reply. With Passthrough on the CD is indeed recognized as an audio CD, but it doesn't
work. When I double click on it in Explorer, Windows Media Player is launched and shows the title
of the CD, but it doesn't start to play. In the meantime Explorer hangs. I have also tried Creative
Media Source, which also recogizes the CD as an audio CD, but it hangs too. In both cases I have to
kill the tasks.

Werner.
wdonne
 
Posts: 9
Joined: 23. Dec 2008, 20:24

Re: Audio CDs are not recognized in Windows guest

Postby tkwm » 3. Mar 2009, 18:14

And I guess you have tried this with different audio-cd's, so that the reason is not a copyprotection-mechanism - right?
May be the situation changes if you select in the Mac's Systempreferences under CD&DVD for Inserting AudioCDs - No Action.
tkwm
Volunteer
 
Posts: 147
Joined: 3. Mar 2008, 17:56

Re: Audio CDs are not recognized in Windows guest

Postby wdonne » 3. Mar 2009, 19:00

There is no copy-protection on the CDs. I tried with the default action off on the host, but that doesn't
change anything. The default action is anyway blocked until the guest is shutdown or unmounts the
CD.

By the way, the VirtualBox version is 2.1.4.
wdonne
 
Posts: 9
Joined: 23. Dec 2008, 20:24

Re: Audio CDs are not recognized in Windows guest

Postby manfredell » 3. Mar 2009, 20:09

folks read the manual!!

"Using the host drive normally provides a read-only drive to the guest. As an ex-
perimental feature (which currently works for data only, audio is not supported), it is
possible to give the guest access to the CD/DVD writing features of the host drive (if
available)"
manfredell
 
Posts: 56
Joined: 1. Feb 2009, 18:57

Re: Audio CDs are not recognized in Windows guest

Postby tkwm » 3. Mar 2009, 20:32

I understood this in a way that writing data works, but not writing audio, but that reading audio works. But actually I have tried that by myself and Werner is right, it does not work.
tkwm
Volunteer
 
Posts: 147
Joined: 3. Mar 2008, 17:56

Re: Audio CDs are not recognized in Windows guest

Postby wdonne » 4. Mar 2009, 10:44

I didn't have the Passthrough option on in the first place because I read in the manual that it is for
writing. It is, however, remarkable that audio CDs are suddenly recognized when the option is
turned on. What else can I look into to make audio CDs work?

Werner.
wdonne
 
Posts: 9
Joined: 23. Dec 2008, 20:24

Re: Audio CDs are not recognized in Windows guest

Postby tkwm » 4. Mar 2009, 14:02

Yesterday I have tried this for a hour or even longer, it does not work. I tried different tools, that use different ways to read audio-cds, like exact audio copy with different settings. I also tried to play a audio-track from the cd within Mac-OS, while the VM was up and then inside the VM, what also did not work.
I have an usb-hd mounted and set up as shared folder, filled with music in the formats mp3, flac, mpc, ape, wma, ogg and so on, that plays through winamp and foobar. So a workaround would be to rip your music to flac and play them so from within the VM. But why do you want to play your audio-cd from within the VM? You can play them with iTunes or Quicktime and use the VM at the same time. You even can play your ripped music from within Mac-OS and use the vm.

I use this free tools from within Mac-OS to rip and play music:
Max - to rip CDs and to convert different music formats, wav, aiff, mp3, flac, mpc, ogg, ape, and others
Cog - to play all kind of different file-formats
Beatport Sync - from Native Instruments, to play and crossfade the most popular music-formats, except lossless wma, mpc and ape. There is also a windowsversion of this player, which is the "little brother" of the professional Traktor-DJ-software.

Again, at the moment there seems to be no way to play audio-CDs from within the VM.
tkwm
Volunteer
 
Posts: 147
Joined: 3. Mar 2008, 17:56

Re: Audio CDs are not recognized in Windows guest

Postby wdonne » 4. Mar 2009, 14:22

I appreciate very much the time you have put into this. It is probably best that I enter this issue in the
bug tracking system of VirtualBox.org.

My reason for wanting audio CDs in the VM is that I would like to continue to use the Creative Media
Source software that came with my MP3 player. Its MP3 encoder produces the highest quality MP3s I
have found so far. I don't mind to replace it with something else provided it matches in quality. Ripping
to WAV files and importing that instead is also a possibility, but then you lose the automatic look-up
of the titles.

Werner.
wdonne
 
Posts: 9
Joined: 23. Dec 2008, 20:24

Re: Audio CDs are not recognized in Windows guest

Postby tkwm » 4. Mar 2009, 14:53

But this does also iTunes. And iTunes uses the original Fraunhofer-codec. And as I have found iTunes rippes also very scratched CDs that Exact Audio Copy, which I prefer, can't rip any more. And, but don't tell anybody, iTunes also circumvents any copyprotection-mechanism I know about. The only reason why I don't use iTunes, is that I prefer flac to mp3. Flac is lossless, that means you can burn the original from it again.
tkwm
Volunteer
 
Posts: 147
Joined: 3. Mar 2008, 17:56

Re: Audio CDs are not recognized in Windows guest

Postby wdonne » 4. Mar 2009, 15:22

The iTunes MP3 codec is indeed based on the Fraunhofer codec, but it isn't nearly as good as the one
provided by Creative. FLAC provides the original quality indeed, but the file size is still 50%, while
a 320kbps MP3 file is about 20% of the original in size. The Creative MP3 codec has been a good
compromise between quality and file size for me.
wdonne
 
Posts: 9
Joined: 23. Dec 2008, 20:24

Re: Audio CDs are not recognized in Windows guest

Postby tkwm » 4. Mar 2009, 15:28

wdonne wrote:The iTunes MP3 codec is indeed based on the Fraunhofer codec, but it isn't nearly as good as the one
provided by Creative.


Do you really hear a difference? May be, with the assistents of a friend, you should do a blind-test, to see if you can differ between the both codecs.
tkwm
Volunteer
 
Posts: 147
Joined: 3. Mar 2008, 17:56

Re: Audio CDs are not recognized in Windows guest

Postby wdonne » 4. Mar 2009, 16:03

I did all that several years ago with different codecs and different bit rates, with head sets and on a
hifi chain. The tests were done mostly with old music. The harpsichord is a very good instrument to test
it with.

That isn't to say I would always notice in all circumstances when hearing just one track. However,
when you're going to start converting a considerable amount of CDs you have to take a decision. It is
a lot of work.
wdonne
 
Posts: 9
Joined: 23. Dec 2008, 20:24

Re: Audio CDs are not recognized in Windows guest

Postby tkwm » 4. Mar 2009, 16:31

But would you hear a difference with your mp3-player and your headphones? German computermagazine c't has made similar tests a few years ago, and up from 192kbit even pro-musicians could not differ between the original cd and the mp3. And if I use 320 kbit I can not differ between lame or Fraunhofer codecs, but may be I'm already to old and have listen to often loud music in my youth (for example listen to UFO with 3 meters distance to their pa, huh there are ants in my ear).
tkwm
Volunteer
 
Posts: 147
Joined: 3. Mar 2008, 17:56

Next

Return to VirtualBox on Mac OS X Hosts

Who is online

Users browsing this forum: Google [Bot] and 27 guests