Webcam not working in windows xp guest

Discussions related to using VirtualBox on Mac OS X hosts.

Webcam not working in windows xp guest

Postby Nacron » 28. Feb 2009, 12:10

Hi,
I installed Virtualbox and Windows XP on a client's Mac Mini Duo Core tonight. The reason for him wanting windows on his Mac was that a video chat application only works on Windows and he would like to have it on his computer. I set up the USB with virtual box and windows recognized and installed the webcam (Logitech Quickcam Communicate Deluxe S7500) but for some reason when you turn it on there is no video. The LED on the camera lights up like it's on but no video is fed to the chat app, the logitech app or the windows webcam app in explorer. I updated the drivers for the camera but it still didn't work. Does anyone else have this problem? Could it be because I don't have windows XP SP3 installed?

Thanks in advanced.
Nacron
 
Posts: 1
Joined: 28. Feb 2009, 11:22

Postby TerryE » 28. Feb 2009, 17:58

The webcam might be using DirectX-3D to accelerate the integration of the video feed onto the XP desktop. Have a look at the installation prerequisites for the application. Often these specify minimum installation reqs that the VM might not offer. You might be able to tweak the graphics settings to get this to work, or you might see if the application can run over the OpenGL interface.
Read the Forum Posting Guide
Google your Q site:VirtualBox.org or search for the answer before posting.
TerryE
Volunteer
 
Posts: 3572
Joined: 28. May 2008, 08:40
Primary OS: Ubuntu other
VBox Version: PUEL
Guest OSses: Ubuntu 10.04 & 11.10, both Svr&Wstn, Debian, CentOS


Return to VirtualBox on Mac OS X Hosts

Who is online

Users browsing this forum: New2VB and 16 guests