OpenSolaris Guest - GuestAdditions - AutoResize Not working

Discussions related to using VirtualBox on Mac OS X hosts.

OpenSolaris Guest - GuestAdditions - AutoResize Not working

Postby wordwarrior » 21. Feb 2009, 04:06

I'm running VirtualBox 2.1.4 on Mac OS X 10.5.6 on a new Unibody MacBook Pro. I've installed OpenSolaris 2008.11 on a 64 bit OpenSolaris VM. The OpenSolaris installation is a fresh one, with no updates.

For some reason, installing Guest Additions does not allow me to automatically resize my display. I tried installing Guest Additions several times using both su and pkexec. Each time, it told me the additions were installed successfully. After logging out and logging in several times, and rebooting, I'm still not able to get the display to auto-resize. In the GNOME screen resolution dialogue, my screen resolution is listed at a maximum of 1024X768.

I am able to move my mouse seemlessly between the VM and OS X, so it seems like the Guest Additions work to a certain extent, but the dynamic screen resizing doesn't work.

I'm going to try creating a 32-bit OpenSolaris VM to see if that works.

Has anybody encountered this problem? Please let me know if you need any more information.
wordwarrior
 
Posts: 5
Joined: 9. May 2008, 01:15

Postby wordwarrior » 21. Feb 2009, 05:31

This does not work on the 32-bit VM either. I even tried switching the VM to "Solaris" instead of "OpenSolaris". No dice.

However, I got this to work on my revision A Intel Core Duo iMac running VirtualBox 2.0.6.

Any workarounds for the above issue?
wordwarrior
 
Posts: 5
Joined: 9. May 2008, 01:15

Solution!

Postby wordwarrior » 21. Feb 2009, 05:47

Here is the solution:

http://forums.virtualbox.org/viewtopic. ... 73b82f1981

-----
Remove the resolution lines in your xorg.conf. If the GA detect those entries, it will disable dynamic resizing.
-----

Here is an example of a line that must be removed in /etc/X11/xorg.conf:

----
Modes "1024X768"
----
wordwarrior
 
Posts: 5
Joined: 9. May 2008, 01:15

Postby jgmdean » 24. Feb 2009, 18:55

"Me Too"

Removed the "Modes" lines, actually the entire Driver sub-section. All is now working Auto-Resize, Seamless Mode, etc.

Bad OpenSolaris, BAD!
Bad VBox, BAD!
Stupid Sun, STUPID!

;-)

James
jgmdean
 
Posts: 2
Joined: 12. Sep 2008, 19:15

Postby sej7278 » 24. Feb 2009, 19:11

the fix works on opensolaris (can't say i had the problem) but it doesn't fix REAL solaris.
sej7278
Volunteer
 
Posts: 1003
Joined: 5. Sep 2008, 14:40
Primary OS: Debian other
VBox Version: PUEL
Guest OSses: Solaris, Linux, Windows, OS/2, MacOSX, FreeBSD


Return to VirtualBox on Mac OS X Hosts

Who is online

Users browsing this forum: Google [Bot] and 10 guests