VBoxNetFlt Driver and AT&T Global Network Client

Discussions related to using VirtualBox on Windows hosts.

VBoxNetFlt Driver and AT&T Global Network Client

Postby sboag » 7. Feb 2009, 01:00

Hello,

First post in this forum.

I installed VirtualBox, and it installed "VirtualBox Host Interface Networking Driver" (VBoxNetFlt Driver). I am using the AT&T Global Network Client (IBM version), which uses the "AGN Virtual Network Adapter". I am working from home and rely on the AT&T client to get to my work network. When I enable the VBoxNetFlt driver in the AGN Virtual Network Adapter, my connection to work stops working, in my XP Windows host. The AT&T Network Client connects without error, I just can't get to any work address.

Is this a known problem? Is there anything I can do?

What I need to do is to get to my work addresses from both the host and from my Ubuntu guest inside the VirtualBox. I think from reading that I need to use the "Host Interface" instead of NAT, but am not sure.

If I disable the VBoxNetFlt driver in the AGN Virtual Network Adapter, I can get to work addresses fine from the XP Host, but not from the Ubuntu guest. I am a Linux novice and am unsure if there's something I could do to get access through the AT&T client via configuration in Ubuntu.

Hoping someone can give me some help or hints.

-scott
sboag
 
Posts: 3
Joined: 7. Feb 2009, 00:43

Postby sboag » 7. Feb 2009, 04:15

Replying to myself, I got the host AT&T client to work with by setting "Allow other network users to connect through this computer's internet connection". But I suspect I don't really even neede the "VirtualBox Host Interface Networking Driver" if I'm using NAT?

For the Ubuntu guest, I got the DNS IPs from the AT&T client, and in the guest in IP4 Settings changed to "Automatic DHCP (Addresses Only)" and then inserted the DNS IPs.

So, good enough to get my work done.

-scott
sboag
 
Posts: 3
Joined: 7. Feb 2009, 00:43

Postby VBRick » 13. Feb 2009, 01:03

I am having a similar problem and just removed virtualbox because of it. I'd like to re-install.

Where did you set "Allow other network users to connect through this computer's internet connection" - in virtualbox????
VBRick
 
Posts: 2
Joined: 6. Feb 2009, 18:35

Postby sboag » 13. Feb 2009, 04:34

> Where did you set "Allow other network users to connect through this computer's internet connection" - in virtualbox????

Start->Control Panel->Network Connections
Right-click properties on I *think* Wireless Network Connection
and go to the Advanced Tab.

BUT, I think it was "For the Ubuntu guest, I got the DNS IPs from the AT&T client, and in the guest in IP4 Settings changed to "Automatic DHCP (Addresses Only)" and then inserted the DNS IPs. " that made the difference. As a matter of fact, something turned the "allow other network users to connect" thing off, and, if I set the DNS correctly in the Ubuntu VirtualBox guest, it works. Be sure to, after you have set the DNS address, to refresh the network connection... click on the little network icon above the desktop, and choose the "Auto eth4" or whatever it is you have there.

I have to set the DNS thing every time I restart. I think this is a known issue, with a kind of ugly fix if you want to put in a bit of work. But someone with some knowledge would have to help with that.

Good luck. Really frustrating, I know. Though, geez, I sure do like VirtualBox. And Ubuntu... trying to resist the urge to install it as my default OS.

-scott
sboag
 
Posts: 3
Joined: 7. Feb 2009, 00:43

Re:

Postby emperor » 19. Oct 2009, 10:34

sboag wrote:> Where did you set "Allow other network users to connect through this computer's internet connection" - in virtualbox????

Start->Control Panel->Network Connections
Right-click properties on I *think* Wireless Network Connection
and go to the Advanced Tab.

BUT, I think it was "For the Ubuntu guest, I got the DNS IPs from the AT&T client, and in the guest in IP4 Settings changed to "Automatic DHCP (Addresses Only)" and then inserted the DNS IPs. " that made the difference. As a matter of fact, something turned the "allow other network users to connect" thing off, and, if I set the DNS correctly in the Ubuntu VirtualBox guest, it works. Be sure to, after you have set the DNS address, to refresh the network connection... click on the little network icon above the desktop, and choose the "Auto eth4" or whatever it is you have there.

I have to set the DNS thing every time I restart. I think this is a known issue, with a kind of ugly fix if you want to put in a bit of work. But someone with some knowledge would have to help with that.

Good luck. Really frustrating, I know. Though, geez, I sure do like VirtualBox. And Ubuntu... trying to resist the urge to install it as my default OS.

-scott

oh?my station is the same as yours. :D
emperor
 
Posts: 3
Joined: 19. Oct 2009, 09:10
Primary OS: MS Windows XP
VBox Version: OSE other
Guest OSses: linux


Return to VirtualBox on Windows Hosts

Who is online

Users browsing this forum: No registered users and 47 guests