Disable cmd+H

Discussions related to using VirtualBox on Mac OS X hosts.

Disable cmd+H

Postby E » 25. Jan 2009, 17:21

Even though my host key is the left cmd button, when I press the right cmd button and the H key (cmd+H) OS X hides the virtual machine that I have open. This happens even when the virual machine has the keyboard and mouse focus. This is interesting because this is the only instance I've found where the host recognizes keyboard shortcuts that do not involve the host key (left cmd). It may just be a bug.

This can be a bit of a nuisance since I frequently use cmd+H in XP while working in MS Office apps to do find/replace in documents.

Has anyone found a way to suppress right cmd+H so that the host (OS X) does not minimize the VM? Thanks!
E
 
Posts: 10
Joined: 21. Aug 2008, 18:35

Disable Cmd+H *and* Cmd+M AND Cmd+Q too

Postby jsdza » 3. Feb 2009, 21:10

I too have the same problem, wish I could suggest a solution but since I can't, I'd like someone to know there's more than one person out there who finds this extremely annoying.

It seems as if all the Cmd keystrokes listed in the menus are immune to keyboard capture. I have Cmd and Alt modifiers swapped in OS X System Prefs, so I use the Cmd key as Alt in a Win2k guest. Hence I'm forever hiding and minimizing the guest window. At least there's a prompt on Quit, if I spot it fast enough :-)

I'm using 2.1.2, and though I can't say for sure when I first noticed the problem, I'm dead certain that it's fairly recent, possibly since version 2 (Isn't that when the menu layout changed, and Save State dropped off the Machine menu and became implicit with Quit? Could it be that menu command keys are now handled differently?)
jsdza
 
Posts: 7
Joined: 3. Feb 2009, 20:32


Return to VirtualBox on Mac OS X Hosts

Who is online

Users browsing this forum: No registered users and 15 guests