Installation fails on 10.13.x, 10.14.x (rc=-1908)

Discussions related to using VirtualBox on Mac OS X hosts.

Re: Installation fails on 10.13.x, 10.14.x (rc=-1908)

Postby TheQL » 18. Apr 2021, 15:01

Have you checked and fixed the permissions of the kext staging folders as suggested in the last few posts in this very thread?
TheQL
 
Posts: 13
Joined: 4. Nov 2020, 22:27

Re: Installation fails on 10.13.x, 10.14.x (rc=-1908)

Postby tcw » 19. Apr 2021, 22:33

I thought I had, but digging through further it seems not - one of the folders didn't have the restricted tag.

After a bunch of confusion I eventually realised I had to go into disk utility and mount Macintosh HD before doing the relevant chflags commands in recovery mode.

Once that was done, the issue was fixed! Thanks very much!
tcw
 
Posts: 2
Joined: 17. Apr 2021, 08:04

Re: Installation fails on 10.13.x, 10.14.x (rc=-1908)

Postby TheQL » 20. Apr 2021, 10:42

Glad it worked! The solution is pretty much explained in detail somewhere, but is somewhat getting lost in the conversation around it ;)
TheQL
 
Posts: 13
Joined: 4. Nov 2020, 22:27

Re: Installation fails on 10.13.x, 10.14.x (rc=-1908)

Postby 2Bornot2B » 27. Apr 2021, 12:59

Hi,

i have a similar problem, after upgrade to MacOS Big Sur Virtual Box can no longer start existing VMs.

Error-Message: Kernel driver not installed (rc=-1908)
Make sure the kernel module has been loaded successfully.
where: suplibOsInit what: 3 VERR_VM_DRIVER_NOT_INSTALLED (-1908) - The support driver is not installed. On linux, open returned ENOENT.

macOS: 11.2.3
VirtualBox: 6.1.20 r143896

The "Allow" Button on System Preferences -> Security & Privacy -> General never shows up.
The installation succeeds without any errors, no errors in the installation log too.

Tried to fix the permissions with

# chflags restricted /Volumes/Macintosh\ HD/private/var/db/KernelExtensionManagement
# chflags restricted /Volumes/Macintosh\ HD/private/var/db/KernelExtensionManagement/Staging

and

# kextcache --clear-staging

in recovery mode - no success. Any help or suggestions are highly appreciated.
2Bornot2B
 
Posts: 2
Joined: 27. Apr 2021, 10:44

Re: Installation fails on 10.13.x, 10.14.x (rc=-1908)

Postby VirtualJan » 10. May 2021, 23:40

2Bornot2B wrote:i have a similar problem, after upgrade to MacOS Big Sur Virtual Box can no longer start existing VMs.

Same here. I will just follow the topic to see if anyone has tips.
VirtualJan
 
Posts: 5
Joined: 5. May 2021, 20:48

Previous

Return to VirtualBox on Mac OS X Hosts

Who is online

Users browsing this forum: towo2099 and 17 guests