Audio problem on macOS Big Sur

Discussions related to using VirtualBox on Mac OS X hosts.

Audio problem on macOS Big Sur

Postby zat » 17. Feb 2021, 23:17

Since i have installed Big Sur i have audio problems whenever i launch the Virtualbox VM (either Windows or Ubuntu guest)
This problems started to show up a few days after installing Big Sur (which I installed as soon as the public release was released in November), until Catalina all worked properly.


PROBLEM DESCRIPTION AND STEPS TO REPRODUCE IT
- launch the guest VM
- play a video/audio from any media source (e.g. Youtube, QuickTime, iTunes..) on the host machine
- The video/audio should not start:
-> on Youtube, i see the loading spinner indefinitely. But, if i disable the audio directly on the player, the video will play fine, of course without audio
-> on QuickTime, the application freezes for about 1-2 minute, and the video doesn't plays after that
-> same on iTunes but with less buggy interaction

- Video plays fine on Youtube on Windows 7/Ubuntu 22.10 guest (with a very low frame rate, but i don't know if this happened also on Catalina because i never played media on guest)
- If the media was already playing before starting the VM, it will continue without any problem (tipically).
- On QuickTime sometimes i was able to pause a video and restart it later (meanwhile doing some operations on the VM) using the earphones controls or by clicking somewhere on the QuickTime application to "activate it" and only after click the play button. If it failed, the only solution was to shut down and restart the guest machine


WHAT I TRIED TO DO:
- change (enable) all possible setting on Security and Privacy for VirtualBox
- try with all connections offline (since I have also some bugs using my AirPods -not related to VirtualBox) i thought that they could be maybe the reason
- reinstall VirtualBox, Extension package, Guest addition
- create new guests directly on Big Sur (old ones were ported from Catalina)
- unfortunately i cannot reinstall macOS at the moment so i can't try that solution
- Enable/disable microphone/speakers on guest machine Status Bar on the bottom
- Enable/disable microphone/speakers on VirtualBox control panel in the machine settings; also tried to disable the audio directly
- Of course I kept updated both macOS and VirtualBox, looking for a fix


In my opinion, it seems like there are some conflicts on the "audio management" between macOS and the VM application


I would like to know if someone have experienced the same problem and possibly how to solve it, because if it's a general problem it seems strange that nobody reported it before.


My machine is a MacBook Pro 2018 i5 2.3 GHz with 8 GB ram.
zat
 
Posts: 1
Joined: 17. Feb 2021, 22:19

Re: Audio problem on macOS Big Sur

Postby Elianapereira » 17. Mar 2021, 21:06

I have exactly the same problem and I couldn't found a solution until now.

Is there anyone who could help?
Elianapereira
 
Posts: 1
Joined: 17. Mar 2021, 20:38

Re: Audio problem on macOS Big Sur

Postby scottgus1 » 17. Mar 2021, 23:24

Elianapereira, I removed your other resurrect-a-topic post. It would spread the possible help among several topics instead of concentrating it in one.

Please Start the VM from full normal shutdown, not save-state. Run until you see the problem happen, then shut down the VM from within the VM's OS if possible. If not possible, close the Virtualbox window for the VM with the Power Off option set.

Right-click the VM in the main Virtualbox window's VM list, choose Show Log. Save the far left tab's log, zip it, and post the zip file, using the forum's Upload Attachment tab.
scottgus1
Site Moderator
 
Posts: 11581
Joined: 30. Dec 2009, 20:14
Primary OS: MS Windows 10
VBox Version: PUEL
Guest OSses: Windows, Linux

Re: Audio problem on macOS Big Sur

Postby PhantomGhostX » 8. Apr 2021, 17:17

scottgus1 wrote:Elianapereira, I removed your other resurrect-a-topic post. It would spread the possible help among several topics instead of concentrating it in one.

Please Start the VM from full normal shutdown, not save-state. Run until you see the problem happen, then shut down the VM from within the VM's OS if possible. If not possible, close the Virtualbox window for the VM with the Power Off option set.

Right-click the VM in the main Virtualbox window's VM list, choose Show Log. Save the far left tab's log, zip it, and post the zip file, using the forum's Upload Attachment tab.


I have the same error heres my log
PhantomGhostX
 
Posts: 1
Joined: 8. Apr 2021, 17:16

Re: Audio problem on macOS Big Sur

Postby winnithedevil » 14. Apr 2021, 22:49

zat wrote:Since i have installed Big Sur i have audio problems whenever i launch the Virtualbox VM (either Windows or Ubuntu guest)
This problems started to show up a few days after installing Big Sur (which I installed as soon as the public release was released in November), until Catalina all worked properly.


PROBLEM DESCRIPTION AND STEPS TO REPRODUCE IT
- launch the guest VM
- play a video/audio from any media source (e.g. Youtube, QuickTime, iTunes..) on the host machine
- The video/audio should not start:
-> on Youtube, i see the loading spinner indefinitely. But, if i disable the audio directly on the player, the video will play fine, of course without audio
-> on QuickTime, the application freezes for about 1-2 minute, and the video doesn't plays after that
-> same on iTunes but with less buggy interaction

- Video plays fine on Youtube on Windows 7/Ubuntu 22.10 guest (with a very low frame rate, but i don't know if this happened also on Catalina because i never played media on guest)
- If the media was already playing before starting the VM, it will continue without any problem (tipically).
- On QuickTime sometimes i was able to pause a video and restart it later (meanwhile doing some operations on the VM) using the earphones controls or by clicking somewhere on the QuickTime application to "activate it" and only after click the play button. If it failed, the only solution was to shut down and restart the guest machine


WHAT I TRIED TO DO:
- change (enable) all possible setting on Security and Privacy for VirtualBox
- try with all connections offline (since I have also some bugs using my AirPods -not related to VirtualBox) i thought that they could be maybe the reason
- reinstall VirtualBox, Extension package, Guest addition
- create new guests directly on Big Sur (old ones were ported from Catalina)
- unfortunately i cannot reinstall macOS at the moment so i can't try that solution
- Enable/disable microphone/speakers on guest machine Status Bar on the bottom
- Enable/disable microphone/speakers on VirtualBox control panel in the machine settings; also tried to disable the audio directly
- Of course I kept updated both macOS and VirtualBox, looking for a fix


In my opinion, it seems like there are some conflicts on the "audio management" between macOS and the VM application


I would like to know if someone have experienced the same problem and possibly how to solve it, because if it's a general problem it seems strange that nobody reported it before.


My machine is a MacBook Pro 2018 i5 2.3 GHz with 8 GB ram.

—————————————————————————————————————————————————————————————————————————-

I have exactly the same problem and I couldn't found a solution until now.

Is there anyone who could help?
winnithedevil
 
Posts: 2
Joined: 14. Apr 2021, 22:44

Re: Audio problem on macOS Big Sur

Postby winnithedevil » 29. Apr 2021, 12:40

This Problem is fixed: ??
VirtL Box 6.1.20. April 2021
winnithedevil
 
Posts: 2
Joined: 14. Apr 2021, 22:44


Return to VirtualBox on Mac OS X Hosts

Who is online

Users browsing this forum: No registered users and 15 guests