[Solved] VirtualBox, no USB device connected

Discussions related to using VirtualBox on Linux hosts.

[Solved] VirtualBox, no USB device connected

Postby Sven_Linuxuser » 20. Jan 2020, 19:44

Hello,

I'm sure, this has been answered before, but I couldn't find a solution so far, so please accept my apology in advance, in case the solution seems trivial to you.

I cannot get any USB-device to show up in my virtual machine.

Here is what I did:

I installed Ubuntu 18.04.3 LTS (x64) and installed all updates.
I installed VirtualBox 5.2.34_Ubuntu r133883, using the official Ubuntu-Software app.
I downloaded Oracle_VM_VirtualBox_Extension_Pack-5.2.34.vbox-extpack and installed it.
The Expension Pack shows in VirtualBox (as Oracle VM VirtualExtension Pack 5.2.34r133893).
I created a virtual machine, using Microsoft Windows 7 Home Premium (x86, since it won't let me create x64-machines).
I installed all Windows 7 updates (yeah, I know, Windows 7 is not supported anymore, I am planning to upgrade to Win10 later).
I installed the guest-extensions, using the menu (devices, mount guest extensions (or similar, I am using German GUI)).
The guest-extensions show as Oracle VM VirtualBox Guest Additions 5.2.34.
They work with shared folders between Ubuntu and Windows.

After I plug in my scanner on my Ubuntu notebook, the lsusb-command in the terminal shows:
Bus 002 Device 007: ID 04a9:221b Canon, Inc. CanoScan 4200F.
And the command sudo VBoxManage list usbhost shows:
UUID: daaceb45-4506-4165-a8d3-454ffa94a75d
VendorId: 0x04a9 (04A9)
ProductId: 0x221b (221B)
Revision: 2.0 (0200)
Port: 0
USB version/speed: 2/High
Manufacturer: Canon
Product: CanoScan
Address: sysfs:/sys/devices/pci0000:00/0000:00:1d.7/usb2/2-1//device:/dev/vboxusb/002/007
Current State: Available

My USB-configuration in VirtualBox is
[x] USB-Controller aktivated
[o] USB-2.0-Controller (EHCI)

I also added a blank-filter for new USB-devices.

I can't get any USB-device to show in the Windows-VM.
Clicking on the USB-icon always displays: no USB-device connected.
Using the menu (devices, usb) shows the same: no device connected.

I can't figure this out, since the commandlines show that the devices are being detected by the system.

There are two aspects, I think may be responsible:
- Ubuntu is 64 bit, Windows 32 bit (I hope that's not it, because I cannot create/start 64-bit-VMs)
- there's a version mismatch. VirtualBox-info displays: 5.2.34_Ubuntu r133883. The extension is shown as 5.2.34r133893. But I installed VirtualBox from the official Ubuntu 18 repositories and I downloaded the extension from virtualbox-org-wiki-Download_Old_Builds_5_2, downloading the file shown under Ubuntu 18.04 LTS.

Or I am just using it all wrong.

Can you give me a hint?

Best regards and thanks in advance,
Sven
Sven_Linuxuser
 
Posts: 5
Joined: 20. Jan 2020, 19:00

Re: VirtualBox, no USB device connected

Postby mpack » 20. Jan 2020, 19:51

5.2.34_Ubuntu r133883

That is a fork, that is not VirtualBox. We don't support forks here, plus we can't assume that the extension pack will work on a fork.
mpack
Site Moderator
 
Posts: 31794
Joined: 4. Sep 2008, 17:09
Primary OS: MS Windows 10
VBox Version: PUEL
Guest OSses: Mostly XP

Re: VirtualBox, no USB device connected

Postby Sven_Linuxuser » 20. Jan 2020, 22:25

Hello and thank you for your help!

So I uninstalled the virtual extension pack and then the virtualbox-ubuntu-fork. I also removed the VirtualBox-configuration files (sudo rm ~/.config/VirtualBox/ -Rf) and rebooted my host, just to be sure.

Then, I downloaded virtualbox-5.2_5.2.36-135684~Ubuntu~bionic_amd64.deb and installed it via double-click. I downloaded Oracle_VM_VirtualBox_Extension_Pack-5.2.36.vbox-extpack and installed it via double-click. No errors here.

I started the virtual machine (Win7), uninstalled the guest-extensions, performed a reboot and mounted and installed the guest-extensions via menu (Oracle VM VirtualBox Guest Additions 5.2.36r135684). Another reboot.

No change. lsusb shows my Canon CanoScan, sudo VBoxManage list usbhost shows my Canon CanoScan. VirtualBox keeps saying: no usb-device connected.

I really can't figure it out.

Do you have any suggestions on what I could try?

Best regards,
Sven
Sven_Linuxuser
 
Posts: 5
Joined: 20. Jan 2020, 19:00

Re: VirtualBox, no USB device connected

Postby konsultnisse » 20. Jan 2020, 23:10

Hi Sven,
I don't remember if it is the same behavior on VirtualBox 5.x but in 6.0 as well as in 6.1 you need to add the host OS user that starts the guest OS to the group vboxusers
It seams that no user is there by default..

The command:
groups $USER

will list what groups you are member in, if vboxusers are missing then try to add yourself with:

sudo usermod -a -G vboxusers $USER

Now logout from your host OS and log in again, and run the first command again.
If you now can see yourself as a member of vboxusers you can try to start the virtualbox guest and look for USB devices again

If you during the usermod command gets an error that the group do not exist, then something more are broken.. :-(

Best Regards - Vänliga Hälsningar,
/Anders
konsultnisse
 
Posts: 3
Joined: 20. Jan 2020, 22:54

Re: VirtualBox, no USB device connected

Postby Sven_Linuxuser » 20. Jan 2020, 23:49

THANK YOU! :D

I forgot to do that (sudo usermod -a -G vboxusers $USER) this time.
I did that the last time, but either it was a version-mismatch last time (virtualbox-ubuntu-fork and oracle-extension-pack) or I forgot the reboot of the host the last time.

Anyhow: It works!



The VM (Windows) recognizes my CanoScan 4200f, so I don't have to throw a working hardware away. :lol:

Best regards,
Sven
Sven_Linuxuser
 
Posts: 5
Joined: 20. Jan 2020, 19:00


Return to VirtualBox on Linux Hosts

Who is online

Users browsing this forum: No registered users and 17 guests