Mouse capture on Fullscreen breaks (Arch)

Discussions related to using VirtualBox on Linux hosts.

Mouse capture on Fullscreen breaks (Arch)

Postby jesses » 4. Nov 2019, 20:33

Hey Everybody,

I hope someone can help. I had this problem before, it went away and now it is back. I am not sure, whether this is a VirtualBox problem. All the Boxes I run are Windows 10 Boxes, and they run perfectly fine as long as I do not switch to full screen.

As soon as I switch to full-screen mode, the mouse is not captured anymore. The keyboard works fine, I can also exit full-screen again via hotkey, but I am not able to click on anything inside the window. Menu bar does not respond to mouse clicks, status bar neither, and the Machine at the least, not even the VirtualBox Manager.

I can grab the Window manager stuff, i.e. resize the window on the corners, or move it around using the title bar. I am fresh out of ideas. As soon as I shutdown the Box, everything is back to normal. I can use the Manager again, no need to restart or anything. Only the Box Window has to disappear.

Something that also works is starting in detachable mode (everything works fine), switching to fullscreen (same problems as above), then detach the head (VirtualBox goes back to working) and reattach to the Box.

As long as I do not switch to full-screen an click anywhere VirtualBox related everything is fine. Any ideas? Anything you guys need to get ideas? I kind of need the full-screen mode for presentation stuff.

I am using Arch-Linux with the gnome desktop (wayland), and VirtualBox 6.0.14r132055.
jesses
 
Posts: 1
Joined: 4. Nov 2019, 20:21

Re: Mouse capture on Fullscreen breaks (Arch)

Postby meeas » 20. Jan 2020, 11:57

I'm experiencing the same issue with version 6.1.2 on Debian Bullseye and a Windows 10 guest (haven't tried other guests yet).
meeas
 
Posts: 2
Joined: 20. Jan 2020, 11:48

Re: Mouse capture on Fullscreen breaks (Arch)

Postby meeas » 20. Jan 2020, 15:18

Found the problem and a solution. Seems like this is related to all the historical issues they have had with the mini-toolbar and X11. If you go to your VM and change the Settings > User Interface to NOT show the mini-toolbar in fullscreen mode, it should work. At least it did for me. I was experiencing all the same nuances of your description until I did this. Now I can run full screen just fine.

Hoping this helps others since it would seem to be a common problem. And for the record, my setup is:

VirtualBox: 6.1.2 with extensions and guest tools installed
Host: Debian Testing (Bullseye) fully updated
Host X: xwayland version 2:1.20.7-2
Guest: Windows 10

As a sidenote, I tried all combinations of disabling Gnome animations, running with and without guest tools, with and without 3D, maxing out guest video memory, etc... The only thing that fixed loosing the mouse when going to fullscreen which also makes it unusable in the main VirtualBox management window until the VM is killed.
meeas
 
Posts: 2
Joined: 20. Jan 2020, 11:48


Return to VirtualBox on Linux Hosts

Who is online

Users browsing this forum: No registered users and 15 guests