No sounds in VB when sounds works fine in host and vice versa

Discussions related to using VirtualBox on Linux hosts.

No sounds in VB when sounds works fine in host and vice versa

Postby KIMW » 4. Aug 2019, 09:32

When I launched VB, sounds is working fine in VB but not in SMPlayer, Firefox, etc, on my Linux Mint system (Distro: Linux Mint 18.3 KDE) and when I run:
Code: Select all   Expand viewCollapse view
pulseaudio -k
then the sound comes back in SMPlayer and Firefox BUT stops in VB.

I've asked on the Linux Mint forum but yet I have not managed to get it working. So I hope someone here will be able to help me. Thanks in advance.

I've used the following procedure to provide you the log:
Start the VM from cold-boot (not from a paused or saved state) / Observe problem / Shutdown the VM (force close it if you have to). With the VM completely shut down (not paused or saved), right-click on the VM in the VirtualBox Manager and select "Show Log". Save only the first "VBox.log", ZIP it and attach it to your response. See the "Upload attachment" tab below the reply form.

(23.54 KiB) Downloaded 16 times
Posts: 30
Joined: 26. May 2016, 19:51
Primary OS: Linux other
VBox Version: OSE other
Guest OSses: Windows 7

Re: No sounds in VB when sounds works fine in host and vice versa

Postby socratis » 14. Aug 2019, 05:13

I have a Mint 19 host and I run a Win7-64 to try to replicate your setup. I had no problems playing two YouTube videos in Firefox simultaneously. Here's what I saw comparing our logs (yours and mine):
VirtualBox VM 5.2.30 r130521 linux.amd64 (May 13 2019 14:52:44) release log
VirtualBox VM 6.0.97 r131153 linux.amd64 (Jun 5 2019 19:34:32) release log
00:00:00.544794 PulseAudio: Using v8.0.0
00:00:08.087181 PulseAudio: Using v11.1.0

And then these from your VBox.log, which I don't have in mine:
00:00:44.329493 Audio: Enable stream '[PulseAudio] Front' failed with VERR_INVALID_POINTER
00:00:55.463915 PulseAudio: Could not connect playback stream 'VirtualBox Front [WIN7]': Bad state
I don't particularly like Invalid_pointers, neither Bad_States, but I can't tell you what's going on in the background.

Other than that the VM configuration and everything else looks fine. I would look to your host's audio config. What I suspect is going on is that you have some sort of setting where only one app is allowed at any time to have access to the audio, but that's a guess.

I'm not a Linux/Pulse audio guy, so I don't really know what "pulseaudio -k" does/doesn't do...
Do NOT send me Personal Messages (PMs) for troubleshooting, they are simply deleted.
Do NOT reply with the "QUOTE" button, please use the "POST REPLY", at the bottom of the form.
If you obfuscate any information requested, I will obfuscate my response. These are virtual UUIDs, not real ones.
Site Moderator
Posts: 27690
Joined: 22. Oct 2010, 11:03
Location: Greece
Primary OS: Mac OS X other
VBox Version: PUEL
Guest OSses: Win(*>98), Linux*, OSX>10.5

Return to VirtualBox on Linux Hosts

Who is online

Users browsing this forum: No registered users and 15 guests