Virtualbox 5.2.x and 6.x fail to start on kernels > 4.18

Discussions related to using VirtualBox on Linux hosts.

Virtualbox 5.2.x and 6.x fail to start on kernels > 4.18

Postby JoegoenDoe » 23. Dec 2018, 14:30

Hi,

I'm running Debian 9-6 with default kernel 4.9.0.8.

Under 4.9.0.8 I can run all VM's without any issues.

I upgraded my to a 4.18.14 and 4.19.12 custom kernel.

Virtualbox 5.2.22 r126460 (Qt5.7.1) as well as 6.0.0 r127566 (Qt5.7.1) fail to run any VM.
They fail with the same error
The virtual machine 'BSD 9' has terminated unexpectedly during startup with exit code 1 (0x1).

Result Code: NS_ERROR_FAILURE (0x80004005)
Component: MachineWrap
Interface: IMachine {5047460a-265d-4538-b23e-ddba5fb84976}

Running /sbin/vboxsetup gives the following
Created symlink /etc/systemd/system/multi-user.target.wants/vboxdrv.service → /lib/systemd/system/vboxdrv.service.
Created symlink /etc/systemd/system/multi-user.target.wants/vboxballoonctrl-service.service → /lib/systemd/system/vboxballoonctrl-service.service.
Created symlink /etc/systemd/system/multi-user.target.wants/vboxautostart-service.service → /lib/systemd/system/vboxautostart-service.service.
Created symlink /etc/systemd/system/multi-user.target.wants/vboxweb-service.service → /lib/systemd/system/vboxweb-service.service.
vboxdrv.sh: Stopping VirtualBox services.
vboxdrv.sh: Starting VirtualBox services.
vboxdrv.sh: Building VirtualBox kernel modules.
vboxdrv.sh: failed: Look at /var/log/vbox-setup.log to find out what went wrong.

There were problems setting up VirtualBox. To re-start the set-up process, run
/sbin/vboxconfig
as root.

Vbox-setup.log starts with
Building the main VirtualBox module.
Error building the module:
make V=1 CONFIG_MODULE_SIG= -C /lib/modules/4.19.12/build SUBDIRS=/tmp/vbox.0 SRCROOT=/tmp/vbox.0 -j4 modules
make[1]: warning: -jN forced in submake: disabling jobserver mode.
mkdir -p /tmp/vbox.0/.tmp_versions ; rm -f /tmp/vbox.0/.tmp_versions/*

WARNING: Symbol version dump ./Module.symvers
is missing; modules will have no dependencies and modversions.

make -f ./scripts/Makefile.build obj=/tmp/vbox.0

ends with
make -f ./scripts/Makefile.modpost
find /tmp/vbox.0/.tmp_versions -name '*.mod' | xargs -r grep -h '\.ko$' | sort -u | sed 's/\.ko$/.o/' | scripts/mod/modpost -m -i ./Module.symvers -I /tmp/vbox.0/Module.symvers -o /tmp/vbox.0/Module.symvers -S -w -s -T -
/bin/sh: 1: scripts/mod/modpost: not found
scripts/Makefile.modpost:92: recipe for target '__modpost' failed
make[2]: *** [__modpost] Error 127
Makefile:1520: recipe for target 'modules' failed
make[1]: *** [modules] Error 2
/tmp/vbox.0/Makefile.include.footer:106: recipe for target 'vboxdrv' failed

Anyone got an idea what is going on here?
How can this be fixed?
Last edited by socratis on 23. Dec 2018, 16:52, edited 2 times in total.
Reason: Enclosed the information in [quote][pre] tags for better readability
JoegoenDoe
 
Posts: 1
Joined: 23. Dec 2018, 14:01

Re: Virtualbox 5.2.x and 6.x fail to start on kernels > 4.18

Postby markd89 » 26. Dec 2018, 07:13

I'm running Debian 9.6 also and a Kernel from backports (Kernel 4.18.0-0.bpo.1-amd64) with Virtualbox Version 5.2.22 r126460 (Qt5.9.2).

I haven't seen your errors before but the recipe that has worked for me is:

0. remove VirtualBox
1. Install new Kernel.
2. Install linux-headers for the new kernel
3. Install Virtualbox. I think I did it by downloading the .deb file and then from the folder containing the downloaded .deb file apt-get install ./nameofdebfile.deb

On a freshly installed Debian, I'll see complaints about missing perl, gcc, etc. which I install and then repeat the process. I have done this a few times with success.

I hope that helps..

Mark
markd89
 
Posts: 15
Joined: 4. Sep 2016, 22:54

Re: Virtualbox 5.2.x and 6.x fail to start on kernels > 4.18

Postby mfelker » 11. Jan 2019, 10:43

Virtualbox 6.0 installs and runs fine on Fedora Rawhide kernel 4.21.0-0.rc0.git1.1.fc30.x86_64. However it failed to compile starting with the git6 version of 4.21 which of course is now 5.0
mfelker
 
Posts: 27
Joined: 27. May 2012, 00:24
Location: Floyd, VA
Primary OS: Debian Sid
VBox Version: PUEL
Guest OSses: Multiple


Return to VirtualBox on Linux Hosts

Who is online

Users browsing this forum: No registered users and 8 guests