Hardening VirtualBox vm, setup custom ACPI table

Discussions related to using VirtualBox on Linux hosts.

Hardening VirtualBox vm, setup custom ACPI table

Postby gillo » 12. Nov 2017, 14:53

hello. I'm trying Hardening VirtualBox vm on Linux host. I find an instruction but cant post it here. because it's my first post and i'm not allowed

but I stuck on third step "VM Creation"
"Run Antivmdetection (outside VM): For me <DmiSystemProduct> resulted in "AllSeries" because I run an ASUS board.
Okay, next step: execute <DmiSystemProduct>.sh - For me, this immediately resulted in a VM I could not start. Responsible for this were the 3 entries
1) DmiBIOSVersion
2) DmiBoardAssetTag
3) DmiBoardLocInChass
Which were set by <DmiSystemProduct>.sh to an integer value and VirtualBox was pretty unhappy with that fact, expecting a string. Changing these to random strings fixed the issue though. So this may be one of the pitfalls you may run into when using the tool. Setting the ACPI CustomTable however worked fine."

this is what I'm talking about. I underlined what is Incomprehensible for me. have no idea how to do that. or what i have to do. how to setup custom ACPI table or what is this string. can someone help me. give some step by step instruction please.
Posts: 1
Joined: 12. Nov 2017, 13:21

Return to VirtualBox on Linux Hosts

Who is online

Users browsing this forum: No registered users and 25 guests