After 5.0 to 5.1 upgrade, host keyboard mapping wrong only for VirtualBox application

Discussions related to using VirtualBox on Linux hosts.

After 5.0 to 5.1 upgrade, host keyboard mapping wrong only for VirtualBox application

Postby randomguy » 9. Oct 2017, 12:21

I had 5.0 and unsuccessfully upgraded to 5.2 RC1 and then after some troubleshooting ended up on 5.1, on Ubuntu 16.04 64-bit.
I connect to host via mstsc/xrdp (sessman-Xvnc) and use LXDE.

It used to work more or less fine with v5.0, but with 5.1 (or maybe after some packages were updated, removed, etc.) when I key in anything in VirtualBox UI, keyboard mapping is incorrect. For example if I type "test" in New > Name, it becomes "ngbn", or if I try to type numbers in NAT settings, they're completely different.
Elsewhere (in other apps, in the same session), I can enter text properly. In LXDE's Language Support, it's set to English (same as before), and Keyboard Input Method System is "none" (also same as before; I also tried IBus, didn't help) and both of these I applied System Wide just to be sure - didn't help.

So far VirtualBox is the only app that has this problem. In GUI under Preferences > Language I selected English (built-in) (before with 5.0 Default worked fine, now even English doesn't work).

Any ideas on what else to check?

$ locale
LANG=en_US.utf8
LANGUAGE=en_US:en
LC_CTYPE="en_US.utf8"
LC_NUMERIC=en_US.UTF-8
LC_TIME=en_US.UTF-8
LC_COLLATE="en_US.utf8"
LC_MONETARY=en_US.UTF-8
LC_MESSAGES="en_US.utf8"
LC_PAPER=en_US.UTF-8
LC_NAME=en_US.UTF-8
LC_ADDRESS=en_US.UTF-8
LC_TELEPHONE=en_US.UTF-8
LC_MEASUREMENT=en_US.UTF-8
LC_IDENTIFICATION=en_US.UTF-8
LC_ALL=
randomguy
 
Posts: 5
Joined: 9. Oct 2017, 08:03

Re: After 5.0 to 5.1 upgrade, host keyboard mapping wrong only for VirtualBox application

Postby randomguy » 7. Nov 2017, 12:48

I'm on 5.2 now, still seeing the same problem.

How can I tell whether it's MSTSC/XRDP or VB that's causing this problem?

It seems something between VNC and Qt5.... Or something.

https://bugs.debian.org/cgi-bin/bugrepo ... bug=814959

Workaround: now I have to use TightVNC Viewer instead of mstsc/xrdp/Mate.
randomguy
 
Posts: 5
Joined: 9. Oct 2017, 08:03


Return to VirtualBox on Linux Hosts

Who is online

Users browsing this forum: FriendDavid and 23 guests