Page 1 of 1

USB forwarding to (any) guest not working

PostPosted: 6. Jul 2017, 17:15
by heis2201
Hi,

I cannot get my USB devices to work on any of my guests (no matter if MS OS or GNU Linux guests).

Host is an up-to-date Fedora 25 on an UEFI system, with SecureBoot disabled.
Virtualbox is most recent version (5.1.22), installed from virtualbox, not rpmfusion.
I have ...
- dkms, kernel-headers, and kernel-modules installed on the host.
- the USB Controller (USB 2.0, EHCI) enabled
- Extensions Pack for virtualbox installed.

Symptom: Virtualbox does not recognize any USB device, though lsusb lists them all correctly, and they work just fine in the host OS.

What is noticed when looking at kernel messages is:
Code: Select all   Expand viewCollapse view
[   13.865599] vboxdrv: loading out-of-tree module taints kernel.
[   13.865828] vboxdrv: module verification failed: signature and/or required key missing - tainting kernel
[   13.872520] vboxdrv: Found 4 processor cores
[   13.891101] vboxdrv: TSC mode is Invariant, tentative frequency 2693746328 Hz
[   13.891102] vboxdrv: Successfully loaded version 5.1.22 (interface 0x00280000)
[   14.106100] vboxpci: IOMMU not found (not registered)


Not sure this is related. I actually understand the tainted kernel as a warning only (secure boot is disabled anyway).

lsmod | grep vbox is giving me:

Code: Select all   Expand viewCollapse view
vboxpci                24576  0
vboxnetadp             28672  0
vboxnetflt             28672  0
vboxdrv               462848  3 vboxnetadp,vboxnetflt,vboxpci


Here is some USB-related stuff I found in VBox.log

Code: Select all   Expand viewCollapse view
00:00:06.742697 OHCI: Software reset
00:00:06.742774 OHCI: USB Reset
00:00:06.819197 OHCI: USB Operational
00:00:06.833816 EHCI: Hardware reset
00:00:06.833976 EHCI: USB Operational
...
00:00:13.406517 EHCI: USB Suspended


Any ideas what to do?
Thanks, Florian.

Re: USB forwarding to (any) guest not working

PostPosted: 6. Jul 2017, 17:31
by heis2201
Topic can be closed.
I made a simple mistake. My user was not part of the vboxusers group.