Microphone doesn't work after upgrade to 5.1

Discussions related to using VirtualBox on Linux hosts.

Re: Microphone doesn't work after upgrade to 5.1

Postby NajiB » 25. Jan 2017, 15:01

pentagonik wrote:@vultan @flubba86

You guys are both on a Linux host, using PulseAudio as the audio driver, right?

True in my case: Ubuntu 16.04 host, Win 7 guest.
NajiB
 
Posts: 7
Joined: 24. Oct 2016, 14:34

Re: Microphone doesn't work after upgrade to 5.1

Postby flubba86 » 24. Feb 2017, 01:40

pentagonik wrote:@vultan @ flubba86

You guys are both on a Linux host, using PulseAudio as the audio driver, right?

Yes, Ubuntu 16.04 host. 3 different VMs, Windows 7, Windows 10 and Windows 10 Anniversary Update, each have the problem.
Yes, using the PulseAudio driver.
flubba86
 
Posts: 5
Joined: 22. Dec 2016, 02:07

Re: Microphone doesn't work after upgrade to 5.1

Postby flubba86 » 10. Mar 2017, 01:47

And chiming in again, updated to just-released 5.1.16, problem still exits.
flubba86
 
Posts: 5
Joined: 22. Dec 2016, 02:07

Re: Microphone doesn't work after upgrade to 5.1

Postby michaln » 10. Mar 2017, 10:44

In case it's not obvious to everyone: If you have a VM with Windows installed which does not see a microphone, upgrading VirtualBox will make no difference. Windows needs to be forced to re-detect the hardware (uninstalling the guest's HD Audio drivers does that).
michaln
Oracle Corporation
 
Posts: 2931
Joined: 19. Dec 2007, 15:45
Primary OS: MS Windows 7
VBox Version: PUEL
Guest OSses: Any and all

Re: Microphone doesn't work after upgrade to 5.1

Postby flubba86 » 17. Mar 2017, 02:11

michaln wrote:In case it's not obvious to everyone: If you have a VM with Windows installed which does not see a microphone, upgrading VirtualBox will make no difference. Windows needs to be forced to re-detect the hardware (uninstalling the guest's HD Audio drivers does that).

Actually yes I had tried that after upgrading from 5.1.2 to 5.1.4, and again after updating from 5.1.4 to 5.1.6, then again after upgrading from 5.1.6 to 5.1.8. It is obvious to me that is the first thing I should try and I tried it more than once.

However I had not been doing the force-re-detect hardware procedure since upgrading to 5.1.10 because I guess I assumed it wouldn't work.

Today after upgrading from 5.1.16 to 5.1.18 and seeing this comment, I decided to give it another go. And it worked! I don't know which version introduced the change that fixed my specific problem, but it must've been some time between 5.1.10 and 5.1.18.
Thanks.
flubba86
 
Posts: 5
Joined: 22. Dec 2016, 02:07

Re: Microphone doesn't work after upgrade to 5.1

Postby michaln » 20. Mar 2017, 11:41

flubba86 wrote:Today after upgrading from 5.1.16 to 5.1.18 and seeing this comment, I decided to give it another go. And it worked! I don't know which version introduced the change that fixed my specific problem, but it must've been some time between 5.1.10 and 5.1.18.

Thanks for the report! It is unfortunate that Windows caches this information (I don't think any other OS does that) but it does, and we unfortunately can't force Windows to re-detect the HDA topology without triggering unwanted side effects.

That's actually how the problem slipped in in the first place, because existing VMs continued to work and only newly installed ones didn't.
michaln
Oracle Corporation
 
Posts: 2931
Joined: 19. Dec 2007, 15:45
Primary OS: MS Windows 7
VBox Version: PUEL
Guest OSses: Any and all

Re: Microphone doesn't work after upgrade to 5.1

Postby Exterminator13 » 14. Oct 2018, 13:47

Despite this thread is quite old, the problem of not working mic still persists.
I faced the issue twice on the following hosts: Linux Mint 17/17.2 (Ubuntu 14.04 LTS) and recently on Linux Mint 19 (Ubuntu 18.04 LTS).
Guest OS: Windows XP SP3
VirtualBox version: 5.1.x (the latest one in the branch, 5.1.38 doesn't work as well)

The problem: audio playback worked great, but microphone didn't work at all! Moreover, USB didn't recognize too!

The solution is simple: you have to add the current user to `vboxusers`:

Code: Select all   Expand viewCollapse view
sudo adduser $USER vboxusers

(details here: bit.ly/2PyEelJ)

After this action, USB devices began to be recognized as nothing happened before. And, of course, microphone also began to work!
Exterminator13
 
Posts: 1
Joined: 14. Oct 2018, 13:29

Previous

Return to VirtualBox on Linux Hosts

Who is online

Users browsing this forum: No registered users and 80 guests