Page 2 of 4

Re: Microphone doesn't work after upgrade to 5.1

PostPosted: 10. Aug 2016, 04:29
by hugonz
I'm experiencing the same problem. Tried everything, microphone does not work with any guest OS on any version, on either Intel or AC97, on any paravirtualization interface. I tried it all. Also tried ALSA, Pulse and OSS.

Thought it could be a problem with pulseaudio, so I tried direct pulse and jack with pulse, no change. Tried Ubuntu Mate and Manjaro, no change.

I checked and there's a lot of changes in the changelogs for recent Virtualbox in the audio department. Apparently they broke audio input and probably have not noticed or been able to fix it.

Here's my logs, just for the record:

Re: Microphone doesn't work after upgrade to 5.1

PostPosted: 10. Aug 2016, 08:58
by Muli
Hi All, suffering from the same issue,
a workaround for me -
- connect an USB headset, and connect to the it from USB devices.
- downgrade to 5.1.0 or prior.

is there any reply from virtualbox guys?

Muli.

Re: Microphone doesn't work after upgrade to 5.1

PostPosted: 12. Aug 2016, 09:41
by gromain
Just to add to the record, I do have the exact same issue.

I attached a clean log from a complete startup and shutdown of my machine.

I'm under Manjaro testing branch (the problem was also present on the stable branch) and running kernel 4.5.7 on a Lenovo Thinkpad E540.


R

Re: Microphone doesn't work after upgrade to 5.1

PostPosted: 17. Aug 2016, 16:36
by NachoGomez
So, there's a new VirtualBox version (5.1.4-110228) and the problem still persists. Probably we are not being heard (read) here in the forum by VBox people :x

Re: Microphone doesn't work after upgrade to 5.1

PostPosted: 17. Aug 2016, 17:52
by socratis
Yes, it usually isn't read. They prefer the bugtracker. In your case, look at: Ticket #15802: [Regression] No microphone, Windows Guest, Linux Host. Make your voice (logs) heard there.

Re: Microphone doesn't work after upgrade to 5.1

PostPosted: 17. Aug 2016, 23:38
by ElOjcar
I also have the problem, with Ubuntu 14.04LTS. Microphone worked well with virtualbox 5.0.xxx, but not with 5.1.xxx

Re: Microphone doesn't work after upgrade to 5.1

PostPosted: 18. Aug 2016, 07:19
by gideong
Mic input is still broken on 5.1.4. :(

Re: Microphone doesn't work after upgrade to 5.1

PostPosted: 24. Aug 2016, 11:57
by pentagonik
I've uploaded a new test build which hopefully should fix the problem:

The files can be downloaded from the https://www.virtualbox.org/wiki/Testbuilds page.

Scroll down to the Latest test builds / 5.1.x builds section and download the build apppropriate for your host platform.

Could you please try this and provide the usual VBox log files afterwards then?

This test build is not intended for production use!

Thank you!

Re: Microphone doesn't work after upgrade to 5.1

PostPosted: 25. Aug 2016, 01:55
by NachoGomez
Hello pentagonik,

Thank you very much for your time and help!

I'll download it tonight and I will test it tomorrow. I'll let you know as soon as I have feedback!

Regards...

Re: Microphone doesn't work after upgrade to 5.1

PostPosted: 25. Aug 2016, 09:40
by Muli
After applying the testbuild - same issue state,
My workaround for now is connecting an Audio USB dongle, connecting audio jacks to it and works.

Muli.

Re: Microphone doesn't work after upgrade to 5.1

PostPosted: 26. Aug 2016, 12:01
by albageddon
Hi pentagonik
well done!

after applying 5.1.5 as you suggested it fixed the problem for me.

my config:
Host: Archlinux with Pulseaudio server
Guest: Win7+VB Guest Additions 5.1.5+VB extpack 5.1.5

thanks again for your help! :)

Re: Microphone doesn't work after upgrade to 5.1

PostPosted: 3. Sep 2016, 09:54
by Monkiki
Great! When would be expect this new release?

Re: Microphone doesn't work after upgrade to 5.1

PostPosted: 5. Sep 2016, 12:25
by 0xCAFEBABE
@pentagonik: After installing it, and installing the guest additions the microphone signal is detected, but is heavily disrupted (stuttering-like). I have the same configuration as @albageddon.

EDIT: Downgrading to VirtualBox 5.1.0-r108711 solves the problem.

Re: Microphone doesn't work after upgrade to 5.1

PostPosted: 16. Sep 2016, 08:42
by gideong
I just tried Virtualbox 5.1.6. Mic is working again. Yay! I have a Windows 10 guest. At first, mic input from host device was still going to CD Audio in the Windows 10 guest VM instead of the mic. I had to uninstall the HD Audio driver and let Windows 10 detect the audio card again. After reinstalling the driver, the host mic is now properly mapped to the guest mic.

Re: Microphone doesn't work after upgrade to 5.1

PostPosted: 16. Sep 2016, 09:56
by Monkiki
I can confirm it works in v5.1.6 r110634

Thanks!!