Page 1 of 1

GParted Won't Start

PostPosted: 30. Jun 2015, 22:09
by BoiledFrog
I am trying to resize my .vdi file. I have successfully resized the .vdi using VBoxManage. Now I am trying to edit the partition table using GParted but it won't start the GUI. I would attach Xorg.0.log but it's only saved on the live disk and it isn't available after I stop it. I see it trying to load vboxvideo but it's complaining that it doesn't exist. After that, it complains that /dev/dri/card0 doesn't exist. Then it complains that /dev/fb0 doesn't exist. At this point it seems to give up and it deletes Screen 0 because it has "no matching config section". VESA(0) then complains it "Cannot read int vect". Then it finally fails because "no screens found".

Is there a way to get this to work? I tried both the i586 and amd64 version of GParted. I used 0.22.0-2 in both cases.

Alternatively, is there a way to mount the .vdi as a loopback device and use Gparted on the host? The host is Ubuntu 14.04.2.

Re: GParted Won't Start

PostPosted: 30. Jun 2015, 22:20
by Perryg
Gparted is based on Debian SID and as such the newest version does not work since it does not contain the guest additions needed and have changed the video for SID now.

Download the version before 0.22 and it will work.

Re: GParted Won't Start

PostPosted: 30. Jun 2015, 22:28
by BoiledFrog
I enabled EFI (whatever that means) and then it worked without having to downgrade GParted. I had to disable it again to boot the Debian guest.

Re: GParted Won't Start

PostPosted: 30. Jun 2015, 22:35
by Perryg
Good to know,but the improvements in Gparted .22 really have little to do with a virtual guest. Hopefully they will get this all figured out soon and we will not need to jump through hoops to get it to work.

Re: GParted Won't Start

PostPosted: 15. Jul 2015, 23:58
by NoNoNo
Recently I heard Gparted support EFI boot, but I didn't expect this situation.
Looks gparted team have something wrong with booting, I hope they boot well with and without EFI (traditional BIOS).

Re: GParted Won't Start

PostPosted: 29. Jan 2016, 13:35
by NoNoNo
NoNoNo wrote:Recently I heard Gparted support EFI boot, but I didn't expect this situation.


Today I try to boot VBox 5.0.14 with Gparted-live 0.25.0-1. Unfortunately, it won't bring up GUI with EFI DISABLE. (but GUI work with EFI enable, like previous statement. :? ) Booting sequences stop and show up "User Login:"(CLI mode).