Bidirectional clipboard not working

Discussions related to using VirtualBox on Linux hosts.

Bidirectional clipboard not working

Postby bluegroper » 4. Dec 2014, 10:35

Hi Forum
I'm using VirtualBox 4.3.20 on Centos 6.6 Host.
Have installed Oracle_VM_VirtualBox_Extension_Pack-4.3.20-96996.vbox-extpack
Using WinXP as Guest
Have installed GuestAdditions 4.3.20r96996
Rebooted guest and host.
Shared Clipboard set to Bidirectional
NOT using any special clipboard manager/s.

Cut 'n paste only works from guest to host :) , BUT NOT from host to guest. :(
Greatly appreciate any tips or clues to get this working as intended.

Edit. Log file now attached.
I did notice this line "fHMForced=true - 64-bit guest", BUT the Settings show "Windows XP (32 bit).
Attachments
WinXP-VBox.log
(63.07 KiB) Downloaded 49 times
bluegroper
 
Posts: 46
Joined: 22. Dec 2008, 08:14
Location: Would rather be swimming.
Primary OS: Linux other
VBox Version: OSE other
Guest OSses: Windozes, Linuxes, BSD's

Re: Bidirectional clipboard not working

Postby bluegroper » 4. Dec 2014, 12:37

I'm experimenting with a different Host hardware setup, but same host OS and Guest OS.
Is it possible that Bidirectional clipboard needs 3D Acceleration enabled ??
Slightly counter intuitive. :?
bluegroper
 
Posts: 46
Joined: 22. Dec 2008, 08:14
Location: Would rather be swimming.
Primary OS: Linux other
VBox Version: OSE other
Guest OSses: Windozes, Linuxes, BSD's

Re: Bidirectional clipboard not working

Postby mpack » 4. Dec 2014, 13:10

Why would a background software construct care about the type of graphics driver the display is using? It doesn't.

It's probably being called a 64bit guest because you gave the guest > 2GB, which btw an XP guest doesn't need. The sweet spot for XP is around 512MB, so 1GB is way more than enough. In any case there are other reasons why VT-x is forced, e.g. you allocated more than one CPU.

As to your issue, this is an area I'm ignorant about. Windows is a unified operating system with a single GUI standard, those standards particularly covering the format of text and graphics placed on the clipboard. That is what ensures that the clipboard data will be acceptable when moved from one Windows app to another, and probably also ensures the success of Windows --> Linux. Does whatever you're using on the Linux host do the same?

And just to clarify, you are only transferring text and images right? Not files containing text or images or anything else.
mpack
Site Moderator
 
Posts: 29224
Joined: 4. Sep 2008, 17:09
Primary OS: MS Windows 10
VBox Version: PUEL
Guest OSses: Mostly XP

Re: Bidirectional clipboard not working

Postby loukingjr » 4. Dec 2014, 13:46

Shared clipboard works in either direction with Mac OSX hosts, Windows XP SP3 guests. As mpack alluded to, with plain text or graphics clippings. What are you trying to copy and paste? From what program to what program?
OSX, Linux and Windows Hosts & Guests
There are three groups of people. Those that can count and those that can't.
loukingjr
Volunteer
 
Posts: 8827
Joined: 30. Apr 2009, 09:45
Primary OS: Mac OS X other
VBox Version: PUEL
Guest OSses: just about all that run

Re: Bidirectional clipboard not working

Postby bluegroper » 5. Dec 2014, 00:57

Only trying to transfer some small amounts of text. Not files or any images.

Microsoft taught us to enable absolutely everything, to make everything work. Sure, that philosophy might be sub-optimal, but any debate belongs elsewhere.
I'd be grateful for any suggestions to get this Bidirectional clipboard working as intended.
I have it working correctly on one hardware box, but not another. Finding the differences is mysterious.
TIA's for any tips or clues.
bluegroper
 
Posts: 46
Joined: 22. Dec 2008, 08:14
Location: Would rather be swimming.
Primary OS: Linux other
VBox Version: OSE other
Guest OSses: Windozes, Linuxes, BSD's

Re: Bidirectional clipboard not working

Postby loukingjr » 5. Dec 2014, 01:45

Because I do have a Linux box with Ubuntu 14.10 on it and I had a trial of Windows 7 available I thought I would test the shared clipboard from Linux>Windows. I copied text from both gedit and LibreOffice Writer and pasted both without a problem into Notepad on Windows 7.

Seeing you say you have a separate machine that works, I would say there is something wrong with the Gentoo install, the VirtualBox install, or the Windows install. Which I can't say. But it's obvious since it works for me with both Mac and Linux hosts > Windows, and it works for you in a different machine, about all you can do is try reinstalling the various bits on the machine that doesn't work.
OSX, Linux and Windows Hosts & Guests
There are three groups of people. Those that can count and those that can't.
loukingjr
Volunteer
 
Posts: 8827
Joined: 30. Apr 2009, 09:45
Primary OS: Mac OS X other
VBox Version: PUEL
Guest OSses: just about all that run

Re: Bidirectional clipboard not working

Postby bluegroper » 5. Dec 2014, 02:16

loukingjr
Thanks for your thoughts.
I agree with your conclusions, especially since :
- I have CentOS host and Windoze XP guest working with Bidirectional clipboard on another box.
- I have CentOS host and Windoze 2000 guest working with Bidirectional clipboard on same host thats borked with WinXP.

Rather than reinstall windoze XP, (which is a total PITA), I'll try exporting the WinXP VM from the working box, and import to the non-working box.
Whatever the outcome, this is already irritating.
bluegroper
 
Posts: 46
Joined: 22. Dec 2008, 08:14
Location: Would rather be swimming.
Primary OS: Linux other
VBox Version: OSE other
Guest OSses: Windozes, Linuxes, BSD's

Re: Bidirectional clipboard not working

Postby loukingjr » 5. Dec 2014, 02:19

Welcome.
I can imagine it's irritating. The next easiest step would be to reinstall VirtualBox.
OSX, Linux and Windows Hosts & Guests
There are three groups of people. Those that can count and those that can't.
loukingjr
Volunteer
 
Posts: 8827
Joined: 30. Apr 2009, 09:45
Primary OS: Mac OS X other
VBox Version: PUEL
Guest OSses: just about all that run

Re: Bidirectional clipboard not working

Postby loukingjr » 5. Dec 2014, 02:23

I know you said you didn't have any special clipboard managers installed but some distros come with Parcelite pre-installed.
OSX, Linux and Windows Hosts & Guests
There are three groups of people. Those that can count and those that can't.
loukingjr
Volunteer
 
Posts: 8827
Joined: 30. Apr 2009, 09:45
Primary OS: Mac OS X other
VBox Version: PUEL
Guest OSses: just about all that run

Re: Bidirectional clipboard not working

Postby socratis » 5. Dec 2014, 07:42

bluegroper wrote:Rather than reinstall windoze XP, (which is a total PITA), I'll try exporting the WinXP VM from the working box, and import to the non-working box.

Another simpler thing to try before you do any of the above, is to uninstall the Guest Additions, shut down the guest, restart it, make sure there are no signs of the GA and finally re-install the GA. There might be a small chance that something went wrong in there...
If you obfuscate any information requested, I will obfuscate my response. These are virtual UUIDs, not real ones.
Do NOT reply with the "QUOTE" button, please use the "POST REPLY", at the bottom of the form.
socratis
Site Moderator
 
Posts: 23883
Joined: 22. Oct 2010, 11:03
Location: Greece
Primary OS: Mac OS X other
VBox Version: PUEL
Guest OSses: Win(*>98), Linux*, OSX>10.5

Re: Bidirectional clipboard not working

Postby bluegroper » 12. Dec 2014, 02:36

This problem is proving very difficult to fix.
I've imported another WinXP VM, and initially the bi-directional was working as expected.
But now, its broken. Clipboard only from guest to host, NOT vice versa.
Tried removing and reinstalling guest additions, but no joy.
Reinstallation of windoze from scratch is such a PITA. And the endless updates, reboots, .....
Any other suggestions will be gratefully received and considered.
(Maybe I just go back to using Win2K, since its small, light and fast. And the clipboard works too.)
bluegroper
 
Posts: 46
Joined: 22. Dec 2008, 08:14
Location: Would rather be swimming.
Primary OS: Linux other
VBox Version: OSE other
Guest OSses: Windozes, Linuxes, BSD's

Re: Bidirectional clipboard not working

Postby bluegroper » 20. Jan 2015, 00:53

Latest testing indicates that these problem/s *might* be caused by KDE clipboard tool called "klipper".
bluegroper
 
Posts: 46
Joined: 22. Dec 2008, 08:14
Location: Would rather be swimming.
Primary OS: Linux other
VBox Version: OSE other
Guest OSses: Windozes, Linuxes, BSD's

Re: Bidirectional clipboard not working

Postby loukingjr » 20. Jan 2015, 01:19

bluegroper wrote:Latest testing indicates that these problem/s *might* be caused by KDE clipboard tool called "klipper".

I suppose it could be a "klipper" problem on the host side. I have two guests with KDE & klipper installed, OpenMandriva 4.1 and Kubuntu Plasma 5 and the bidirectional clipboard works fine.

You could always try uninstalling or disabling klipper.
OSX, Linux and Windows Hosts & Guests
There are three groups of people. Those that can count and those that can't.
loukingjr
Volunteer
 
Posts: 8827
Joined: 30. Apr 2009, 09:45
Primary OS: Mac OS X other
VBox Version: PUEL
Guest OSses: just about all that run

Re: Bidirectional clipboard not working

Postby hmickler » 27. Jan 2015, 16:45

I encountered the same problem and could identify the circumstances when this happens for me.

See my bugreport: Ticket #13792

Regards,
Holger
Last edited by mpack on 27. Jan 2015, 16:52, edited 1 time in total.
Reason: Add ticket URL.
hmickler
 
Posts: 1
Joined: 27. Jan 2015, 16:33

Re: Bidirectional clipboard not working

Postby mpack » 27. Jan 2015, 16:55

Re your ticket speculation "Obviously, the clipboard seems to be cleared when the VM started ". I would have guessed something different, i.e. that the Guest Additions in the VM cannot process a "new clipboard data" signal from the host when the GAs are not running.
mpack
Site Moderator
 
Posts: 29224
Joined: 4. Sep 2008, 17:09
Primary OS: MS Windows 10
VBox Version: PUEL
Guest OSses: Mostly XP

Next

Return to VirtualBox on Linux Hosts

Who is online

Users browsing this forum: Google [Bot] and 9 guests