Incorrect Password When Installing Extension Pack

Discussions related to using VirtualBox on Linux hosts.

Incorrect Password When Installing Extension Pack

Postby jim_deadlock » 13. May 2013, 14:47

I've just done a fresh install of my OS - Ubuntu 13.04 - and I've installed Virtualbox 4.2.12, it's all clean and new and is running fine. It runs my previously-created VMs (if I disable USB support) and creates new ones without any problem. However, when I try to install the Extension Pack 4.2.12 a bizarre thing happens, after I enter my login/admin password in the grey box it pops up again saying incorrect password. I'm DEFINITELY entering the correct password, I've tried it several times, checked my caps lock and everything. I did add my user to the vboxusers group in case that makes a difference. I've been using Vbox for years and this is the first time I've seen this. Weird!
jim_deadlock
 
Posts: 4
Joined: 13. May 2013, 14:31

Re: Incorrect Password When Installing Extension Pack

Postby noteirak » 13. May 2013, 19:41

Where did you download the extension pack?
Hyperbox - Virtual Infrastructure Manager - https://kamax.io/hbox/
Manage your VirtualBox infrastructure the free way!
noteirak
Site Moderator
 
Posts: 5134
Joined: 13. Jan 2012, 11:14
Primary OS: Debian other
VBox Version: OSE Debian
Guest OSses: Debian, Win 2k8, Win 7

Re: Incorrect Password When Installing Extension Pack

Postby jim_deadlock » 13. May 2013, 20:56

From the normal Vbox downloads page.
jim_deadlock
 
Posts: 4
Joined: 13. May 2013, 14:31

Re: Incorrect Password When Installing Extension Pack

Postby Perryg » 13. May 2013, 21:05

Problem is the password *is* the one for the host. You might be able to install using the terminal and using sudo.
Code: Select all   Expand viewCollapse view
sudo VBoxManage extpack install <tarball>

Replace <tarball> with the exact name of the ExtPack install
Perryg
Site Moderator
 
Posts: 33646
Joined: 6. Sep 2008, 22:55
Primary OS: Linux other
VBox Version: OSE self-compiled
Guest OSses: *NIX

Re: Incorrect Password When Installing Extension Pack

Postby jazzyl » 14. May 2013, 02:14

I'm experiencing the same problem as jim_deadlock.

I'm a newbie in the world of Linux. A Windows user all of my life (except a brief time with Commodore), so I'm a old guy in a young person's world. Help me out. I've read and reread the Virtualbox manual. Obviously there are a few steps I must have missed or just don't understand.

I've created my VM using Windows XP. I've added myself to the Vboxusers group.

Some of my system information is listed below.
-Computer- Processor : 2x Intel(R) Core(TM)2 CPU 6400 @ 2.13GHz
Memory : 1010MB (701MB used)
Operating System : Ubuntu 12.04.2 LTS

I'm attempting to add the Oracle VM VirtualBox Extension Pack 4.2.12-84980.vbox-extpack to my VirtualBox Settings using this sequence in the GUI from the Oracle VM Virtualbox Manager:
File
Preferences (Virtualbox Settings)
Extensions (Extension Packages)
Add Package (and I select the above mentioned extension package and click open)
License agreement and then click install

When I used my camraman1 password I get this result:
Failed to install the Extension Pack /home/camraman1/Downloads/Oracle_VM_VirtualBox_Extension_Pack-4.2.12-84980.vbox-extpack.

The installer failed with exit code 3: .

Result Code: NS_ERROR_FAILURE (0x80004005)
Component: ExtPackManager
Interface: IExtPackManager {3295e6ce-b051-47b2-9514-2c588bfe7554}

I've entered the same password I use with a request for authorization (I'm assuming this would be an equivalent admin password) using the Ubuntu Software program. I get this message after 3 attempts:

Failed to install the Extension Pack /home/camraman1/Downloads/Oracle_VM_VirtualBox_Extension_Pack-4.2.12-84980.vbox-extpack.

The installer failed with exit code 1: GNOME_SUDO_PASS

Sorry, try again.

GNOME_SUDO_PASS

Sorry, try again.

sudo: 3 incorrect password attempts.

Result Code: NS_ERROR_FAILURE (0x80004005) Component: ExtPackManager Interface: IExtPackManager {3295e6ce-b051-47b2-9514-2c588bfe7554}

Please help. I really need the USB 2.0 support. I'm a month behind updating my radio stations.

Is it possible to resolve this using the GUI?
jazzyl
 
Posts: 3
Joined: 14. May 2013, 00:13

Re: Incorrect Password When Installing Extension Pack

Postby Perryg » 14. May 2013, 02:28

@jazzyl,

You should first try from the VirtualBox main manager. (click file then preference and follow the instructions How to install Extension Pack
Perryg
Site Moderator
 
Posts: 33646
Joined: 6. Sep 2008, 22:55
Primary OS: Linux other
VBox Version: OSE self-compiled
Guest OSses: *NIX

Re: Incorrect Password When Installing Extension Pack

Postby jim_deadlock » 14. May 2013, 02:56

Worked like a charm thanks!

I'm still curious to know why it won't accept my host password normally though - that's what I kept trying to enter.
jim_deadlock
 
Posts: 4
Joined: 13. May 2013, 14:31

Re: Incorrect Password When Installing Extension Pack

Postby Perryg » 14. May 2013, 03:10

Not sure. I would guess it would depend on how you entered it and remember Linux is case sensitive so SUDO and sudo are not the same thing.
Perryg
Site Moderator
 
Posts: 33646
Joined: 6. Sep 2008, 22:55
Primary OS: Linux other
VBox Version: OSE self-compiled
Guest OSses: *NIX

Re: Incorrect Password When Installing Extension Pack

Postby jazzyl » 14. May 2013, 06:13

Perryg, I did.
jazzyl wrote:I'm attempting to add the Oracle VM VirtualBox Extension Pack 4.2.12-84980.vbox-extpack to my VirtualBox Settings using this sequence in the GUI from the Oracle VM Virtualbox Manager:
File
Preferences (Virtualbox Settings)
Extensions (Extension Packages)
Add Package (and I select the above mentioned extension package and click open)
License agreement and then click install

I just reviewed your How to install Extension Pack instructions and it matches the steps I took to install it.
The reason I'm attempting from the GUI is because of my inexperience with Linux command line.
Perryg wrote: You might be able to install using the terminal and using sudo.
Code: Select all   Expand viewCollapse view
sudo VBoxManage extpack install <tarball>

Replace <tarball> with the exact name of the ExtPack install

Since jim_deadlock was successful, I will make my first attempt at using the terminal. Are spaces allowed when entering the file name or should/do I add the underscore in place of spaces?
jazzyl
 
Posts: 3
Joined: 14. May 2013, 00:13

Re: Incorrect Password When Installing Extension Pack

Postby noteirak » 14. May 2013, 10:13

For the file name, it must be an exact match. The best would be that, from the directory where the file is, you enter the start of the filename (remember it's case-sensitive) and then press the TAB key, which will auto-complete the name.
Hyperbox - Virtual Infrastructure Manager - https://kamax.io/hbox/
Manage your VirtualBox infrastructure the free way!
noteirak
Site Moderator
 
Posts: 5134
Joined: 13. Jan 2012, 11:14
Primary OS: Debian other
VBox Version: OSE Debian
Guest OSses: Debian, Win 2k8, Win 7

Re: Incorrect Password When Installing Extension Pack

Postby Perryg » 14. May 2013, 14:16

Are spaces allowed when entering the file name or should/do I add the underscore in place of spaces?


You can not change the name and it does not have spaces in the original form.

Example for version 4.2.12
Code: Select all   Expand viewCollapse view
sudo VBoxManage extpack install Oracle_VM_VirtualBox_Extension_Pack-4.2.12.vbox-extpack
Perryg
Site Moderator
 
Posts: 33646
Joined: 6. Sep 2008, 22:55
Primary OS: Linux other
VBox Version: OSE self-compiled
Guest OSses: *NIX

Re: Incorrect Password When Installing Extension Pack

Postby jazzyl » 15. May 2013, 02:41

Thank you, Perryg and noteirak, for your assistance. I was successful with installing the extension pack. I had to add myself to the sudo group via the GUI (http://www.liberiangeek.net/2010/08/ena ... ucid-lynx/) and, in the terminal, performed a change directory (https://help.ubuntu.com/community/UsingTheTerminal) to point to the extension pack and watched the installation to a successful completion. :-)
jazzyl
 
Posts: 3
Joined: 14. May 2013, 00:13

Re: Incorrect Password When Installing Extension Pack

Postby noteirak » 15. May 2013, 09:46

Glad to hear it all worked out, and thank you for posting back on your success, giving others the ability to see what worked and what did not.
Hyperbox - Virtual Infrastructure Manager - https://kamax.io/hbox/
Manage your VirtualBox infrastructure the free way!
noteirak
Site Moderator
 
Posts: 5134
Joined: 13. Jan 2012, 11:14
Primary OS: Debian other
VBox Version: OSE Debian
Guest OSses: Debian, Win 2k8, Win 7

Re: Incorrect Password When Installing Extension Pack

Postby janssensm » 24. Jun 2013, 14:06

Hi,

Had the same issue today. I knew it could be done via command line, but couldn't stand that it didn't work with gui.

Found out that more applications had this behavior.
My first encounter was with Ati control center. see bug #801952 on launchpad
This is my first post so i'm not allowed to post urls, but i'm sure you can find it.

How tot solve:
gksu-properties was set to su instead of sudo. So just type:
Code: Select all   Expand viewCollapse view
gksu-properties

And set is to sudo.

So setting it to sudo solved installing the expension pack for VirtualBox too.
janssensm
 
Posts: 1
Joined: 24. Jun 2013, 13:49


Return to VirtualBox on Linux Hosts

Who is online

Users browsing this forum: Yahoo [Bot] and 7 guests