VBoxSVC uses >100% of CPU

Discussions related to using VirtualBox on Linux hosts.

VBoxSVC uses >100% of CPU

Postby ElectricSnark » 6. Jul 2012, 01:06

Just noticed that the VBoxSVC process is using > 100% of CPU, even when no VM is running. I'm running a 3.0.0 debian kernel, with version 4.1.18 of virtualbox.

Anyone have a clue what's causing this? I'm pretty sure it didn't use to do this, though I don't know when it started.

thanks in advance!
ElectricSnark
 
Posts: 5
Joined: 6. Jul 2012, 01:04

Re: VBoxSVC uses >100% of CPU

Postby Perryg » 6. Jul 2012, 01:39

Depends on if the com server got stuck.
Kill the service and and see if it happens again. If it does then you need to provide the information needed to try and diagnose the problem.
Where did you get your version of VirtualBox? Was it the Debian repo or VirtualBox.org?
Perryg
Site Moderator
 
Posts: 25915
Joined: 6. Sep 2008, 22:55
Primary OS: Linux other
VBox Version: OSE self-compiled
Guest OSses: *NIX - Other

Re: VBoxSVC uses >100% of CPU

Postby ElectricSnark » 6. Jul 2012, 19:41

I have killed and restarted the service several times, to no effect.

The version is from virtualbox[dot]org:

download[dot]virtualbox[dot]org/virtualbox/4.1.18/virtualbox-4.1_4.1.18-78361~Debian~lenny_amd64.deb

(sorry about the formatting - it seems i'm not yet allowed to post urls)

I have also installed the appropriate expansion pack

here's what it looks like in top:
Code: Select all   Expand viewCollapse view
  PID USER      PR  NI  VIRT  RES  SHR S %CPU %MEM    TIME+  COMMAND           
19930 usernam   20   0  233m 9556 5916 S  128  0.1   1394:29 VBoxSVC           
ElectricSnark
 
Posts: 5
Joined: 6. Jul 2012, 01:04

Re: VBoxSVC uses >100% of CPU

Postby Perryg » 6. Jul 2012, 19:52

Very unusual. Even with everything running I only see 0.4% of CPU usage for VBoxSVC.
Post the /var/log/vbox-install.log
Perryg
Site Moderator
 
Posts: 25915
Joined: 6. Sep 2008, 22:55
Primary OS: Linux other
VBox Version: OSE self-compiled
Guest OSses: *NIX - Other

Re: VBoxSVC uses >100% of CPU

Postby ElectricSnark » 6. Jul 2012, 20:02

/var/log/vbox-install.log:

Code: Select all   Expand viewCollapse view
Uninstalling modules from DKMS
Attempting to install using DKMS

Creating symlink /var/lib/dkms/vboxhost/4.1.18/source ->
                 /usr/src/vboxhost-4.1.18

DKMS: add completed.

Kernel preparation unnecessary for this kernel.  Skipping...

Building module:
cleaning build area....
make KERNELRELEASE=3.0.0 -C /lib/modules/3.0.0/build M=/var/lib/dkms/vboxhost/4.1.18/build..........
cleaning build area....

DKMS: build completed.

vboxdrv:
Running module version sanity check.
 - Original module
   - No original module exists within this kernel
 - Installation
   - Installing to /lib/modules/3.0.0/updates/dkms/

vboxnetflt.ko:
Running module version sanity check.
 - Original module
   - No original module exists within this kernel
 - Installation
   - Installing to /lib/modules/3.0.0/updates/dkms/

vboxnetadp.ko:
Running module version sanity check.
 - Original module
   - No original module exists within this kernel
 - Installation
   - Installing to /lib/modules/3.0.0/updates/dkms/

vboxpci.ko:
Running module version sanity check.
 - Original module
   - No original module exists within this kernel
 - Installation
   - Installing to /lib/modules/3.0.0/updates/dkms/

depmod....

DKMS: install completed.
ElectricSnark
 
Posts: 5
Joined: 6. Jul 2012, 01:04

Re: VBoxSVC uses >100% of CPU

Postby Perryg » 6. Jul 2012, 20:09

Sorry to say I don't know what to tell you. The VBoxSVC should really not be running if the guest and the VBox main manager is not running.
You said that you killed and then started it again. You don't mean that you are manually starting the VBoxSVC do you? The service is on demand.
Perryg
Site Moderator
 
Posts: 25915
Joined: 6. Sep 2008, 22:55
Primary OS: Linux other
VBox Version: OSE self-compiled
Guest OSses: *NIX - Other

Re: VBoxSVC uses >100% of CPU

Postby ElectricSnark » 6. Jul 2012, 20:25

I killed it either with a KILL signal to the process, or by quitting from the "Oracle VM VirtualBox Manager" app. It starts up again when I start the "Oracle VM VirtualBox Manager" app. Note that as soon as I start the manager, the CPU pegs to > 100%, before I even start a VM guest. Here are the processes I see running:

starting the app:
Code: Select all   Expand viewCollapse view
USER       PID %CPU %MEM    VSZ   RSS TTY      STAT START   TIME COMMAND
usernam  30598 14.0  0.4 554568 51740 ?        Sl   11:20   0:00 /usr/lib/virtualbox/VirtualBox
usernam  30614  0.5  0.0  88520  5316 ?        S    11:20   0:00 /usr/lib/virtualbox/VBoxXPCOMIPCD
usernam  30621  121  0.0 241624  9888 ?        Sl   11:20   0:04 /usr/lib/virtualbox/VBoxSVC --auto-shutdown


starting a VM:
Code: Select all   Expand viewCollapse view
USER       PID %CPU %MEM    VSZ   RSS TTY      STAT START   TIME COMMAND
usernam  30598  0.7  0.4 554700 51928 ?        Sl   11:20   0:00 /usr/lib/virtualbox/VirtualBox
usernam  30614  0.0  0.0  88580  5512 ?        S    11:20   0:00 /usr/lib/virtualbox/VBoxXPCOMIPCD
usernam  30621  126  0.1 243076 12212 ?        Sl   11:20   2:36 /usr/lib/virtualbox/VBoxSVC --auto-shutdown
usernam  30663  153  9.0 1673320 1040800 ?     SLl  11:22   0:06 /usr/lib/virtualbox/VirtualBox --comment WinXP --startvm 4bca1a50-5bc-c77-88d0-77f272a167b0 --no-startvm-errormsgbox


stopping the VM:
Code: Select all   Expand viewCollapse view
USER       PID %CPU %MEM    VSZ   RSS TTY      STAT START   TIME COMMAND
usernam  30598  0.5  0.4 554700 51800 ?        Sl   11:20   0:01 /usr/lib/virtualbox/VirtualBox
usernam  30614  0.1  0.0  88576  5508 ?        S    11:20   0:00 /usr/lib/virtualbox/VBoxXPCOMIPCD
usernam  30621  128  0.1 243340 12848 ?        Sl   11:20   4:27 /usr/lib/virtualbox/VBoxSVC --auto-shutdown
ElectricSnark
 
Posts: 5
Joined: 6. Jul 2012, 01:04

Re: VBoxSVC uses >100% of CPU

Postby Perryg » 6. Jul 2012, 20:33

I don't know what to tell you. It must be something specific to your host as I have never seen this here before or on any of my installs.
You should post a ticket at bugtracker
Perryg
Site Moderator
 
Posts: 25915
Joined: 6. Sep 2008, 22:55
Primary OS: Linux other
VBox Version: OSE self-compiled
Guest OSses: *NIX - Other

Re: VBoxSVC uses >100% of CPU

Postby ElectricSnark » 6. Jul 2012, 20:51

Done: ticket #10733

Thanks.
ElectricSnark
 
Posts: 5
Joined: 6. Jul 2012, 01:04

Re: VBoxSVC uses >100% of CPU

Postby malloc » 9. Jul 2012, 09:02

I'm having the same behaviour on CentOS 6.2 x64 (kernel 2.6.32 vbox 4.1.18). When any guest system is started, VBoxSVC uses about 160% of cpu. So the problem seems not to be host specific.
malloc
 
Posts: 2
Joined: 9. Jul 2012, 08:45

Re: VBoxSVC uses >100% of CPU

Postby malloc » 10. Jul 2012, 08:36

When no VM is started VBoxSVC consumes 120-140% of cpu. Now i'm running 3 vm's (2xwin2003srv 32bit and 1xwin2008srv x64) and VboxSVC uses 160-200% of cpu even if guest systems ane not used at all (1-2% utilisation per core). It did not happen with previous (4.1.16) version.
malloc
 
Posts: 2
Joined: 9. Jul 2012, 08:45

Re: VBoxSVC uses >100% of CPU

Postby TuXator » 11. Jul 2012, 16:21

I had similar issues.
The kernels leap second bug turned out to be the reason.
Resetting the clock, e.g. using
Code: Select all   Expand viewCollapse view
date -s "$(LC_ALL=C date)"
fixed the problem for me. (Rebooting is another option.)

Cheers,
--leo
TuXator
 
Posts: 1
Joined: 11. Jul 2012, 16:02

Re: VBoxSVC uses >100% of CPU

Postby ctrl » 14. Jul 2012, 10:24

TuXator wrote:I had similar issues.
The kernels leap second bug turned out to be the reason.

Same thing here, and it also fixed my serviio server eating the other 3 cores. Thanks.
ctrl
 
Posts: 3
Joined: 14. Jul 2012, 10:21

Re: VBoxSVC uses >100% of CPU

Postby A1an » 15. Jan 2013, 20:54

Just stumbled across a similar issue. No VM running (one marked as inaccessible tough). Shortly after starting the manager GUI it gets greyed out ant top shows similar process list with SVC at 101%

uname -a
Linux host 2.6.32-45-generic #102-Ubuntu SMP Wed Jan 2 22:38:04 UTC 2013 x86_64 GNU/Linux

Ubuntu 10.04.4 lucid

virtualbox-4.2 (4.2.6-82870~Ubuntu~lucid)

Resetting date did not solve the issue.
A1an
 
Posts: 8
Joined: 19. Nov 2012, 13:34


Return to VirtualBox on Linux Hosts

Who is online

Users browsing this forum: Bing [Bot] and 19 guests