USB Problems in version 4.1.x (4.0.x works ok)

Discussions related to using VirtualBox on Linux hosts.

USB Problems in version 4.1.x (4.0.x works ok)

Postby starfry » 4. Jan 2012, 23:05

Hello, I have a problem on my system since upgrading from 4.0.8 that makes USB not work properly.

I have tried versions 4.1.6 (previously mentioned this issue on thread discuss the 4.1.6 release) and now 4.1.8 has the same problem.

Everything appears to work but when I go to use a USB device I get errors. For example, I have a creative ZEN media player and have been using its "organiser" app for some time to load videos on to it over USB. It's always worked fine and does still work fine if I run VirtualBox 4.0.8.

If I use a version later than 4.0.8 ( specifically I have tried 4.1.6 and 4.1.8 ) the app reports errors claiming that the video file is not of the correct format.

If I downgrade to VirtualBox 4.0.8 it works fine: same host, same guest image, same video file, same USB connection.

Host is Arch Linux. I am using the official Oracle package not the one in the Arch Linux package repository.

Guest is Windows 7.

If I can help by providing more information please let me know how. I am currently stuck unable to update (at least I have a working system albeit stuck at version 4.0.8.

Many thanks.
Last edited by starfry on 12. Jan 2012, 13:03, edited 1 time in total.
starfry
 
Posts: 23
Joined: 31. Oct 2007, 11:59

Re: USB Problems on versions after 4.0.8

Postby starfry » 8. Jan 2012, 23:01

No word on this, well I have done some more research. The problem was introduced with the 4.1.x version stream. Version 4.1.0 has the problem. Version 4.0.14 does not. I will raise a bug report.

*defect raised: https://www.virtualbox.org/ticket/10145
starfry
 
Posts: 23
Joined: 31. Oct 2007, 11:59


Return to VirtualBox on Linux Hosts

Who is online

Users browsing this forum: Bing [Bot] and 35 guests