Unable to exit scale mode

Discussions related to using VirtualBox on Linux hosts.

Unable to exit scale mode

Postby bobo333 » 13. Oct 2011, 16:39

Hi
I am a virtualbox newbie. I recently installed 4.1.2 for Natty host with win7 64 enterprise as the guest. 4.1.2 was working very well and then updated to 4.1.4. Notice that guestadditions were installed.
Soon after updating I noticed that when I switch to scale, full screen or seamless mode (Host-C) it is impossible to reverse to any other mode. The VB menu becomes inaccessible and the shortcuts Host-F, Host-C, Host-home just do not work. When in scale mode, frequently, but not always the guest OS freezes and the only option is to power off the virtual machine. When I restart the guest OS I get the message telling me that the guest OS will be start in scale mode. If I do not accept the virtual machine sessions fails to open with the following message

Failed to open a session for the virtual machine win7_
The VM session was closed before any attempt to power it
Result Code: NS_ERROR_FAILURE (0x80004005)
Component: SessionMachine
Interface: ISession {12f4dcdb-12b2-4ec1-b7cd-ddd9f6c5bf4d}

If I try to start a the guest OS again, there is no message about starting is scale mode and the OS boots regularly, but again switching to any mode once will make the menu inaccessible and the Host key shortcuts ineffective.

Tried sudo /etc/init.d/vboxdrv setup which did not make any difference

1. does anybody else experiences this problem?
2. how can I remove the current virtualbox install and install a fresh one without losing my host and its settings. I am thinking to go back to 4.1.2. I looked around but I was not able to find a step by step procedure
Thanks I advance for any help
bobo333
 
Posts: 2
Joined: 13. Oct 2011, 16:10
Primary OS: Ubuntu other
VBox Version: OSE Debian
Guest OSses: Win7 64 enterprise

Re: Unable to exit scale mode

Postby peterkawa » 17. Oct 2011, 13:31

Exactly the same problems with losing the VB menu and shortcuts Host-C Host-home etc. here.
Running Ubuntu 11.10 and VB 4.1.4.
I'm stuck with a scaled virtual now and can't get it to boot in 'normal' mode... Anyone? T.i.a.
peterkawa
 
Posts: 3
Joined: 17. Oct 2011, 13:22
Primary OS: Ubuntu other
VBox Version: PUEL
Guest OSses: windows7 windows8

Re: Unable to exit scale mode

Postby peterkawa » 17. Oct 2011, 13:47

Hi,
I've found a 'solution'.
Changing your Home key seems to help!
 Edit: Forgot to say this works for me. 

Try changing it from Alt Gr to Right CTRL for example.
Go tot File -> Preferences -> Input

Link:
viewtopic.php?f=8&t=18487
peterkawa
 
Posts: 3
Joined: 17. Oct 2011, 13:22
Primary OS: Ubuntu other
VBox Version: PUEL
Guest OSses: windows7 windows8

Re: Unable to exit scale mode

Postby bobo333 » 17. Oct 2011, 16:52

peterkawa, it works!!!!!
Thank you so much!!!!
bobo333
 
Posts: 2
Joined: 13. Oct 2011, 16:10
Primary OS: Ubuntu other
VBox Version: OSE Debian
Guest OSses: Win7 64 enterprise

Re: Unable to exit scale mode

Postby peterkawa » 18. Oct 2011, 22:56

You're welcome bobo333!
peterkawa
 
Posts: 3
Joined: 17. Oct 2011, 13:22
Primary OS: Ubuntu other
VBox Version: PUEL
Guest OSses: windows7 windows8

Re: Unable to exit scale mode

Postby blux » 22. Nov 2011, 22:36

If anyone has been using a Mac OS install and get stuck with the scale mode, you can force a reset by these steps:

1. Close all virtual machines and VirtualBox
2. Find your machine config files (i.e. C:\Users\your.login\.VirtualBox\Machines\Mac)
3. Open for edit the file Mac.xml (or your machine name *.xml)
4. Edit the line <ExtraDataItem name="GUI/Scale" value="on"/> to
<ExtraDataItem name="GUI/Scale" value="off"/>
5. Restart VirtualBox

Hopefully that works for you!
blux
 
Posts: 1
Joined: 22. Nov 2011, 22:31
Primary OS: MS Windows 7
VBox Version: OSE other
Guest OSses: Mac OS

Re: Unable to exit scale mode

Postby MrEraky » 1. Sep 2012, 02:15

right Ctrl+C will make "Scale Mode" off
MrEraky
 
Posts: 1
Joined: 1. Sep 2012, 02:13

Re: Unable to exit scale mode

Postby wayfarer_boy » 11. Oct 2012, 14:52

Thanks MrEraky, Right Ctrl+C was the answer for me. :)
wayfarer_boy
 
Posts: 1
Joined: 11. Oct 2012, 14:51

Re: Unable to exit scale mode

Postby Iftekher » 24. Oct 2012, 09:40

Thank you very much MrEraky... yous reply was very simple and practical... :)
Iftekher
 
Posts: 2
Joined: 24. Oct 2012, 09:38

Re: Unable to exit scale mode

Postby MixMasterMax » 26. Oct 2012, 17:01

I had the same problem - stuck in scale mode, host key not working and no menus visible.

MrErkay: The OP's and my problem was that using the host key didn't work. In my case, I could use neither right ctrl + c to change the display mode nor use right crtl + pos1 to display the menu.

It now works after changing several settings. I'm not sure which was the fix, though.

Changing host key from right ctrl to AltGr, as suggested above, did not work initially.
Changing the settings for the mini toolbar to display at the top or toggling it off did not work (it was initially "on", but the mini toolbar was not displaying)

I then:

- changed host key back to right ctrl
- switched display mini toolbar to "on" again
- activated IO-APIC

One of these changes must have done the trick!

I'm running Win7 as a guest on a Linux Mint host.

Hope this helps.
MixMasterMax
 
Posts: 1
Joined: 26. Oct 2012, 16:51

Re: Unable to exit scale mode

Postby alan123 » 25. May 2015, 07:21

turn off the machine and turn on again. Virtual box will ask you if you want the escalde mode, click no. then start again and the problem is solved.
alan123
 
Posts: 3
Joined: 18. May 2015, 02:00


Return to VirtualBox on Linux Hosts

Who is online

Users browsing this forum: No registered users and 16 guests