NS_ERROR_FAILURE

Discussions related to using VirtualBox on Linux hosts.

NS_ERROR_FAILURE

Postby bluecube » 19. May 2011, 15:32

Hello,

I am getting this error with my Windows 7 VM. It's currently inaccessible..

Code: Select all   Expand viewCollapse view
PCDATA invalid Char value 3.
Location: '/home/my.name/VirtualBox VMs/Windows 7/Windows 7.vbox', line 157 (3), column 36.
/home/vbox/vbox-4.0.8/src/VBox/Main/src-server/MachineImpl.cpp[679] (nsresult Machine::registeredInit()).
Result Code:
NS_ERROR_FAILURE (0x80004005)
Component:
VirtualBox
Interface:
IVirtualBox {d2de270c-1d4b-4c9e-843f-bbb9b47269ff}


I'm running Fedora 14 on 2.6.35

I've done some searching, but a lot of the problems don't apply to me. Can anyone help me figure this out? I am relatively new to Linux, I've been on board for just about a year now.
bluecube
 
Posts: 3
Joined: 19. May 2011, 15:27
Primary OS: Fedora other
VBox Version: OSE Fedora
Guest OSses: Windows 7

Re: NS_ERROR_FAILURE

Postby Perryg » 19. May 2011, 15:38

Do you know what caused this? Fedora update, VBox update, Power failure, ETC.? What happened between the time it worked and now?
Also where does you VBox come from, VirtualBox.org,? It looks like you are running a self-compiled version, is that right?
Perryg
Site Moderator
 
Posts: 34372
Joined: 6. Sep 2008, 22:55
Primary OS: Linux other
VBox Version: OSE self-compiled
Guest OSses: *NIX

Re: NS_ERROR_FAILURE

Postby bluecube » 19. May 2011, 15:52

I did a VBox update not too long ago, I ran the Windows 7 VM once after the update to 4.0.8, when I shut it down and tried to run it again I got the error.

I am running from the rpm at virtualbox.org
bluecube
 
Posts: 3
Joined: 19. May 2011, 15:27
Primary OS: Fedora other
VBox Version: OSE Fedora
Guest OSses: Windows 7

Re: NS_ERROR_FAILURE

Postby Perryg » 19. May 2011, 16:02

Go ahead and post the *.vbox file for this guest. Also if there is a valid guest log file, post the newest (lowest number) here as well (as an attachment).
Do you use snapshots, or was the VBox update done while the guest was in a saved stated (not shut down)?
Perryg
Site Moderator
 
Posts: 34372
Joined: 6. Sep 2008, 22:55
Primary OS: Linux other
VBox Version: OSE self-compiled
Guest OSses: *NIX

Re: NS_ERROR_FAILURE

Postby tmhunt2 » 19. May 2011, 17:03

I got the same error today with the exact same symptoms as you.

Only my xml file referenced line 158. I look at the file and Line 158 had the following line:

<GuestProperty name="/VirtualBox/GuestAdd/VersionEx" value="^L^C" timestamp="1305645451082681000" flags=""/>

The "^L^C" looked oddly out of place. So I removed those values and left it blank ex: value=""

The new line loks like:

<GuestProperty name="/VirtualBox/GuestAdd/VersionEx" value="" timestamp="1305645451082681000" flags=""/>

I could then boot the VM normally. I have no idea what might have caused this only that it fixed my issue. So far I have had no repercussions.

Hope this helps you.
tmhunt2
 
Posts: 2
Joined: 9. Dec 2009, 22:22
Primary OS: Fedora other
VBox Version: OSE Fedora
Guest OSses: Windows XP 32bit, Windows 7 64bit

Re: NS_ERROR_FAILURE

Postby colemickens » 19. May 2011, 18:05

I have had this problem occur three times.

I'm using the Ubuntu 11.04 binary packages. I have the default extpack installed. I always shut down my VM responsibly, and know for sure that I did so when this same corruption has occurred. Opening the *.vbox file and removing the GuestPropert for VersionEx resolves the problem each time.

I never had this happen prior to upgrading to 4.0.8.

(also, off topic, I find it completely unacceptable that my password was emailed to me in plaintext)
colemickens
 
Posts: 1
Joined: 19. May 2011, 18:02
Primary OS: Ubuntu other
VBox Version: OSE Debian
Guest OSses: Windows 7

Re: NS_ERROR_FAILURE

Postby bluecube » 19. May 2011, 18:18

I did the same thing, and saw two funny characters in the value property, deleted them and I'm back..

Must be a bug..

Thank you guys for helping me out..
bluecube
 
Posts: 3
Joined: 19. May 2011, 15:27
Primary OS: Fedora other
VBox Version: OSE Fedora
Guest OSses: Windows 7

Re: NS_ERROR_FAILURE

Postby tmhunt2 » 19. May 2011, 18:32

Glad it helped. I never had this happen before either. I guess we will be seeing 4.0.10 pretty soon. ;-)
tmhunt2
 
Posts: 2
Joined: 9. Dec 2009, 22:22
Primary OS: Fedora other
VBox Version: OSE Fedora
Guest OSses: Windows XP 32bit, Windows 7 64bit

Re: NS_ERROR_FAILURE

Postby defol » 20. May 2011, 08:55

I have the same problem:
This line is responsible:
<GuestProperty name="/VirtualBox/GuestAdd/VersionEx" value="" timestamp="1305871687566004000" flags=""/>

After changing the value to .... (I tried rather everything incl. deleting the complete line) I can start the VM .....but only once.
After shutting down the VM the invalid characters are written back.

I also changed the windoof7-64.vbox file to read only (chmod 400 windoof7-64.vbox) but it was changed back by virtualbox.
Any other idea?
Regards
D.F.
defol
 
Posts: 1
Joined: 19. May 2011, 15:57
Primary OS: Ubuntu other
VBox Version: OSE Debian
Guest OSses: Windows 7 - 64

Re: NS_ERROR_FAILURE

Postby brhahlen » 20. May 2011, 09:07

I am having the same error, Fedora 14, x86_64.
It only started occurring after my update to 4.0.8, never happened before.
My error reads:
Code: Select all   Expand viewCollapse view
PCDATA invalid Char value 3.
Location: '/home/bhahlen/.VirtualBox/Machines/VD_Office/VD_Office.xml', line 90 (3), column 36.
/home/vbox/vbox-4.0.8/src/VBox/Main/src-server/MachineImpl.cpp[679] (nsresult Machine::registeredInit()).
Result Code:
NS_ERROR_FAILURE (0x80004005)
Component:
VirtualBox
Interface:
IVirtualBox {d2de270c-1d4b-4c9e-843f-bbb9b47269ff}

The line in the XML reads:
Code: Select all   Expand viewCollapse view
<GuestProperty name="/VirtualBox/GuestAdd/VersionEx" value="" timestamp="1305789086129642000" flags=""/>

The last time I just deleted this line, and everything worked again, but removing the values in it also seems to work.
I think this really is a bug.
brhahlen
 
Posts: 6
Joined: 8. Apr 2010, 10:14
Primary OS: Fedora other
VBox Version: PUEL
Guest OSses: Win7, WinXP, Fedora, RHEL, OEL

Re: NS_ERROR_FAILURE

Postby kjbucknum » 20. May 2011, 14:09

Thanks for the tip. For the last 3 days I've been recreating the machine each morning. I had tried deleting the line, but it wouldn't start after that. I'll try just removing the control characters Monday when I come in.
kjbucknum
 
Posts: 4
Joined: 20. May 2011, 14:07
Primary OS: Ubuntu other
VBox Version: PUEL
Guest OSses: Win 7

Re: NS_ERROR_FAILURE

Postby matakb » 26. May 2011, 02:50

I have the same problem, everytime i have to remove the value="L " to value="". The win7 then can start. But it will write back to the file. Annoying when using.
matakb
 
Posts: 2
Joined: 26. May 2011, 02:45
Primary OS: Ubuntu other
VBox Version: OSE Debian
Guest OSses: Win7

Re: NS_ERROR_FAILURE

Postby Perryg » 26. May 2011, 02:58

Shut all things VBox down. Guest must be shut down not saved state.
Replace the crazy values with "4.0.8" and start the VBox service and guest. Does this help?
Perryg
Site Moderator
 
Posts: 34372
Joined: 6. Sep 2008, 22:55
Primary OS: Linux other
VBox Version: OSE self-compiled
Guest OSses: *NIX

Re: NS_ERROR_FAILURE

Postby brewerja » 27. May 2011, 15:35

No, I have the same problem, and replacing with 4.0.8 does not work. It starts and runs fine, but after shutdown, the value reverts to the special character. Very annoying to have to edit the .vbox file every time.
brewerja
 
Posts: 2
Joined: 27. May 2011, 15:32
Primary OS: Fedora other
VBox Version: OSE Fedora
Guest OSses: Windows 7

Re: NS_ERROR_FAILURE

Postby brewerja » 27. May 2011, 16:48

The solution can be found in the comments of this ticket: http://www.virtualbox.org/ticket/8948
brewerja
 
Posts: 2
Joined: 27. May 2011, 15:32
Primary OS: Fedora other
VBox Version: OSE Fedora
Guest OSses: Windows 7

Next

Return to VirtualBox on Linux Hosts

Who is online

Users browsing this forum: No registered users and 15 guests