vbox4 Auto capture keyboard

Discussions related to using VirtualBox on Linux hosts.

vbox4 Auto capture keyboard

Postby tot-to » 18. Jan 2011, 14:57

Recently I updated VirtualBox from 3.2.10 to 4.0.0
In older version with uncheked "Auto capture keyboard" hotkeys of my window manager always worked and arrow in right-bottom was black. Now when I switch workspace (aka virtual desktop) to workspace with Virtual Machine window, the arrow becomes green and hotkeys of window manager don't works.
What shall I do to get back old behavior?
tot-to
 
Posts: 5
Joined: 18. Jan 2011, 14:45
Primary OS: Other
VBox Version: PUEL
Guest OSses: Windows 7 Pro x64

Re: vbox4 Auto capture keyboard

Postby Sasquatch » 18. Jan 2011, 23:49

Check File > Preferences > Input in the main GUI. That's still there since they started VB years ago.
Read the Forum Posting Guide before opening a topic.
VirtualBox FAQ: Check this before asking questions.
Online User Manual: A must read if you want to know what we're talking about.
Howto: Install Linux Guest Additions
Howto: Use Shared Folders on Linux Guest
See the Tutorials and FAQ section at the top of the Forum for more guides.
Try searching the forums first with Google and add the site filter for this forum.
E.g. install guest additions site:forums.virtualbox.org

Retired from this Forum since OSSO introduction.
Sasquatch
Volunteer
 
Posts: 17800
Joined: 17. Mar 2008, 13:41
Location: /dev/random
Primary OS: Debian other
VBox Version: PUEL
Guest OSses: Windows XP, Windows 7, Linux

Re: vbox4 Auto capture keyboard

Postby tot-to » 19. Jan 2011, 11:41

Of course, it still there. But... it don't works. When I uncheck it, keyboard keeps capturing.
tot-to
 
Posts: 5
Joined: 18. Jan 2011, 14:45
Primary OS: Other
VBox Version: PUEL
Guest OSses: Windows 7 Pro x64

Re: vbox4 Auto capture keyboard

Postby Sasquatch » 21. Jan 2011, 23:16

Works as advertised for me.
Read the Forum Posting Guide before opening a topic.
VirtualBox FAQ: Check this before asking questions.
Online User Manual: A must read if you want to know what we're talking about.
Howto: Install Linux Guest Additions
Howto: Use Shared Folders on Linux Guest
See the Tutorials and FAQ section at the top of the Forum for more guides.
Try searching the forums first with Google and add the site filter for this forum.
E.g. install guest additions site:forums.virtualbox.org

Retired from this Forum since OSSO introduction.
Sasquatch
Volunteer
 
Posts: 17800
Joined: 17. Mar 2008, 13:41
Location: /dev/random
Primary OS: Debian other
VBox Version: PUEL
Guest OSses: Windows XP, Windows 7, Linux

Re: vbox4 Auto capture keyboard

Postby tot-to » 25. Jan 2011, 17:40

Whew I activate window with virtual machine, keyboard is capturing in vb4, but not in vb3.
tot-to
 
Posts: 5
Joined: 18. Jan 2011, 14:45
Primary OS: Other
VBox Version: PUEL
Guest OSses: Windows 7 Pro x64

Re: vbox4 Auto capture keyboard

Postby tot-to » 25. Jan 2011, 17:41

with unmarked "Auth capture keyboard" in both cases.
tot-to
 
Posts: 5
Joined: 18. Jan 2011, 14:45
Primary OS: Other
VBox Version: PUEL
Guest OSses: Windows 7 Pro x64

Re: vbox4 Auto capture keyboard

Postby Sasquatch » 27. Jan 2011, 00:48

You mean that the icon turns green (as in captured) with VB4? I know that even though the keyboard isn't grabbed for focus, as long as the VM window has focus, some keys are sent to the VM (you can type a document without having the keyboard grabbed for example).
Read the Forum Posting Guide before opening a topic.
VirtualBox FAQ: Check this before asking questions.
Online User Manual: A must read if you want to know what we're talking about.
Howto: Install Linux Guest Additions
Howto: Use Shared Folders on Linux Guest
See the Tutorials and FAQ section at the top of the Forum for more guides.
Try searching the forums first with Google and add the site filter for this forum.
E.g. install guest additions site:forums.virtualbox.org

Retired from this Forum since OSSO introduction.
Sasquatch
Volunteer
 
Posts: 17800
Joined: 17. Mar 2008, 13:41
Location: /dev/random
Primary OS: Debian other
VBox Version: PUEL
Guest OSses: Windows XP, Windows 7, Linux

Re: vbox4 Auto capture keyboard

Postby tot-to » 27. Jan 2011, 16:08

>You mean that the icon turns green (as in captured) with VB4?
Yes, it is. After that, hotkeys of my window manager (i.e. for change workspace or active window) don't works. In VB3 it happens only after pressing host key.
tot-to
 
Posts: 5
Joined: 18. Jan 2011, 14:45
Primary OS: Other
VBox Version: PUEL
Guest OSses: Windows 7 Pro x64

Re: vbox4 Auto capture keyboard

Postby Sasquatch » 28. Jan 2011, 23:46

Check the VirtualBox.xml file, you should have the following on line 7 (it's there in my config, you might have a different line number, but it's at the top at least).
Code: Select all   Expand viewCollapse view
<ExtraDataItem name="GUI/Input/AutoCapture" value="false"/>

If it doesn't say "false", then the option is never saved. If it does say "false", then I really wonder what is different on your system compared to mine that makes VB grab the keyboard despite the option.
Read the Forum Posting Guide before opening a topic.
VirtualBox FAQ: Check this before asking questions.
Online User Manual: A must read if you want to know what we're talking about.
Howto: Install Linux Guest Additions
Howto: Use Shared Folders on Linux Guest
See the Tutorials and FAQ section at the top of the Forum for more guides.
Try searching the forums first with Google and add the site filter for this forum.
E.g. install guest additions site:forums.virtualbox.org

Retired from this Forum since OSSO introduction.
Sasquatch
Volunteer
 
Posts: 17800
Joined: 17. Mar 2008, 13:41
Location: /dev/random
Primary OS: Debian other
VBox Version: PUEL
Guest OSses: Windows XP, Windows 7, Linux

Re: vbox4 Auto capture keyboard

Postby Villain » 23. Feb 2011, 05:46

Bump.

Have the same problem here, with a freshly installed VBox 4.0.4. Occurs when I switch to the running VM window, only under the condition that the cursor is over the desktop area of the VM (i.e. doesn't happen when the cursor is over a VBox toolbar). In fullscreen mode, it doesn't happen when switching between virtual desktops on my host, but does happen when switching between windows on the same virtual desktop.
Auto-capture checkbox is, of course, unchecked, and the GUI/Input/AutoCapture option in VirtualBox.xml is accordingly set to false.

Host is Slackware 13.1, x86. DE is Xfce.

This is very irritating - I'd be grateful for any help.
Villain
 
Posts: 1
Joined: 23. Feb 2011, 05:28
Primary OS: Linux other
VBox Version: PUEL
Guest OSses: WinXP, Win7

Re: vbox4 Auto capture keyboard

Postby Sasquatch » 26. Feb 2011, 16:17

Exactly what is happening when you're doing what, and what are you expecting to happen instead? You're quite vague about your issue.
Read the Forum Posting Guide before opening a topic.
VirtualBox FAQ: Check this before asking questions.
Online User Manual: A must read if you want to know what we're talking about.
Howto: Install Linux Guest Additions
Howto: Use Shared Folders on Linux Guest
See the Tutorials and FAQ section at the top of the Forum for more guides.
Try searching the forums first with Google and add the site filter for this forum.
E.g. install guest additions site:forums.virtualbox.org

Retired from this Forum since OSSO introduction.
Sasquatch
Volunteer
 
Posts: 17800
Joined: 17. Mar 2008, 13:41
Location: /dev/random
Primary OS: Debian other
VBox Version: PUEL
Guest OSses: Windows XP, Windows 7, Linux

Re: vbox4 Auto capture keyboard

Postby excel12 » 28. Feb 2011, 17:24

I have the same problems as the users above. For this reason I just abandoned version 4.0.4 and returned to 3.2.
The problem is the following: whatever you do, whether you have the Auto Capture option disabled in the "Preferences" or you do it manually in the configuration file mentioned before, VirtualBox just ignores it. The symptoms are following:
1. My VirtualBox works in full-screen mode (guest OS Windows XP).
2. Using Ctrl-Tab (kde) I switch from e.g. xterm windows to VirtualBox (Windows XP) window.
3. I write something or move a mouse cursor. From now on Ctr-Tab switched between windows inside Windows XP. With auto capture disabled it should still switch between kde windows (this was happening with ver. 3.2).

Shall I report a bug?
excel12
 
Posts: 1
Joined: 28. Feb 2011, 17:14
Primary OS: Debian Lenny
VBox Version: OSE Debian
Guest OSses: Windows XP


Return to VirtualBox on Linux Hosts

Who is online

Users browsing this forum: No registered users and 40 guests