File transfer from host to guest without guest additions

Discussions related to using VirtualBox on Linux hosts.

File transfer from host to guest without guest additions

Postby cwarner7_11 » 14. Jun 2010, 03:59

I am using VirtualBox PUEL 3.1.2, Host is Ubuntu 9.04 and Guest is Windows 98SE, for which there are no guest additions. How does one get files from the host system to the guest? Upgrading the guest to XP is not an option, because the whole purpose of going this route is to preserve some legacy applications that won't run in XP...98SE does not recognize my thumb drives, and the computer does not have a floppy drive.
cwarner7_11
 
Posts: 15
Joined: 14. Jun 2010, 03:53
Primary OS: Ubuntu other
VBox Version: PUEL
Guest OSses: Windows 98SE

Re: File transfer from host to guest without guest additions

Postby Perryg » 14. Jun 2010, 04:23

If the guest has network access you can do a normal network map of a shared drive. You would need to be using Bridged mode (if there is a router) or host-only if not. You can always add a second adapter to the guest set to NAT if you need Internet access.
Both machines will need to be in the same workgroup too. Samba will come into play also.
Perryg
Site Moderator
 
Posts: 25915
Joined: 6. Sep 2008, 22:55
Primary OS: Linux other
VBox Version: OSE self-compiled
Guest OSses: *NIX - Other

Re: File transfer from host to guest without guest additions

Postby cwarner7_11 » 14. Jun 2010, 04:35

I have tried to set up a host to guest network, but can not figure out which network driver I should use. I have tried several different adapters from the menu, but none seem to work. I have also loaded samba and am able to designate which folders I want to share, but they do not show up in Network Places (I did get one case where the VBox machine showed up in network places, but it was empty). What is NAT?
cwarner7_11
 
Posts: 15
Joined: 14. Jun 2010, 03:53
Primary OS: Ubuntu other
VBox Version: PUEL
Guest OSses: Windows 98SE

Re: File transfer from host to guest without guest additions

Postby TonyPh12345 » 15. Jun 2010, 21:35

NAT (Network Address Translation) makes your GUEST think it's using ONE IP address, while the outsiders see a different IP address.

This is the same think that your home broadband router does... 192.168.x.x on the inside, and some public address on the outside.

http://www.virtualbox.org/manual/ch06.html#network_nat
TonyPh12345
 
Posts: 30
Joined: 15. Jun 2010, 02:25
Primary OS: Fedora other
VBox Version: OSE Fedora
Guest OSses: Win 7

Re: File transfer from host to guest without guest additions

Postby ahznb » 16. Jun 2010, 06:28

You can also create a raw disk vmdk of the partition you wish to share with the VM (see manual 9.7.1.1). Just be sure that the disk you're sharing isn't mounted on the host when accessing from the VM. You'll also need to set permissions to access the raw disk i.e. chmod 666 /dev/sd?.
ahznb
 
Posts: 64
Joined: 7. Feb 2010, 13:39
Primary OS: Ubuntu other
VBox Version: PUEL
Guest OSses: Win98, XP, Win7, Ubuntu

Re: File transfer from host to guest without guest additions

Postby cwarner7_11 » 16. Jun 2010, 08:34

ahznb wrote:You can also create a raw disk vmdk of the partition you wish to share with the VM (see manual 9.7.1.1). Just be sure that the disk you're sharing isn't mounted on the host when accessing from the VM. You'll also need to set permissions to access the raw disk i.e. chmod 666 /dev/sd?.

This approach doesn't quite suit my particular needs, since I want to be able to switch between host and guest during a project. This is a data acquisition application, where I am using Win98 SE legacy software to access some data acquisition hardware, and I want to send the results to the host (generally in *.csv format) for further manipulation and analysis. There is also a desire (but not an absolute need) to occasionally send graphics images to the host (i.e., charts from Excel 2000), but I have other ways of accomplishing this if I can get the raw data to the host. I do not need to connect the guest to the Internet (one should NEVER connect a Windows box to the Internet!), nor do I need to connect the guest to other computers. This is strictly guest to host communications...
cwarner7_11
 
Posts: 15
Joined: 14. Jun 2010, 03:53
Primary OS: Ubuntu other
VBox Version: PUEL
Guest OSses: Windows 98SE

Re: File transfer from host to guest without guest additions

Postby cwarner7_11 » 16. Jun 2010, 09:41

Perryg wrote:If the guest has network access you can do a normal network map of a shared drive. You would need to be using Bridged mode (if there is a router) or host-only if not. You can always add a second adapter to the guest set to NAT if you need Internet access.
Both machines will need to be in the same workgroup too. Samba will come into play also.

Here is some additional information on the machine setup:

1. The computer is set up as a dual boot system, first boot sector is Ubuntu 9.04, 32 bit (and this is the sector I am working in with VirtualBox, with Win98SE as the Guest) and Ubuntu 9.10 64-bit (I haven't been able to get VirtualBox to re-build in Ubuntu 9.10 after an attempted upgrade yet, but that is another issue).
2. Apparently, My "Host Only" network setup is actually detecting the Ubuntu 9.10 64-bit sector, not the actual host sector.
Here are some settings from the guest and the host:

In VirtualBox:

Host-only Network Details:

IOv4 Addre4ss: 192.168.56.1
IPv4 Network Mask: 255.255.255.0
IPv6 Address: fe80:0000:0000:0000:0800:27fe00:0000
IPv6 Network Mask Length: 64

DHCP Server:

Enabled
Server Address: 192.168.56.100
Server Mask: 255.255.255.0
Lower Address Bound: 192.168.56.101
Upper Address Bound: 192.168.56.254

In Ubuntu 9.04, Devices - Network Tools:

For Network Device: "Unknown Interface (vboxnet0)"

IPv6 fe80::800:27ff:fe00:0 Netmask/Prefix 64 Scope Link
IPv4 192.168.56.1 255.255.255.0

In VirtualBox, In "Network Neighborhood" in the Win98SE guest, I now see a "Vbox1" computer listed, but interestingly, it is Described as "VirtualBox on Ubuntu 9.10". The host is actually Ubuntu 9.04, although the machine is set up for a dual boot between Ubuntu 9.10 and 9.04. So, it looks like the network is picking up the wrong disk sector- not the actual host sector.

So, where do I go from here?

Charlie
cwarner7_11
 
Posts: 15
Joined: 14. Jun 2010, 03:53
Primary OS: Ubuntu other
VBox Version: PUEL
Guest OSses: Windows 98SE

Re: File transfer from host to guest without guest additions

Postby ahznb » 16. Jun 2010, 10:17

Can you access your shares through that "Vbox1"? What did you name your host? Host name can be found in /etc/hostname & /etc/hosts .

What are you using to create network shares on the host? If your using samba, then in /etc/samba/smb.conf contains the description of your host.

Did you actually create any shares?

Is your host and vm on the same workgroup? If your using samba on the host, then /etc/samba/smb.conf also contains the workgroup name. You should change your vm to use the same workgroup.

If you didn't boot your host from the ubuntu 9.10 partition, then there is no way anyone can identify anything as being from that 9.10. You may have named your host 9.10 or Vbox1 or whatever the heck.
ahznb
 
Posts: 64
Joined: 7. Feb 2010, 13:39
Primary OS: Ubuntu other
VBox Version: PUEL
Guest OSses: Win98, XP, Win7, Ubuntu

Re: File transfer from host to guest without guest additions

Postby cwarner7_11 » 16. Jun 2010, 17:36

ahznb wrote:Can you access your shares through that "Vbox1"? What did you name your host? Host name can be found in /etc/hostname & /etc/hosts .

Vbox1 on the Guest opens, but is empty. Host name from /etc/hostname is "rocketman-desktop" and /etc/hosts has "localhost" and "rocketman-desktop".

What are you using to create network shares on the host? If your using samba, then in /etc/samba/smb.conf contains the description of your host.

/etc/samba/smb.conf names the workgroup "WORKGROUP". I do not find any description of the host in this file.

Did you actually create any shares?

Yes, I have created shares on "rocketman-desktop"

Is your host and vm on the same workgroup? If your using samba on the host, then /etc/samba/smb.conf also contains the workgroup name. You should change your vm to use the same workgroup.

How do I change the vm to use the same workgroup? I see nothing in the VirtualBox help files about workgroups. Now, I notice, which I had not noticed before, when I open "entire network" I see a work group "CWENG" which may have come from a previous experiment with VirtualBox on either the 9.04 or 9.10 installation. The VirtualBox installation on the 9.10 sector is no longer functional, however (lost during any attempted upgrade). I do not remember every having set up this work group in any of my systems, but there it is...

If you didn't boot your host from the ubuntu 9.10 partition, then there is no way anyone can identify anything as being from that 9.10. You may have named your host 9.10 or Vbox1 or whatever the heck.


I would like to believe that there is no way anyone can identify anything as being from the 9.10 sector, but that is what I am seeing. In Windows Guest, when I hignlight the Vbox1 icon, the description that appears most definitely says "\\Virtualbox on Ubuntu 9.10".

This is definitely more complicated than the old days of setting up a local network over RS232 hardwired connections!
cwarner7_11
 
Posts: 15
Joined: 14. Jun 2010, 03:53
Primary OS: Ubuntu other
VBox Version: PUEL
Guest OSses: Windows 98SE

Re: File transfer from host to guest without guest additions

Postby ahznb » 16. Jun 2010, 19:02

To change workgroup in Win98, you do it in the VM. Reference: http://technet.microsoft.com/en-us/libr ... 68184.aspx under section "Setting Computer Names and Workgroups".

BTW, did you install Win98 drivers for your virtual network card? Open Device Manager->Network Adapters, does it show your virtual network card? Is it configured properly? What is the guest's IP address?

If the guest's network is configured correctly, and you still can't see your host's shares, then in Windows Explorer, in the address box, type \\192.168.56.1, that is your host's IP address.
ahznb
 
Posts: 64
Joined: 7. Feb 2010, 13:39
Primary OS: Ubuntu other
VBox Version: PUEL
Guest OSses: Win98, XP, Win7, Ubuntu

Re: File transfer from host to guest without guest additions

Postby cwarner7_11 » 17. Jun 2010, 02:58

ahznb wrote:To change workgroup in Win98, you do it in the VM. Reference: http://technet.microsoft.com/en-us/libr ... 68184.aspx under section "Setting Computer Names and Workgroups".

BTW, did you install Win98 drivers for your virtual network card? Open Device Manager->Network Adapters, does it show your virtual network card? Is it configured properly? What is the guest's IP address?

If the guest's network is configured correctly, and you still can't see your host's shares, then in Windows Explorer, in the address box, type \\192.168.56.1, that is your host's IP address.


I have had a new incident here. When I check the "Cable Connected" box in the VirtualBox Network settings, I get another computer icon in "Network Places" which uses a truncated version of the host name (the actual host name is 17 characters long, and for some reason, I get only 16 characters). "Network Places" tells me this is not accessible. When I type \\192.168.56.1 into Windows Explorer, it asks for a password, but doesn't like the normal password that I use for that computer. I have allowed for Guest Access without user account in my shares. I get the same request for password when I type the truncated name into Windows Explorer.

With regards to virtual network card, I let Windows identify the network card and load the drivers- several times, as I have tried a number of different options available in the VirtualBox Network settings. I am beginning to suspect there may be something wrong with how I have Samba configured on the host, and I have begun wading through the documentation on Samba to see if I can find a clue, as well as reviewing the MS document you so kindly directed me to.

Charlie
cwarner7_11
 
Posts: 15
Joined: 14. Jun 2010, 03:53
Primary OS: Ubuntu other
VBox Version: PUEL
Guest OSses: Windows 98SE

Re: File transfer from host to guest without guest additions

Postby Perryg » 17. Jun 2010, 03:18

I have had a new incident here. When I check the "Cable Connected" box in the VirtualBox Network settings, I get another computer icon in "Network Places" which uses a truncated version of the host name (the actual host name is 17 characters long, and for some reason, I get only 16 characters). "Network Places" tells me this is not accessible. When I type \\192.168.56.1 into Windows Explorer, it asks for a password, but doesn't like the normal password that I use for that computer. I have allowed for Guest Access without user account in my shares. I get the same request for password when I type the truncated name into Windows Explorer.


Windows 98 can not handle log names. Probably another reason it is not a supported guest. Anyway it is not going to work like the newer OSes and you are going to need to use trial and error to get it to work.
Also remember that Windows 98 is 16-bit and that really makes a lot of difference. Keep every thing to no more then 8 characters and it should work.
Perryg
Site Moderator
 
Posts: 25915
Joined: 6. Sep 2008, 22:55
Primary OS: Linux other
VBox Version: OSE self-compiled
Guest OSses: *NIX - Other

Re: File transfer from host to guest without guest additions

Postby cwarner7_11 » 17. Jun 2010, 04:05

If I can just figure out how to change the host name...
cwarner7_11
 
Posts: 15
Joined: 14. Jun 2010, 03:53
Primary OS: Ubuntu other
VBox Version: PUEL
Guest OSses: Windows 98SE

Re: File transfer from host to guest without guest additions

Postby Perryg » 17. Jun 2010, 04:09

Perryg
Site Moderator
 
Posts: 25915
Joined: 6. Sep 2008, 22:55
Primary OS: Linux other
VBox Version: OSE self-compiled
Guest OSses: *NIX - Other

Re: File transfer from host to guest without guest additions

Postby ahznb » 17. Jun 2010, 06:45

As I've stated before, the host name is in /etc/hostname and /etc/hosts, just change it in those two places and reboot. Its a good idea to setup a samba user and password, you could allow guest access afterward. To setup a samba user, type "smbpasswd -a <username>".
ahznb
 
Posts: 64
Joined: 7. Feb 2010, 13:39
Primary OS: Ubuntu other
VBox Version: PUEL
Guest OSses: Win98, XP, Win7, Ubuntu

Next

Return to VirtualBox on Linux Hosts

Who is online

Users browsing this forum: Yahoo [Bot] and 11 guests