SEAMLESS MODE

Discussions related to using VirtualBox on Linux hosts.

SEAMLESS MODE

Postby philosopher » 7. Mar 2010, 14:28

Seamless mode is grayed out. I am using Mint Linux 8 as my guest operating system and I have already installed the guest addition. Is there anything else required to get seamless mode working. I know that guest addition is installed correctly and working since I am now able to use higher resolutions, but for some reason still cannot get seamless mode working.

I am fairly new to this all and any help would be greatly appreciated.

Regards,

Jeffrey
philosopher
 
Posts: 11
Joined: 26. Feb 2010, 04:36
Primary OS: Ubuntu other
VBox Version: OSE Debian
Guest OSses: Mint

Re: SEAMLESS MODE

Postby Perryg » 7. Mar 2010, 17:53

I suspect there is something wrong with your install or the guest additions did not install properly.
I just re-installed Mint-8 to see and it works like it should. Did you reboot after installing the guest additions?

What version of VirtualBox are you using?
Perryg
Site Moderator
 
Posts: 25920
Joined: 6. Sep 2008, 22:55
Primary OS: Linux other
VBox Version: OSE self-compiled
Guest OSses: *NIX - Other

Re: SEAMLESS MODE

Postby philosopher » 9. Mar 2010, 04:52

Do you have the instructions on how to install. I first tried to install, but further research revealed I needed to install dkms which I did after first install. Then I reinstalled guest additions. I suppose now I should uninstall guest additions and then reinstall/ Is there anything else I need to do?

I am running VB 3.1.2.

Thanks for your help!

Regards,

Jeffrey
philosopher
 
Posts: 11
Joined: 26. Feb 2010, 04:36
Primary OS: Ubuntu other
VBox Version: OSE Debian
Guest OSses: Mint

Re: SEAMLESS MODE

Postby Perryg » 9. Mar 2010, 16:10

Perryg
Site Moderator
 
Posts: 25920
Joined: 6. Sep 2008, 22:55
Primary OS: Linux other
VBox Version: OSE self-compiled
Guest OSses: *NIX - Other

Re: SEAMLESS MODE

Postby philosopher » 14. Mar 2010, 22:29

Thanks. I t did that but now can get gui up. It seems this is a possibility as per instructions but I am unable to use host+f2 to get to the CLI. Does anyone know how to access CLI using mint on virtual box?
philosopher
 
Posts: 11
Joined: 26. Feb 2010, 04:36
Primary OS: Ubuntu other
VBox Version: OSE Debian
Guest OSses: Mint

Re: SEAMLESS MODE

Postby Perryg » 15. Mar 2010, 01:51

Well I just tried and host+F1 through F6 opens fine and host+F7 takes it back to the desktop.
Maybe you need to boot direct to the CLI.
As soon as you see the boot screen hit the escape key, select recovery mode ii the grub menu, the select drop to root shell.
Perryg
Site Moderator
 
Posts: 25920
Joined: 6. Sep 2008, 22:55
Primary OS: Linux other
VBox Version: OSE self-compiled
Guest OSses: *NIX - Other

Re: SEAMLESS MODE

Postby philosopher » 15. Mar 2010, 03:04

OK I was able to hit esc and get into command line mode, thanks for that.

Now I have completed the instructions as per the link, but still get a white screen with no GUI. Did you have to create the xorg.conf file. When I went to the .etc.X11 there was no xorg.conf file so I creasted just as they had it in instructions. Then I added the lines about the display but still left with white screen. Any thoughts?
philosopher
 
Posts: 11
Joined: 26. Feb 2010, 04:36
Primary OS: Ubuntu other
VBox Version: OSE Debian
Guest OSses: Mint

Re: SEAMLESS MODE

Postby philosopher » 15. Mar 2010, 04:04

seems like i got seamless working now, i turned off 3-d acceleration. Do you use 3-d acceleration?
philosopher
 
Posts: 11
Joined: 26. Feb 2010, 04:36
Primary OS: Ubuntu other
VBox Version: OSE Debian
Guest OSses: Mint

Re: SEAMLESS MODE

Postby Perryg » 15. Mar 2010, 15:20

Actually no I don't. Eye candy does not appeal to me in a working guest, performance does, so I always leave 3D/2D off.
Perryg
Site Moderator
 
Posts: 25920
Joined: 6. Sep 2008, 22:55
Primary OS: Linux other
VBox Version: OSE self-compiled
Guest OSses: *NIX - Other

Re: SEAMLESS MODE

Postby philosopher » 16. Mar 2010, 04:11

oki assume, then that was the problem. thanks for your help!
philosopher
 
Posts: 11
Joined: 26. Feb 2010, 04:36
Primary OS: Ubuntu other
VBox Version: OSE Debian
Guest OSses: Mint

Re: SEAMLESS MODE

Postby Perryg » 16. Mar 2010, 04:37

As a side note. I have never gotten the 3D effects to work in seamless. Since the main screen is blanked out to where all you have is the panel and program it really does not matter. Full screen worked good though when I tried it out.
Perryg
Site Moderator
 
Posts: 25920
Joined: 6. Sep 2008, 22:55
Primary OS: Linux other
VBox Version: OSE self-compiled
Guest OSses: *NIX - Other

Re: SEAMLESS MODE

Postby philosopher » 16. Mar 2010, 04:59

Ok thanks.
philosopher
 
Posts: 11
Joined: 26. Feb 2010, 04:36
Primary OS: Ubuntu other
VBox Version: OSE Debian
Guest OSses: Mint

Re: SEAMLESS MODE

Postby philosopher » 16. Mar 2010, 05:00

Next project is to check out this wine3d stuff, just to explore.
philosopher
 
Posts: 11
Joined: 26. Feb 2010, 04:36
Primary OS: Ubuntu other
VBox Version: OSE Debian
Guest OSses: Mint


Return to VirtualBox on Linux Hosts

Who is online

Users browsing this forum: No registered users and 24 guests