Symbolic link on shared folder not visible as directory

Discussions related to using VirtualBox on Linux hosts.

Symbolic link on shared folder not visible as directory

Postby gewe » 8. Dec 2009, 15:04

In my shared folder on the host I created some symbolic links to other directories. In the guest, when browsing the shared folder, these symbolic links were visible and usable as directories.
After upgrading to VirtualBox 3.1 the symbolic links are now visible as 1kB files. They can not be opened as a file, and can not be used as a directory.

Host: Ubuntu 9.04, kernel 2.6.28-17-generic, with VirtualBox 3.1.0r55467
Guest 1: Windows XP Pro SP2, with Guest Additions 3.1.0.r55467
Guest 2: Windows Server 2003 Enterprise Edition SP2, with Guest Additions 3.0.8r53138

Both guests have the same problem. I removed VirtualBox 3.1, and reinstalled VirtualBox 3.0. Without changing anything in the guests, the symbolic links were usable again as directories.

How can I get back the original behaviour of the symbolic links, using VirtualBox 3.1?
gewe
 
Posts: 32
Joined: 8. Jan 2008, 20:36

Re: Symbolic link on shared folder not visible as directory

Postby TerryE » 8. Dec 2009, 15:29

Hummm, the nearest that i've found to this one is http://www.virtualbox.org/ticket/818. Perhaps your should register and log your problem case here.
Read the Forum Posting Guide
Google your Q site:VirtualBox.org or search for the answer before posting.
TerryE
Site Moderator
 
Posts: 3572
Joined: 28. May 2008, 08:40
Primary OS: Ubuntu other
VBox Version: PUEL
Guest OSses: Ubuntu 10.04 & 11.10, both Svr&Wstn, Debian, CentOS

Re: Symbolic link on shared folder not visible as directory

Postby gewe » 9. Dec 2009, 09:36

That ticket is 2 years old, and related to Linux guests. My problem is introduced with VirtualBox 3.1, and related to Windows guests. After creating a new ticket, I discovered an already existing one. :oops:
gewe
 
Posts: 32
Joined: 8. Jan 2008, 20:36

Re: Symbolic link on shared folder not visible as directory

Postby TerryE » 9. Dec 2009, 11:03

gewe, the ticket might be 2 years old, but it's been updated for 3.x, and the last change was 5 days ago, so it's still current. But you're right: one is Windows and one Linux; what this ticket says is that they are now both consistent: host symlinks don't work.
Read the Forum Posting Guide
Google your Q site:VirtualBox.org or search for the answer before posting.
TerryE
Site Moderator
 
Posts: 3572
Joined: 28. May 2008, 08:40
Primary OS: Ubuntu other
VBox Version: PUEL
Guest OSses: Ubuntu 10.04 & 11.10, both Svr&Wstn, Debian, CentOS

Re: Symbolic link on shared folder not visible as directory

Postby iraebrasil » 18. Jan 2010, 22:12

At work I use host Mac OS X 10.5.8, Linux CentOS guest and Virtualbox 3.0.12 r54655. Symbolic links created on the host file system works well on the guest file system via vboxsf mount. I rely on symbolic links for my work, so I won't update yet as everything is fine.

At home however, it doesn't work. There I use Mac OS X 10.6.2, same CentOS host. I was using Virtualbox 3.x (can't remember minor version) and it won't work. Updated to Virtualbox 3.1.2 and still won't work.

Mas OS X 10.6.x had some updates to the HFS+ file system and the filesystem API, so I thought this might be useful info. Tough Apple documentation may be more complete, I've read about the changes here: http://arstechnica.com/apple/reviews/20 ... 10-6.ars/7

For now. at home, I'm using an bash script loop with rsync to simulate the symbolic links.
Code: Select all   Expand viewCollapse view
#!/bin/bash
I=1
while [ $I -lt 2 ]; do
rsync -a /path/to/local/folder/ /path/to/shared/foder/subfolder/
sleep 2
done


This is lame, but saved my day.
iraebrasil
 
Posts: 2
Joined: 10. Sep 2009, 17:25
Primary OS: Mac OS X Leopard
VBox Version: OSE other
Guest OSses: Windows XP, CentOS


Return to VirtualBox on Linux Hosts

Who is online

Users browsing this forum: No registered users and 10 guests