HWACCM: AMD-V features= 0 , opteron 2210

Discussions related to using VirtualBox on Linux hosts.

HWACCM: AMD-V features= 0 , opteron 2210

Postby tomwardathome » 19. Aug 2009, 21:33

I am have tried VirtualBox 3.02 and 3.04 on Ubuntu 64 bit 9.04 and 9.10 (alpha)
with all combinations I get the following output in the log file (and no hardware virtualisation)

00:00:04.066 HWACMM: AMD cpu with erratum 170 family f model 41 stepping 2
00:00:04.066 HWACMM: cpuid 0x80000001.u32AMDFeatureECX = 1f
00:00:04.066 HWACMM: cpuid 0x80000001.u32AMDFeatureEDX = ebd3fbff
00:00:04.066 HWACCM: AMD-V revision = 1
00:00:04.066 HWACCM: AMD-V max ASID = 64
00:00:04.066 HWACCM: AMD-V features = 0

It is strange that virtualbox is unable to use the svm becasue it is picking up the SVM support of the CPU (AMD opteron 2210), see below extract from same log file.

00:00:03.474 SVM - AMD VM Extensions = 0 (1)

kvm with kvm_amd works fine on this machine, it runs XP at near native speed and turning off hardware support slows it to a crawl - about the same speed as virtualbox manages.

I have an Intel based laptop running almost the same setup and I am happy to say that virtualbox is working very well on that machine (with hardware support).


thanks for any help

Tom
tomwardathome
 
Posts: 2
Joined: 19. Aug 2009, 21:20
Primary OS: Ubuntu other
VBox Version: PUEL
Guest OSses: XP

Re: HWACCM: AMD-V features= 0 , opteron 2210

Postby Sasquatch » 19. Aug 2009, 23:20

Is the VT-x/AMD-V option available for you in the VM settings? Did you enable it in your BIOS?
Read the Forum Posting Guide before opening a topic.
VirtualBox FAQ: Check this before asking questions.
Online User Manual: A must read if you want to know what we're talking about.
Howto: Install Linux Guest Additions
Howto: Use Shared Folders on Linux Guest
See the Tutorials and FAQ section at the top of the Forum for more guides.
Try searching the forums first with Google and add the site filter for this forum.
E.g. install guest additions site:forums.virtualbox.org

Retired from this Forum since OSSO introduction.
Sasquatch
Volunteer
 
Posts: 17800
Joined: 17. Mar 2008, 13:41
Location: /dev/random
Primary OS: Debian other
VBox Version: PUEL
Guest OSses: Windows XP, Windows 7, Linux

Re: HWACCM: AMD-V features= 0 , opteron 2210

Postby tomwardathome » 20. Aug 2009, 17:09

thansk for the suggestion Sasquatch

yes SVM is enabled in the BIOS, KVM and VMWARE can use it and in fact virtualbox does see it, see below
00:00:03.474 SVM - AMD VM Extensions = 0 (1)
but 'sfor some reason it fails Virtualbox's tests for HVM so it doesn't use it and returns 0

HWACCM: AMD-V features = 0

for HVM to work with SVM I believe it should return F, I had a brief look though the code from svn but I'm afraid it was too difficult for me to work out what test the CPU is failing.

I do know that ASUS have a poor reputation for BIOS so it may be some quirk of the BIOS, I haven't noticed any other opteron users complaining about this and there must be quite a few running virtualbox on opterons, I guess they all use Tyan boards....

regards,

Tom
tomwardathome
 
Posts: 2
Joined: 19. Aug 2009, 21:20
Primary OS: Ubuntu other
VBox Version: PUEL
Guest OSses: XP


Return to VirtualBox on Linux Hosts

Who is online

Users browsing this forum: dpai and 21 guests