Your CPU doesn't support long mode. CentOS x86_64

Discussions related to using VirtualBox on Linux hosts.

Your CPU doesn't support long mode. CentOS x86_64

Postby rwyland@ps » 28. May 2009, 19:35

Host: RHEL 5.3 x86_64
Guest: centOS 5.3 x86_64
VirtualBox 2.2.2


When I try to start up the virtual machine I made, it loads the installer and then says:
"Your CPU does not support long mode. Use a 32bit distribution."
which is odd since I'm running a 64 bit redhat distribution which is very similar to the 64 bit centOS I'm trying to run.

I went into BIOS and turned on VT and also turned it on for the checkbox in the settings, still get the same error.

Any help would be much appreciated. Thanks ahead of time.
~RW
rwyland@ps
 
Posts: 4
Joined: 28. May 2009, 19:21
Primary OS: Linux other
VBox Version: OSE other
Guest OSses: centOS_x86_64

Re: Your CPU doesn't support long mode. CentOS x86_64

Postby Perryg » 28. May 2009, 20:07

What is the make and model of the PC and also the Make, model number of the processor?
Perryg
Site Moderator
 
Posts: 25942
Joined: 6. Sep 2008, 22:55
Primary OS: Linux other
VBox Version: OSE self-compiled
Guest OSses: *NIX - Other

Re: Your CPU doesn't support long mode. CentOS x86_64

Postby rwyland@ps » 28. May 2009, 20:15

Thanks for the reply:

Dell OptiPlex 760
with a Intel Pentium Dual CPU E2200 @ 2.20 GHz
rwyland@ps
 
Posts: 4
Joined: 28. May 2009, 19:21
Primary OS: Linux other
VBox Version: OSE other
Guest OSses: centOS_x86_64

Re: Your CPU doesn't support long mode. CentOS x86_64

Postby Perryg » 28. May 2009, 20:35

As much as I hate to say this you might need to contact Dell support and ask them what the deal is. You can also search for the Intel chip tool and see that it does in fact support Hardware V, as well as vmware tool to test you machine. Sorry I do not have those links in front of me at the moment, but I found them before googling for it.
Perryg
Site Moderator
 
Posts: 25942
Joined: 6. Sep 2008, 22:55
Primary OS: Linux other
VBox Version: OSE self-compiled
Guest OSses: *NIX - Other

Re: Your CPU doesn't support long mode. CentOS x86_64

Postby rwyland@ps » 28. May 2009, 21:19

That would be misleading if the OptiPlex BIOS menu gave VT enabling options when the processor doesn't even support it.
However, after digging around I found something interesting.
With the virtual machine running, I went to: Machine > Session Information Dialog : and noticed something interesting.

The Details tab lists VT-x/AMD-V as enabled however the Runtime tab says the Runtime Attributes for VT-x/AMD-V is disabled.
Perhaps there is some sort of file somewhere that I could go change to force enable it at runtime?
Maybe there is a small bug where the advanced settings are not getting saved properly?

~RW
rwyland@ps
 
Posts: 4
Joined: 28. May 2009, 19:21
Primary OS: Linux other
VBox Version: OSE other
Guest OSses: centOS_x86_64

Re: Your CPU doesn't support long mode. CentOS x86_64

Postby Perryg » 28. May 2009, 21:40

Maybe but you would not be the first nor the last to have been mislead by a manufacture. The run time is telling you that it can not see it. Not only does the BIOS need to support it and the processor but the main board chip set has to as well. I have worked on this issue numerous times and they have all but a very few been because the hardware did not fully support the process. As I say the only way to be sure is to contact the manufacture and find out. The last person that did found that HP disabled it on purpose and would not turn it on for him. I am in the exact same boat. Mine was supposed to support 64 bit but they do not tell me that it does not support Hardware Virtualization.
Perryg
Site Moderator
 
Posts: 25942
Joined: 6. Sep 2008, 22:55
Primary OS: Linux other
VBox Version: OSE self-compiled
Guest OSses: *NIX - Other

Re: Your CPU doesn't support long mode. CentOS x86_64

Postby fixedwheel » 28. May 2009, 21:49

Code: Select all   Expand viewCollapse view
cat /proc/cpuinfo|grep vmx


That would be misleading if the OptiPlex BIOS menu gave VT enabling options when the processor doesn't even support it.

maybe you can buy this machine also with another, VT-x capable CPU?
fixedwheel
Volunteer
 
Posts: 1699
Joined: 13. Sep 2008, 02:18

Re: Your CPU doesn't support long mode. CentOS x86_64

Postby rwyland@ps » 28. May 2009, 22:33

It's confirmed, this CPU does not support it.
I'm in the process of setting up a dualboot now :)

Thanks guys.
~RW
rwyland@ps
 
Posts: 4
Joined: 28. May 2009, 19:21
Primary OS: Linux other
VBox Version: OSE other
Guest OSses: centOS_x86_64

Re: Your CPU doesn't support long mode. CentOS x86_64

Postby Sasquatch » 28. May 2009, 23:13

As for why the VM settings show it as enabled, check the change logs from a version back or so. It's now enabled by default, VT-x/AMD-v capable or not. Both my systems aren't capable of it (laptop CPU does, but mainboard doesn't), and it's still enabled when I create a new VM. I already addressed this, that there should be a check when creating a VM and only enable it if the CPU really does support it. A dev assured me that there is a check, but it obviously fails.
Read the Forum Posting Guide before opening a topic.
VirtualBox FAQ: Check this before asking questions.
Online User Manual: A must read if you want to know what we're talking about.
Howto: Install Linux Guest Additions
Howto: Use Shared Folders on Linux Guest
See the Tutorials and FAQ section at the top of the Forum for more guides.
Try searching the forums first with Google and add the site filter for this forum.
E.g. install guest additions site:forums.virtualbox.org

Retired from this Forum since OSSO introduction.
Sasquatch
Volunteer
 
Posts: 17800
Joined: 17. Mar 2008, 13:41
Location: /dev/random
Primary OS: Debian other
VBox Version: PUEL
Guest OSses: Windows XP, Windows 7, Linux

Re: Your CPU doesn't support long mode. CentOS x86_64

Postby nv128334 » 2. Oct 2009, 09:25

It is very strange. I am running latest Virtual Box 3.0.6 on MacOS.

Guest RHEL 5.3 x86_64 - works fine

Guest CentOS 5.3 x86_64 - gives this error.

Is CentOS is simply using RHEL source !!!!! :( :wink:
nv128334
 
Posts: 3
Joined: 24. Jul 2008, 07:43


Return to VirtualBox on Linux Hosts

Who is online

Users browsing this forum: No registered users and 13 guests